Architect: Locale settings - Swedish with American English language

#1

The one thing that really irritates me with Architect is that we’re right back in basics, where I, who is Swedish but want my desktop in English, has to write in those 9(?) lines manually to get everything but the language in Swedish (Metric system, the date in the right order etc). A lot of distros (and Windows) have the setting sv_EN because of this, because it is common enough that a lot of people do it. Arch, and therefore Manjaro, does not. However the Calamari Installer happily sets all locale options to Swedish except the language of you pick Language English, timezone Stockholm. It just does it automatically.

Is there ANY way to get the CLI based installer to do the same?

0 Likes

Locale issue with XFCE
#2

Check the locale settings you want from a system installed with calamares, post them and we can add them to manjaro-architect?

Personally I would not use a finnish locale because it makes terminal usage so much harder, but I understand the appeal. I don’t have time to do the necessary research for this, but if someone provides me with the data I’m happy to add the option.

0 Likes

#3

I always install Lang: en_US and time zone Europe - Stockholm.
That gives me everything but the language in Swedish standard, aka meters, centigrades, , instead of . in numbers (we write 3,4 not 3.4) the date as YYYY-MM-DD etc etc.

I noticed for example Suse and Windows having a setting in their net installer that specifies that that is I guess unofficial: se_EN which don’t come up as an option in Arch based CLI installs.

0 Likes

#4

Having a similar problem here in Iceland. Tried setting up cinnamon DE from architect but got menus (some items) in icelandic. Nothing I did changed it to english. In the end I gave up and dl the ISO for cinnamon :frowning:

p.s. there seems to be a problem with architect partition settings, when choosing ‘automatic’ one would asume that the setup program would do things right but the ‘root’ partiton is always to small for the install!

1 Like

#5

Please specify further. It should make 2 partitions: 512Mb for /boot/efi and allocate the rest for the root. Does it do something else instead?

0 Likes

#6

Could either of you you post the output of locale in the desired environment?

0 Likes

#7

It did allocate 512Mb for /boot/ and rest for root. I ran the installer several times and did not mess with the partitions set-up. It wasn’t untill I choose one of the command line utilities to delete the /root partition and have everything in just one partition that the installer had enough space to install everything and run to the end of the setup process.

0 Likes

#8

Sorry, no. I gave up and used the cinnamon ISO and there were no problems there. Note: This has happened before, I just thought the problem had been fixed.

0 Likes

#9

I meant: can you run that command on a system installed with the cinnamon iso and post the output, so that I know how it looks on that kind of system?

0 Likes

#10
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC=is_IS.UTF-8
LC_TIME=is_IS.UTF-8
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY=is_IS.UTF-8
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER=is_IS.UTF-8
LC_NAME=is_IS.UTF-8
LC_ADDRESS=is_IS.UTF-8
LC_TELEPHONE=is_IS.UTF-8
LC_MEASUREMENT=is_IS.UTF-8
LC_IDENTIFICATION=is_IS.UTF-8
LC_ALL=
2 Likes

#11

Thank you, this will be useful!

2 Likes

#12

Same problem here. Live in Belgium but want to install in english.

LANG=en_US.UTF-8
LC_CTYPE=“en_US.UTF-8”
LC_NUMERIC=fr_BE.UTF-8
LC_TIME=fr_BE.UTF-8
LC_COLLATE=“en_US.UTF-8”
LC_MONETARY=fr_BE.UTF-8
LC_MESSAGES=“en_US.UTF-8”
LC_PAPER=fr_BE.UTF-8
LC_NAME=fr_BE.UTF-8
LC_ADDRESS=fr_BE.UTF-8
LC_TELEPHONE=fr_BE.UTF-8
LC_MEASUREMENT=fr_BE.UTF-8
LC_IDENTIFICATION=fr_BE.UTF-8
LC_ALL=

3 Likes

closed #13

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

0 Likes