arch-deepin

arch-deepin - archlinux with deepin desktop with installer

Notes for this Build:

  • Live Account (try before you install)
  • Easy to use CLI Installer
  • Linux Kernel: latest
  • Uses Approx 8GB of hard drive space after install
  • Works in a virtual machine and on Hardware (hardware recommended)
  • Option to create a swapfile (recommended)
  • 450MB at first boot (approx)
  • deepin-wm

DEEPIN EXTRA:

  1. deepin-boot-maker 2) deepin-calculator 3) deepin-clone
    4) deepin-community-wallpapers 5) deepin-draw 6) deepin-editor 7) deepin-movie
    8) deepin-music 9) deepin-picker 10) deepin-screen-recorder
    11) deepin-screensaver-pp 12) deepin-screenshot 13) deepin-terminal
    14) deepin-voice-recorder

First Boot:

  1. Start the installer on desktop
  2. Go through the install process in order
  3. After install, Close installer & Reboot

After install:

  1. Update your mirrorlist [tutorial]
  2. In a terminal do a sudo pacman -Syy then update with sudo pacman -Syu
  3. Use like any other arch install

Added software:

  • linux-headers
  • gedit
  • gnome-disk-utility
  • terminus-font
  • ttf-hannom (Fixes Chinese and Vietnamese fonts in browser)
  • gparted
  • custom wallpaper (by antechdesigns)
  • dconf-editor

Download archdeepin

More Info

6 Likes

Due to the popular demand I was getting for arch-deepin, despite the amount of bugs, I decided to release an updated ISO.

Anybody that uses arch-deepin I urge you to please report any bugs you find, this is the only way I know that might make a difference:

Also any developers out there that can help with bug fixes etc, please visit:

Thanks for caving in to the masses. :wink:

I downloaded it and ran it in a VM.
No luck. Tried several options and it's always stuck at the same spot (picture below).
I'm also going to post a shot of my VM settings. I'm very new to running VMs so I'm probably doing something wrong. Typical of me. :upside_down_face:


Yes, I spelled deepin in the .vdi file wrong. /sigh

Display needs to be set to VBoxVGA

That was the first option I chose when I made the VM.
Which made me try others.

Hmm, I'm just going to remake the VM. Maybe that has bad mojo or something. :wink:

Thank you @ant

Also You only need to add the iso, under 'Storage'. no need to rename anything...

Yeah, I had that all setup. When I created the space for the VM I mistyped naming the .vdi. Archdeepon. :smirk:

I'm remaking the VM now.

Thanks for your patience. I have no idea what the issue was. I obviously had something incorrectly set.

Anyway, new VM.

Beautiful. :smiling_face_with_three_hearts:

1 Like

No Problem :wink:

Yes it is, real shame about the silly little bugs though :frowning:

1 Like

It is. It really is an excellent DE.
I had the Deepin ISO installed for a while and while not as bad in my experience as the issues in Manjaro, even their own Distro was proving more and more buggy for me. I finally just removed the VM. I wish I had the know-how to offer even a little help to them. But I'm just a beginner, so.... :woman_shrugging:
Thank you for your efforts and sticking your hand back in the hornets nest so to speak. :wink:

well reporting bugs has been futile, they admit they need more experienced developers to fix the issues.

hopefully someone will install it and realize they know how to fix a certain bug, its a long shot but it just might work :wink:

I tried to install arch-deepon on this new gigabyte pcie nvme but the installer couldnt see the nvme so I tried manjaro cinnamon with calamares installer no problem worked fine

Does arch-deepin use the same installer as Ant's deep-plasma? It appears that installer has problems with nvme drives?

BTW OT: Manjaro Cinnamon is surprisingly great. Pretty, rock solid, feature-packed, and with its recent upgrades (Cinnamon 4.2) actually a fast and snappy performer.

yes same installer it doesnt even see the drive so thats a no go for nvme and yes cinnamon is ok except the keyring is rather annoying and I couldnt download opera browser so I have gone to kde

Yup, exactly the same problem many of us have been having with deep-plasma preventing us from installing that :frowning:

ok thanks mate sorry we cant test on nvme I wonder if ant knows about this

I believe he's aware but doesn't have an nvme drive to test if I remember correctly and I think he said others have been successful, so he wasn't sure what this particular issue is...

Stupid question: The Manjaro installer sometimes won't install on my nvme drives unless I purposefully unmount the drive first... I wonder if that would help here?

Huh, I've never had a keyring ever come up except when selecting auto login in preferences. Is that what you're using?

ye autologin

Autologin is the only time I've ever had keyword problems. Login each time manually and that should go away....