Arch-Anywhere -> Anarchy Linux :)

The previous “arch-anywhere” arch-based netinstaller distro, has finally moved their name, domain, website, (due to the Arch Linux™ team violation checkers’), over to their new home:
https://anarchy-linux.org/
…wish them all the best.

Nice name, still has Arch in it.
Although, according to the website:

Arch Anywhere is no more due to a potential trademark violation pointed out by the Arch Linux™ team. I have decided to remove the name “Arch” entirely and go in the direction of my own Arch Linux™ based distrobution called Anarchy.

1 Like

Shhh…:shushing_face: So I’m not the only one that noticed lol :wink:

1 Like

Ooh, they have sublime-text in repos! Sweet!

Arch-anywhere was the other choice I considered using as base for manjaro-architect instead of architect

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Continuing from: Arch-Anywhere -> Anarchy Linux :)

https://anarchylinux.org/ no longer works and https://github.com/AnarchyLinux/installer/releases has been archived by the owner. It is now read-only.

https://anarchyinstaller.org/ now should point to https://gitlab.com/anarchyinstaller/installer/-/releases

6 posts were split to a new topic: Should you use an Arch installer?

Is that project in transition? Seems like it went from being an installer to being a distribution and now back to being an installer again.

Short answer
Thanks for reopening the closed thread. I have no inside information.

Genesis of my investigation
Yesterday somebody posted on their IRC channel that the old website seemed down. I replied with the github release page noting that it was archived, but the poster seemed satisfied that the ISOs were available. This morning, I got curious, and did some investigation and the project appears to be moved from github to gitlab, and re-branded as in installer, rather than a distro.

My use of Anarchy
The last time I used it, you actually had to be careful if your goal was to install pure Arch; if you select defaults (generally hitting enter on the TUI menus), you end up with additional repos that seemed to include Anarchy branding, and possibly Anarchy settings. But, after a few tries, I was able to install only Arch repos and packages (plus yay, but I did not notice that until later, when I run my typical pacman-Qm).

More thoughts
Perhaps my use of Anarchy was typical, and almost everybody just wanted pure Arch, so they gave up on their own repos. Or maybe they got tired of maintaining them. FWIW, Distrowatch considers them a distro. And, while I found it ridiculous that KDE Neon claimed not to be a distro, if Anarchy no longer has their own repos, then, yes, I agree that they are only an installer, not a distro.

3 Likes

About 1+ years ago when I installed a VM using the Arnarchy iso, the installer gave you options as to whether you wanted to add their own small repo or keep it to solely Arch repos.

A few weeks ago I did a real metal install of Anarchy using the latest iso, due to this problem:
https://forum.manjaro.org/t/seeking-problem-solving-help-with-my-ex-apricity-arch-repo-partition/141125

and there is no longer a choice to add additional repos. The only repos are Arch ones (I checked after installation).

However, so longer as you choose a desktop environment as part of your installation using their installer, you will get a DE that is pre-configured and themed the way they want it. Thus, when I chose Gnome, the installation came preconfigured with Arc-Dark theme and lightdm display manager.

Also, they add their own collection of Anarchy-related wallpapers into /usr/share/backgrounds as part of the installation, same as how ant added his wallpapers to his Archdeepin iso in the past. No additional repo is added, so I assume the wallpapers are found on the iso already.

As for why I installed Anarchy, it was to take over from my former Apricity install, which just died after 4.5 years of problem-free use, as I'd explained in my link above. It was about getting an Arch-repo-based Gnome install up and running without too much thinking, and then copying over all the config and other files from the /home of my Apricity partition.

The Anarchy iso/installer worked well for me for that purpose.

2 Likes

So, all this made me want to re-test.
Tried to get the ISO from SourceForge website (kept failing), so:

$ wget https://sourceforge.net/projects/anarchyinstaller/files/latest/download

At least wget re-tries nicely.

$ mv download anarchyinstaller.iso

Start VMWare Player, pointing it to the ISO
Update the installer (just in case) anarchy -u
Check the version: 1.2.1

Start the installer, taking defaults other than keyboard, region, timezone, etc., until (and these are key if you don't really want any Anarchy customizations):

  • Select Anarchy-Advanced (not the default Anarchy-Desktop).
  • Select Clean Desktop Environments (in my case KDE Plasma, with SDDM)

Power off the system
Remove the ISO from VMWare Player.

Restart the VM. Result:

  • Unthemed SDDM
  • Upstream KDE-themed Plasma (no Anarchy wallpapers).
  • No yay
1 Like

Anarchy installer is currently rewritten and will be a pure arch installer without any third party tool from AUR.

I wonder how long customized anarchy session will stay alive.

Lovely. I really liked apricity os. Especially the gnome edition. Unfortunately I've been too late into arch based distros to get it.
Thinking of recreating it with either manjaro gnome or vanilla arch, maybe even with the anarchy installer like you did.
It was really one of the most beautiful and special distros out there.

I don't think yay was in default Anarchy Desktop either.

Forum kindly sponsored by