Apps shows as open on main monitor but not on secondary

If Firefox is open and there is a little dot below the Firefox icon in the doc. But on my second monitor there is no dot below Firefox. The Firefox window is on my main monitor. If I switch the Firefox window over to the secondary monitor, the dot appears below Firefox on the secondary monitor doc and disappears on them main monitor. Is there an option I missed or is this a bug?

I use GNOME 41.2 with X11 and latest NVIDIA Drivers (Stable Branch).

I’m no expert on GNOME, but that sounds like the normal behavior to me. The dot below the icon in the dock is showing the application as either being minimized or running but without that it is the active window.

There might be configuration option for changing that behavior ─ there is in Plasma, where this is very easy ─ but if there is, then you’ll have to find it yourself, unless someone experienced in GNOME comes along and tells you how to do it. :stuck_out_tongue:

This should solve the issue. I just noticed it as well. Go to Extensions then Dash to Dock. On the Launchers tab under “Show running applications” there is a check mark for “Isolate monitors”. Uncheck it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.