Apps Locking Up

I’m coming from Mint Cinnamon, and noticing things are quite a bit more prone to locking up. I’m not sure if it’s KDE or what. It’s not a new laptop (2019-ish?) but should be able to handle a few web browser windows I think. Here is inxi -Fza output:

  Kernel: 5.19.7-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.19-x86_64
    root=UUID=b9fe7de1-0542-4c82-92b6-0832366a9f4e rw quiet
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 13 9370 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0H0VG3 v: A00 serial: <superuser required>
    UEFI-[Legacy]: Dell v: 1.13.1 date: 07/08/2020
  ID-1: BAT0 charge: 22.5 Wh (100.0%) condition: 22.5/52.0 Wh (43.2%)
    volts: 8.5 min: 7.6 model: LGC-LGC6.73 DELL H754V type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 built: 2017 process: Intel 14nm family: 6
    model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1550 high: 2000 min/max: 400/4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2000 2: 2000 3: 2000
    4: 2000 5: 2000 6: 800 7: 800 8: 800 bogomips: 32012
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: DP-5,DP-6
    off: eDP-1 empty: DP-1,DP-2,DP-7 bus-ID: 00:02.0 chip-ID: 8086:5917
    class-ID: 0300
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-5:2 chip-ID: 0bda:58f4 class-ID: 0e02 serial: <filter>
  Device-3: Microsoft LifeCam Cinema type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 3-1.1:3 chip-ID: 045e:075d
    class-ID: 0102
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: not-matched mapped: DP-2-1 pos: primary,left res: 1920x1080
    hz: 60 dpi: 93 size: 527x296mm (20.75x11.65") diag: 604mm (23.8")
    modes: N/A
  Monitor-2: not-matched mapped: DP-2-2 pos: right res: 1920x1080 hz: 60
    dpi: 93 size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  Monitor-3: eDP-1 note: disabled model: Sharp 0x1484 built: 2017
    res: 1920x1080 dpi: 166 gamma: 1.2 size: 294x165mm (11.57x6.5")
    diag: 337mm (13.3") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa
    22.1.7 direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell
    driver: snd_hda_intel bus-ID: 3-1.1:3 v: kernel chip-ID: 045e:075d
    alternate: snd_soc_skl,snd_soc_avs class-ID: 0102 bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Device-2: Microsoft LifeCam Cinema type: USB
    driver: snd-usb-audio,uvcvideo
  Device-3: Plantronics Plantronics D100 type: USB
    driver: plantronics,snd-usb-audio,usbhid bus-ID: 3-1.3:4 chip-ID: 047f:ab01
    class-ID: 0300
  Device-4: Realtek USB Audio type: USB driver: snd-usb-audio
    bus-ID: 3-1.5:5 chip-ID: 0bda:4014 class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.19.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Rivet Networks Killer 1435 Wireless-AC driver: ath10k_pci v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:003e
    class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 4-1.2:3 chip-ID: 0bda:8153 class-ID: 0000
    serial: <filter>
  IF: enp63s0u1u2 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-1: Foxconn / Hon Hai type: USB driver: btusb v: 0.8 bus-ID: 1-7:3
    chip-ID: 0489:e0a2 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 98.3 GiB (20.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM981 NVMe 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: EXA73D1Q
    temp: 49.9 C scheme: MBR
  ID-1: / raw-size: 476.93 GiB size: 468.38 GiB (98.21%) used: 98.3 GiB
    (21.0%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 54.0 C pch: 45.0 C mobo: 43.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 4795
  Processes: 295 Uptime: 3d 20h 11m wakeups: 117 Memory: 7.2 GiB used: 6.73
  GiB (93.4%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1628
  libs: 394 tools: pamac,yay pm: flatpak pkgs: 0 Shell: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.21

Hi @craigbass76, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.


I see you have Plasma 5.25 installed, which is full of problems. Personally I think that might be/is the reason. And no, sadly I don’t know if there is anything to be done about it.

I see no swap and then I see this:

I think this might be your problem. You should probably create a swap file or consider reinstalling with a swap partition.


Hah – I was discovering the forum accepted markdown and facepalming as you were typing I think…

I’ll throw XFCE or something on then, and try it. I’m not attached to KDE necessarily (last used it Fedora 4 or so), but I always really liked Konquest…

This was happening a little bit in Mint, but only when I’d have way too much stuff going at once – Windows in Virtual box, Accuradio in a browser, etc…

1 Like

I wondered about this during install, and why I wasn’t prompted to create one. Do I need to reinstall, or can I just do it all from a live iso?

If you’re going to install it with Xfce or something, you might just do it then.

I’ve had the option to create swap, and I did. So I know it’s there in installation. Although, AFAIK you can do it from your machine as well. See:


Otherwise, there’s also the Lxqt Community edition by @Jim.B, which AFAIK is rather lightweight, so more resouce-friendly than Plasma:


You can create a swap file at any time.

First, create a 4GB slab of zeros (or 2G, or 1G, depends on your preference) directly in the root filesystem of your NVMe:

sudo dd if=/dev/zero of=/swapfile bs=1M count=4096

Then make it root-only read-write permission:

sudo chmod 600 /swapfile

Then convert it to a swap file:

sudo mkswap /swapfile

Then activate it (only needs to be done once, since you’ll add an fstab entry:

sudo swapon /swapfile

Then add this entry to your /etc/fstab:

/swapfile      swap      swap      defaults      0      0


Your root filesystem is located on an NVMe drive, so at least when your system places data into swap, it will be seated on a fast device, unlike a traditional spinning HDD. However, you should still address the core issues: (1) “Why is my system using so much RAM on a fresh install?” and (2) “I need to add more RAM.”

With Chromium open as I write this post on KDE, my system is using 1.3 GB of RAM.