Applications not recognizing soundcard correctly


#1

Hi.
I use Manjaro KDE up-to-date. Audio always worked nice until recent months.
First, Polyphone (built from AUR) stopped to output sound.
Then, after some weeks the same happened to Audacity.
Looking at configurations I noticed that both in KDE and Pulseaudio configurations I have available hw:0,0 as analog output and hw:0,1 as digital output. Only when I choose hw:0,0 analog output I get any sound from any application. If choose hw:0,1 digital output I get no sound at all.
But in Polyphone’s and Audacity’s configurations both of them no longer recognize the existence of hw:0,0 in my system. In their configurations only hw:0,1 is available. However, if I go to my user audio settings and choose hw:0,1, Audacity and Polyphone make hw:0,0 available in their configurations again. But that’s useless since when my system is configured to hw:0,1 it has no sound output.

Now, comes a temporary workaround: I kill pulseaudio, start jack and open Qjackctl. (If I try to start jack with pulseaudio running or even with pasuspender parameter I get that annoying messages: Jack could not be started.)
Then Audacity and Polyphone are able to connect to jack and I have sound output from both.
But that creates another issue. After I close jack (even if I kill all jack related processes) I get no more sound. I tried to kill all jack processes and then use pulseaudio --start and/or pulseaudio -D but I had no sound from any application.
The only way to got sound back was to reboot the computer.

Can you help me to:
1 - Solve the issue of Audacity and Polyphone not recognizing hw:0,0 analog output?
2 - Get sound back after using and closing jack?

Thanks.

(PS: I had the same issue logged in XFCE. Then, probably, it’s not related to DE.)


#2

set apps to direct to pulse audio, set pulseaudio to your sound card disable what card you do not need in pulseaudio, in terminal type alsamixer press f6 choose your soundcard, make sure the levels are correct, and nothing you use is muted mm if it is press help follow the directions. exit reboot.


#3

Thank you for trying to help but unfortunately none of your suggestions worked.
Neither in KDE nor in Pulseaudio nor in Alsamixer I have any control that allows me to disable hw:0,1. Indeed the only soundcard I have only one soundcard that is built-in in my motherboard and its output is through the physical jack (probably analog).

As for the second issue: Running LADI player automatically suspends pulseaudio and runs jack. But after I close it I remain without sound output until I reboot the PC.

Here’s the output of commands about my audio config:

$ aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog]
 Subdevices: 0/1
 Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: ALC887-VD Digital [ALC887-VD Digital]
 Subdevices: 1/1
 Subdevice #0: subdevice #0

aplay -L
null
   Discard all samples (playback) or generate zero samples (capture)
jack
   JACK Audio Connection Kit
pulse
   PulseAudio Sound Server
default
   Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=Generic
   HD-Audio Generic, ALC887-VD Analog
   Default Audio Device
front:CARD=Generic,DEV=0
   HD-Audio Generic, ALC887-VD Analog
   Front speakers
surround21:CARD=Generic,DEV=0
   HD-Audio Generic, ALC887-VD Analog
   2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=Generic,DEV=0
   HD-Audio Generic, ALC887-VD Analog
   4.0 Surround output to Front and Rear speakers
surround41:CARD=Generic,DEV=0
   HD-Audio Generic, ALC887-VD Analog
   4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Generic,DEV=0
   HD-Audio Generic, ALC887-VD Analog
   5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Generic,DEV=0
   HD-Audio Generic, ALC887-VD Analog
   5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Generic,DEV=0
   HD-Audio Generic, ALC887-VD Analog
   7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Generic,DEV=0
   HD-Audio Generic, ALC887-VD Digital
   IEC958 (S/PDIF) Digital Audio Output
usbstream:CARD=Generic
   HD-Audio Generic
   USB Stream Output

inxi -F
System:    Host: fernando-pc Kernel: 4.19.2-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.14.3 Distro: Manjaro Linux  
Machine:   Type: Desktop System: Gigabyte product: N/A v: N/A serial: <root required>  
          Mobo: Gigabyte model: F2A55M-S1 v: x.x serial: <root required> BIOS: American Megatrends v: FC date: 01/10/2014  
CPU:       Topology: Quad Core model: AMD A10-7850K Radeon R7 12 Compute Cores 4C+8G bits: 64 type: MCP L2 cache: 2048 KiB  
          Speed: 1696 MHz min/max: 1700/3700 MHz Core speeds (MHz): 1: 1752 2: 1827 3: 1869 4: 2234  
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics] driver: radeon v: kernel  
          Display: x11 server: X.Org 1.20.3 driver: radeon resolution: 1360x768~60Hz  
          OpenGL: renderer: AMD KAVERI (DRM 2.50.0 4.19.2-1-MANJARO LLVM 7.0.0) v: 4.5 Mesa 18.2.5  
Audio:     Device-1: Advanced Micro Devices [AMD] FCH Azalia driver: snd_hda_intel  
          Sound Server: ALSA v: k4.19.2-1-MANJARO  
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168  
          IF: enp1s0 state: up speed: 100 Mbps duplex: half mac: 94:de:80:f7:1b:90  
Drives:    Local Storage: total: 530.98 GiB used: 212.94 GiB (40.1%)  
          ID-1: /dev/sda vendor: Samsung model: HD322HJ size: 298.09 GiB  
          ID-2: /dev/sdb vendor: Western Digital model: WD2500BPVT-22ZEST0 size: 232.89 GiB  
Partition: ID-1: / size: 39.12 GiB used: 21.04 GiB (53.8%) fs: ext4 dev: /dev/sda7  
          ID-2: /home size: 133.45 GiB used: 37.50 GiB (28.1%) fs: ext4 dev: /dev/sda6  
          ID-3: swap-1 size: 2.01 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5  
Sensors:   System Temperatures: cpu: 3.9 C mobo: N/A gpu: radeon temp: 4 C  
          Fan Speeds (RPM): N/A  
Info:      Processes: 173 Uptime: 12m Memory: 6.75 GiB used: 941.4 MiB (13.6%) Shell: bash inxi: 3.0.27


#4

maybe related to:


#5

Thank you. That’s exactly my issue.


#6

About using jack: Does anyone know how to have sound back, without rebooting, after running jack?
Edit: I started jack using LADI Player. Just ran it and pressed play. Before close ladi I pressed the stop button and then unload studio button. After I closed ladi my sound was back.
Then we have 2 workarounds. Routing apps through jack or downgrading alsa as stated in the thread indicated by ara.


#7

This might not solve your problem, but Audacity 2.3.0 has issues. I would try downgrading it, since it’s not stable for linux (and I experienced similar, though not exactly the same problems as you). Also try downgrading alsa-lib 1.1.7 (though you’re using pulseaudio - so prolly not!).


#8

After last Manjaro update, that includes alsalib 1.1.7-2, Audacity has pulse and default options again and sound is working.
Polyphone still has sound broken but I have used it’s windows version under wine and it works as nicely as the AUR vesion.