Applications don't open after being closed on an external monitor on Wayland

Hello, sorry for the long title, but i can’t fit it into something catchy and informative :smiley:

I had just right now this weird issue. I use wayland as my daily driver on my laptop. At work i have an external monitor connected, but at home i don’t.
I usually have Firefox and Thunderbird open on the external monitor. And now i just needed to do something quick there, and wasn’t able to open them.

I tried to open them via terminal to see the error message. Unfortunately i didn’t safe it, but it said something about not being able to connect to something. My guess is, that it tried to open it on the external monitor, which it obviously couldn’t.

The workaround was to switch to X11, open the applications which works fine, and then switch back to Wayland. Now the applications can be opened and get displayed on the normal primary display.

Is this a known bug with wayland, or is there some setting that i have to choose, so that wayland opens the programs on the only display it has, if it doesn’t have the last known place?

Quick inxi output:

inxi --admin --verbosity=7 --filter --no-host --width

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=7e80cf66-70c0-4121-892f-b6b2b6a2f2d7 ro quiet 
  root=/dev/mapper/luks-2f1f276b-9eb0-4569-a04c-ff770d89e352 apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_wayland 
  vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Panasonic product: CF-AX2LDCHCE v: 001 serial: <filter> 
  Chassis: type: 10 v: 001 serial: <filter> 
  Mobo: Panasonic model: CFAX2-1 v: 1 serial: <filter> 
  UEFI: American Megatrends v: 1.50L15 date: 05/17/2018 
  ID-1: BAT1 charge: 12.6 Wh (98.4%) condition: 12.8/29.5 Wh (43.3%) 
  volts: 7.5 min: 7.2 model: Panasonic CF-VZSU81 type: Li-ion serial: <filter> 
  status: Unknown 
  ID-2: BAT2 charge: 8.7 Wh (100.0%) condition: 8.7/14.8 Wh (58.9%) volts: 7.4 
  min: 7.2 model: Panasonic 2-653864-B01 type: Li-ion serial: <filter> 
  status: Unknown 
  RAM: total: 3.71 GiB used: 2.67 GiB (72.0%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5-3427U bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  cache: L2: 3 MiB bogomips: 18366 
  Speed: 1596 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 1596 2: 2017 
  3: 1306 4: 1262 
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov 
  constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept 
  erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs ida 
  lahf_lm lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdrand 
  rdtscp rep_good sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp 
  syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid x2apic 
  xsave xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Matsushita 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300 
  Device-2: Acer USB HD Webcam type: USB driver: uvcvideo bus-ID: 1-1.2:5 
  chip-ID: 5986:0297 class-ID: 0e02 serial: <filter> 
  Display: wayland server: X.Org compositor: kwin_wayland driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :1 
  screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: XWAYLAND0 res: 1366x768 hz: 60 dpi: 155 
  size: 224x126mm (8.8x5.0") diag: 257mm (10.1") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 21.1.6 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Matsushita driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:1e20 class-ID: 0403 
  Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
  Device-1: Intel 82579LM Gigabit Network vendor: Matsushita driver: e1000e 
  v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: f040 bus-ID: 03:00.0 chip-ID: 8086:0082 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: wwp0s26u1u1c2i5 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Alps UGNZH type: USB driver: btusb v: 0.8 bus-ID: 3-1.5:3 
  chip-ID: 044e:301d class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Message: No logical block device data found. 
  Device-1: luks-2f1f276b-9eb0-4569-a04c-ff770d89e352 maj-min: 254:0 
  type: LUKS dm: dm-0 size: 446.83 GiB 
  p-1: sda2 maj-min: 8:2 size: 446.83 GiB 
  Message: No RAID data found. 
  Local Storage: total: 447.13 GiB used: 121.72 GiB (27.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SUV500MS480G 
  size: 447.13 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 56RR scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 446.83 GiB size: 438.82 GiB (98.21%) 
  used: 121.62 GiB (27.7%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-2f1f276b-9eb0-4569-a04c-ff770d89e352 label: N/A 
  uuid: 7e80cf66-70c0-4121-892f-b6b2b6a2f2d7 
  ID-2: /boot raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 111.5 MiB (37.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 6B0E-C817 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 8 GiB used: 26.2 MiB (0.3%) priority: -2 
  file: /swapfile 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 
  Device-1: 1-1.1:6 info: Sierra Wireless MC8305 Modem 
  type: Communication,CDC-Data driver: cdc_mbim interfaces: 2 rev: 2.0 
  speed: 480 Mb/s power: 500mA chip-ID: 1199:9011 class-ID: 0a00 
  Device-2: 1-1.2:5 info: Acer USB HD Webcam type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 256mA chip-ID: 5986:0297 
  class-ID: 0e02 serial: <filter> 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 2-3:2 info: D-WAV Scientific eGalaxTouch EXC7903-02v10 type: Mouse 
  driver: hid-multitouch,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 0eef:7903 class-ID: 0301 
  Device-2: 2-4:3 info: ROHM LSI Systems USA LLC HID Sensor Board DFUP2183ZA 
  type: HID driver: hid-generic,hid-sensor-hub,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s power: 100mA chip-ID: 04b5:0680 class-ID: 0300 
  serial: <filter> 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-5: 3-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 
  Device-1: 3-1.5:3 info: Alps UGNZH type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip-ID: 044e:301d class-ID: e001 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 45.4 C mobo: 45.4 C 
  Fan Speeds (RPM): N/A 
  Processes: 216 Uptime: 20m wakeups: 1 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: pacman: 1385 lib: 415 flatpak: 0 
  Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06 


Right now you can do that again and get the exact error.

This kernel is EOL for long time now, please change it.

There are plenty of things not ready for daily use in wayland …

Yeah, that still works. No problem of using it, and Manjaro can’t do anything about wayland to fix it.

1 Like

Thank you, for your precisely formated answer.

Yeah, i also immediately thought that i need to update my kernel when i saw that :smiley:

I can’t replicate it right now, because i don’t have a compatible external monitor here with me, but i will add the error message next week, if i can replicate it.

X11 is not really a viable choice on my lil laptop anymore, because X11 is very less perfomant than Wayland. Watching 720p60fps with X11? Uh-uh :grimacing:. Watching 720p60fps with Wayland? Yes :blush:.

Besides from that issue, i would definitely argue that Wayland is ready for daily use of most applications.