Application like notify-send.sh doesn't work


#1

I tried multiple applications like notify-send for custom popup notifications but nothing works. I tried notify-desktop-git and toastify-git from aur.

I initially thought this was the package’s fault then toastify prints a message:
$ toastify send "Hello"
"Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

What to do?

I am using i3-gaps wm(originally it is xfce). Is xfce’s default notification shower thingy interfering with this or something?

SOLUTION: Just get dunst or similar notification server runnin in the background.


#2

Is dunst not working for you?

I remember having a similar problem 2 years ago when I was also running i3+xfce. However I don’t remember how I fixed it as I switched to i3+kde - funnily enough presenting the same problem.
Whenever I move from i3 to KDE I have to remove dunst (default notifier in i3), else dunst would also be used by KDE instead of its own notifier.


#3

What a ■■■■■■, it needs dunst running for it to actually work.
I ran dunst in one terminal then tried running notify-send it works now.
Now i need to customize dunstrc or something.


#4

Have you installed any notification server? For instance xfce4-notifyd should do the job.


#5

It works. I just need dunst in background.
Thank you anyway.

The packages should specify that notification servers must be runnin in the background for these to work. They just lazy.


#6

That’s quite obvious isn’t it?


#7

Arch Wiki is your friend. :smiley:


#8

It wasn’t obvious for me. Since they didn’t specify, I thought it works standalone.


#9

Nevermind :slight_smile: your problem is solved or isn’t it?
If yes, please mark the thread as “solved”.