Application launcher freezes; all applications open very slowly first time

I have recently installed manjaro KDE. I have a btrfs partition for root and a separate ext4 partition for /home.

When I reboot and open the application launcher, after typing the first character in the search box, the application launcher freezes. It will eventually ‘unfreeze’ and allow me to enter the rest of the application name to launch.

All applications I launch (by whatever means) open very slowly the first time they are launched. Subsequent launches perform as expected.

1 Like

Well, as far as concerns applications openning slowly after launch the first time, this is quite normal behaviour after every reboot. I’m on KDE Plasma as well…you get used to that(and the slow boot times too :wink:).

thats absolutely not normal … could be related to you using btrfs, which is still not stable enough, or it could be because of the baloo indexer, so open system settings/file search and uncheck all options, click apply, then reboot and see if it helped …

there are no slow boot times unless you are using HDD, this is mine:

systemd-analyze                                                                                                            ─╯
Startup finished in 2.532s (kernel) + 415ms (userspace) = 2.948s reached after 415ms in userspace.

Actually, that’s no doubt quite truthful to a certain extent. I am using a HDD and not an SSD. So, to resume: HDD slower boot times and SSD fricking fast boot times! Of course, other desktops can be quicker booting up from my experience, even with a HDD :smiley:

are you also using btrfs?
boot times over 10s on ssds are not normal and boot times around 15s on hdd are acceptable … what is your boot time:

You must be joking. btrfs is a rock-solid and stable filesystem, and it’s generally faster at reading than ext4 because it uses compression.


Here we go, as concerns my system:

Startup finished in 2.291s (kernel) + 26.429s (userspace) = 28.720s reached after 22.678s in userspace.

your kernel loading is faster than mine … check with:
systemd-analyze blame

1 Like

I appreciate your help :+1:Here’s my output:

systemd-analyze blame
12.053s systemd-journal-flush.service
7.294s dev-sda1.device
6.394s cups.service
5.894s snapd.service
4.100s systemd-udevd.service
3.961s man-db.service
3.866s logrotate.service
2.876s apparmor.service
2.458s polkit.service
2.442s tlp.service
2.075s avahi-daemon.service
2.060s dbus.service
2.034s systemd-logind.service
1.958s ModemManager.service
1.840s udisks2.service
1.204s NetworkManager.service
1.168s snapd.apparmor.service
1.062s systemd-tmpfiles-setup-dev.service
840ms systemd-random-seed.service
636ms upower.service
627ms lvm2-monitor.service
498ms systemd-tmpfiles-setup.service
477ms modprobe@drm.service
455ms colord.service
355ms modprobe@fuse.service
334ms systemd-modules-load.service
330ms systemd-tmpfiles-clean.service
298ms user@1000.service
233ms systemd-udev-trigger.service
219ms systemd-timesyncd.service
216ms systemd-sysctl.service
168ms dev-hugepages.mount
166ms dev-mqueue.mount
lines 1-33

so open this file:
kate /etc/systemd/journald.conf
and edit this line: #SystemMaxUse= to look like this:
SystemMaxUse=25M - the # is removed; save the file, and restart journal:
systemctl restart systemd-journald
then clean the journal:

sudo journalctl --rotate
sudo journalctl -m --vacuum-time=1s

this cups is related to printing, so if you are not using printing, you can uninstall all cups packages except these 2: cups-filters, libcups - they have to many dependencies … or you can disable all cups services from system settings/systemd and check show inactive and show unloaded both in units and user units and search for cups, then right click and stop the service, wait, right click and mask the service

these are related to snapd/apparmor, since you dont have installed any snap, you can uninstall snapd from add/remove software …
for the apparmor, you can uninstall it too, unless you are using samba shares, if you dont want to uninstall them disable them as mentioned above

also avahi services can be disabled, search for them in systemd, and mask them

modem can also be disabled, highly doubt you are using it, the best option would be to disable it in bios if you have that option

another services are audit: audit.service and audit.socket - both can be masked; open ksystemlog and there youll see audit logs, they are not really usefull for any troubleshooting, so you can disable them

Thanks for the useful tips, it’s really cool of you :+1:I’ll take a dive beneath the bonnet of my system sometime today no doubt, or, tomorrow at the very latest, and I’ll let you know how it all pans out :wink:

1 Like

For comparison my top two…

7.972s pamac-mirrorlist.service
6.542s NetworkManager-wait-online.service

And the printer service
75ms cups.service

But for me, snapd is zero because I have no intent to install Ubuntu :slight_smile:

With Journalctl, I added to my ‘clean’ terminal alias recently which leaves the last 3 hours intact.

sudo journalctl --vacuum-time=3h && sudo 
journalctl --flush --rotate

As for BTRFS - I reformatted my oldest HDD last year - it’s (Western Digital WD20EZRX) which looked as if it might die some 4-5 years ago (I think I bought it in 2013, now PoweredOn is 7 years 6 months) archiving some TV and Movies) and have been very happy - I’m not sure if it’s actually quieter, or if that’s my wishful thinking…

So I’ve also reinstalled Manjaro with BTRFS - though I still run Back-in-time to give RSYNC backup copies on HDD as well as using snapshots.