Apparmor is not working


~ >>> apparmor_status
apparmor module is loaded.
apparmor filesystem is not mounted.

~ >>> systemctl status apparmor.service
β—‹ apparmor.service - Load AppArmor profiles
Loaded: loaded (/usr/lib/systemd/system/apparmor.service; enabled; vendor preset: disabled)
Active: inactive (dead)
Condition: start condition failed at Tue 2021-06-22 09:15:34 CEST; 9min ago
└─ ConditionSecurity=apparmor was not me

how to fix this

Hello,

Have checked this??

or tied this ??

add in grub to GRUB_CMDLINE_LINUX_DEFAULT
apparmor=1 security=apparmor
then update grub: sudo update-grub
Restart computer
Then check in terminal:
aa-enabled

Just an idea :slight_smile:

cant figure out how to add or edit grub

Open /etc/default/grub with sudo permissions with nano or vim or vi or what ever is your favorite editor.

Open the terminal

$ export $EDITOR="your favorite editor" 
$ echo $EDITOR                 --> to check that the editor is properly set
$ sudoedit /etc/default/grub   --> it will prompt you for your password write it and hit enter

Now add in the line
GRUB_CMDLINE_LINUX_DEFAULT = " quiet apparmor=1 security=apparmor ..."

Save the file

$ sudo update-grub  --> it will prompt you for your password write it and hit enter

Restart your pc / laptop

:crossed_fingers:

1 Like

Thank you :+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.