Apparently Manjaro is resetting my cable modem many times per day after update.

Hello,

I'm running Manjaro 4.19.36-1 with KDE plasma. Some info:

for dmesg | grep r8169

[   25.799054] r8169 0000:01:00.0: can't disable ASPM; OS doesn't have ASPM control
[   25.802286] libphy: r8169: probed
[   25.802472] r8169 0000:01:00.0 eth0: RTL8105e, b8:88:e3:8f:56:db, XID 40c00000, IRQ 29
[   26.083289] r8169 0000:01:00.0 enp1s0: renamed from eth0
[   39.953962] Generic PHY r8169-100:00: attached PHY driver [Generic PHY] (mii_bus:phy_addr=r8169-100:00, irq=IGNORE)
[   40.222362] r8169 0000:01:00.0 enp1s0: Link is Down
[   41.747937] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[15801.801960] r8169 0000:01:00.0 enp1s0: Link is Down
[15843.348113] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[16090.318980] r8169 0000:01:00.0 enp1s0: Link is Down
[16131.915703] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[16669.259700] r8169 0000:01:00.0 enp1s0: Link is Down
[16960.665660] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[16971.486624] r8169 0000:01:00.0 enp1s0: Link is Down
[16973.122801] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[16973.129353] r8169 0000:01:00.0 enp1s0: Link is Down
[17014.698598] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[17075.018260] r8169 0000:01:00.0 enp1s0: Link is Down
[17116.441559] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[18073.099378] r8169 0000:01:00.0 enp1s0: Link is Down
[18114.569347] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[18211.769372] r8169 0000:01:00.0 enp1s0: Link is Down
[18253.169964] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[18506.374087] r8169 0000:01:00.0 enp1s0: Link is Down
[19556.678800] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[20255.557467] r8169 0000:01:00.0 enp1s0: Link is Down
[20296.899356] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[20593.562565] r8169 0000:01:00.0 enp1s0: Link is Down
[20635.064575] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx
[21145.685342] r8169 0000:01:00.0 enp1s0: Link is Down
[21187.349006] r8169 0000:01:00.0 enp1s0: Link is Up - 100Mbps/Full - flow control rx/tx

for mhwd -lh -d

11: PCI 100.0: 0200 Ethernet controller
  SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: network
  Model: "Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8136 "RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x3977 
  Revision: 0x05
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: enp1s0
  I/O Ports: 0x2000-0x20ff (rw)
  Memory Range: 0xd0404000-0xd0404fff (ro,non-prefetchable)
  Memory Range: 0xd0400000-0xd0403fff (ro,non-prefetchable)
  IRQ: 16 (580805 events)
  HW Address: b8:88:e3:8f:56:db
  Permanent HW Address: b8:88:e3:8f:56:db
  Link detected: yes
  Module Alias: "pci:v000010ECd00008136sv000017AAsd00003977bc02sc00i00"
  Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Attached to: #7 (PCI bridge)

So I do have a Gigabit ethernet controller, but it seems to keep me around 100 Mbps and starting the service many times over. I've disabled the auto negotiation and set manually to full duplex and over 100Mbps.

So what could be causing this? Is it possible that the OS is resetting the modem? Or it must be a problem with the modem alone?

I have an AUR nordvpn package whose service I disabled completely just for the sake of eliminating possible culprits. Could it be that the package screwed up something in my network manager?

In sum: how to actually force the system to recognize my full gigabit ethernet and prevent the modem from restarting all the time? (as I type this thing restarted again that r8169 created a new link, I get those many times per day)

Set the conection back to auto-negotiation.

Install ethtool:

sudo pacman -S ethtool

Restart.

You need to test different kernels. Have you done that. If so, which ones.

I didn't try any, as I searched here I've found that you usually tell people to blacklist r8168, but I do not even have that one installed so that solution wouldn't work (unless you tell me to try that one, if yes how?)

Also, maybe relevant, but often I get the ethernet icon like this: https://i.imgur.com/EnSaGCK.png

If I set it to auto negotiation, it will make it half-duplex and 100 Mbps, that's what it was doing all along at least, and it restarts the modem all the same.

Do this^^^

Do this^^^

I installed and rebooted as you said, ethtool enp1s0 gives me

Settings for enp1s0:
        Supported ports: [ TP AUI BNC MII FIBRE ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes
You need to test different kernels.

You mean downgrade the system? How do I do that?

I would suggest installing and testing both older and newer kernels. Try at least two or three alternate kernels. Install kernels through Manjaro Settings Manager, and always have at least two kernels installed at all times for safety.

How to switch kernels:

When you reboot if you do not see the grub boot screen press and hold down the ESC, SHIFT or F8 key. This should show the GRUB boot menu if it doesn't appear. As soon as you see the grub boot screen, press the down arrow. Select the "advanced" menu from the choices and press enter. In the next menu you can select the different kernels you have installed to boot from. Select the regular kernel you wish boot into (not the fallback), and then press enter to complete the kernel change.

Ok I'm downloading 4.14.113-1, what is the "real time" thing? Should I also try this?

No need.

How old is this computer. Is there a bios update available, or are you using most recent bios.

Please post:

inxi -Fxxxz

How old is your router. Have you considered the router could be failing, or overheating. Have you rebooted the router.

Have you tried a different cable yet.

Have you tried a different port on the router.

Disable IPv6 in your router and (or) in Network Manager.

Is there a firmware update available for your router.

Can you test another router for comparison.

Ok, so the boot was waay faster but opening firefox made everything freeze, I got frozen for some good 7 minutes. Is it really safe to use other kernels like this?

Regarding ethernet, I got this:

~$ dmesg | grep r8169
[   13.598988] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   13.598996] r8169 0000:01:00.0: can't disable ASPM; OS doesn't have ASPM control
[   13.599348] r8169 0000:01:00.0 eth0: RTL8105e at 0xffffb68141041000, b8:88:e3:8f:56:db, XID 00c00000 IRQ 29
[   14.014098] r8169 0000:01:00.0 enp1s0: renamed from eth0
[   25.598605] r8169 0000:01:00.0 enp1s0: link down
[   25.598606] r8169 0000:01:00.0 enp1s0: link down
[   27.170871] r8169 0000:01:00.0 enp1s0: link up
[   27.177129] r8169 0000:01:00.0 enp1s0: link down
[   28.733248] r8169 0000:01:00.0 enp1s0: link up

inxi -Fxxxz

System:    Host: v3v439bm0-pc Kernel: 4.14.113-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.4 
           tk: Qt 5.12.3 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20210 v: Lenovo IdeaPad P500 serial: <filter> Chassis: type: 10 
           v: Lenovo IdeaPad P500 serial: <filter> 
           Mobo: LENOVO model: INVALID v: 31900003WIN8 STD MLT serial: <filter> UEFI: LENOVO v: 71CN22WW(V1.05) 
           date: 09/14/2012 
Battery:   ID-1: BAT1 charge: 35.5 Wh condition: 35.5/N/A Wh volts: 16.1/14.4 model: LENOVO PABAS0241231 type: Li-ion 
           serial: <filter> status: Full 
CPU:       Topology: Dual Core model: Intel Core i7-3520M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23154 
           Speed: 1239 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 1197 2: 1198 3: 1197 4: 1199 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0166 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.0.3 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:1e20 
           Sound Server: ALSA v: k4.14.113-1-MANJARO 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo driver: r8169 v: 2.3LK-NAPI port: 2000 
           bus ID: 01:00.0 chip ID: 10ec:8136 
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel port: 2000 bus ID: 02:00.0 chip ID: 8086:0888 
           IF: wlp2s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 136.51 GiB (14.7%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB speed: 3.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 0001 scheme: GPT 
Partition: ID-1: / size: 29.16 GiB used: 10.06 GiB (34.5%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 885.41 GiB used: 126.45 GiB (14.3%) fs: ext4 dev: /dev/sda4 
           ID-3: swap-1 size: 1000.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 156 Uptime: 18m Memory: 7.65 GiB used: 918.4 MiB (11.7%) Init: systemd v: 242 Compilers: gcc: 8.3.0 
           clang: 8.0.0 Shell: bash v: 5.0.3 running in: konsole inxi: 3.0.33

Your hardware is older so I would try another older kernel such as 4.9. if that is no better, try a newer kernel like 5.1.

Please answer as many questions as possible that I have asked you.

Yes I've tried a lot of different things and all of those. My cable is the correct standard CAT.5e, I tried another one of the same standard.

Right now I ran a speed test and it peaked 120-ish. How is that possible if the whole system still says I have 100Mbps? It doesn't sustain above 100 tho. The specs of my laptop say it has 10/100/1000 ethernet, but manjaro doesn't recognize the 1000 part.

My ISP technician ran a test in the very same modem and it sustained 120-ish most of the time, it is definitely something in my computer, and my laptop vendor says it has gigabit capability. Lenovo P500 IdeaPad S/N 59347559.

In this kernel firefox is randomly freezing and eats 100% of CPU. Why is this happening? Am I downgraded in everything?

Sorry for delay in answers, my system freezes and I see new questions slowly.

Try installing another kernel.

Run these ethtool commands in the terminal:

sudo ethtool -s enp1s0 speed 1000 autoneg off

Also try this:

ethtool -K enp1s0 tso off gso off

After running those commands, test your speed for improvement.

Have you tried other live boot disks from other distros?

Does the same thing occur from live disks?

If so, this points to a hardware/router issue.

Which kernels have you tested?

Hi thank you for all the help @tbg. I had a hard time with the kernels, mostly I got firefox freezes and none worked for my ethernet, all of them cap it to 100Mbps no matter what, no matter which parameter used.

I'm just curious, why do I need to switch to a whole different kernel just to test a different driver? That seems way overkill, like killing an ant with a bazooka. Why isn't possible to just get the drivers themselves and load different versions of them? That would be way more "mere mortal" friendly.

Kudos.

@tbg one last thing you mentioned I forgot and just did it now. I got a live boot from ubuntu 18.1 I had somewhere. It seems the same occurs. So it must be some linux-wide thing with this particular laptop/ethernet card.

It could be that lenovo has some economy energy savings for the ethernet port which are getting in the way and manjaro got no option, like windows, to disable it? The BIOS options I get are scant. I'd put this solution in the category of miracle right now, next thing I'll burn a win10 iso and try it there with different options. I used 3 different cat5e cables and all the same, 100mbps. Such unimaginable pain in the ** this :frowning: I'm sure the card IS gigabit capable.

I'm having the same issue after updating today, the cable modem doesn't reboot or anything like that but I constantly get notifications about my connection being deactivated and activated back again. Only gets fixed by not using auto-negotation and manually setting it to full or half-duplex instead, then my connection is somewhat usable but still unstable.

My setup: KDE Plasma, r8168 then switched to r8169 with no difference, 4.14 kernel.
Some more relevant info from inxi -Fxxxz

Machine:   Type: Desktop Mobo: MSI model: B250M PRO-VD (MS-7A74) v: 1.0 serial: <filter> UEFI: American Megatrends v: 1.40 
           date: 04/06/2017 

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: 2.3LK-NAPI 
           port: d000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: up speed: 100 Mbps duplex: half mac: <filter> 

I'm dualbooting with W10, no issues there, only on Manjaro after today's update. I will try switching to other kernels later.

E: Tried 4.19 this time, still unsure if it's working well or not. It keeps disconnecting and connecting back again for about 30 seconds before staying connected and working. So it means I have to wait a bit after connecting for the first time. I'll give it a try and see how it goes or if it ends up being unstable.

Often when dealing with network adapters there are no alternate drivers. Many drivers are simply included in the Linux kernel. Different kernel versions may introduce bugs that cause the driver to perform poorly or not function at all. Changing kernels is one of the easiest troubleshooting steps you can perform with Manjaro.

Using Manjaro Settings Manager multiple kernels can be easily installed at the same time. Changing a kernel in Manjaro is so simple, it's certainly nothing to worry about. If a new kernel is buggy on your system simply reboot and switch to a different kernel at the grub boot menu. Easy peasy.

Here is some other things you could try.

Changing Adapter Configuration Parameters With Ethtool:

Changing your adapter's configuration may help to improve connectivity issues,

You can test changing various adapter options with any of the following parameters.

Simply enter any of the following commands in the terminal.

You must substitute your adapters ID for "eth0" in any of these ethtool commands:

Gigabit configuration with auto-negotiation disabled:

ethtool -s eth0 speed 1000 duplex full autoneg off

Gigabit configuration with auto-negotiation enabled:

ethtool -s eth0 speed 1000 duplex full autoneg on

Disable Scatter and Gather:

ethtool -K eth0 sg off

TSO and GSO are related, so it is often better (but not required) to enable/disable them together.

Disable TCP Segmentation Offload (TSO) and Generic Segmentation Offload (GSO):

ethtool -K eth0 tso off gso off

Disable Generic Receive Offload (GRO):

sudo ethtool -K eth0 gro off

Disable TSO, GSO and GRO:

sudo ethtool -K eth0 tso off gso off gro off

Disable TCP checksum offloading:

sudo ethtool -K eth0 tx off rx off

Reduce the ringbuffer size:

sudo ethtool -G eth0 rx 256 tx 256

Your adapter may or may not support the above options.

Run the following command (replacing "eth0" with your adapters designation):

ethtool eth0

Example returned from my system (partial):

Advertised link modes:  10baseT/Half 10baseT/Full 
                                            100baseT/Half 100baseT/Full 
                                            1000baseT/Half 
                                            1000baseT/Full 

Is "1000baseT/Half 1000baseT/Full" returned in the "Advertised link modes:" section?

If not, this indicates that your switch/router thinks that the links maximum mode is only100mb/full. Usually this tends to suggest a cabling problem. However, it could also be your switch configuration, or a defective port on your switch/router.

Having the same issue after recent update.

Disabling auto-negotiation fixes it for me.

Here's the inxi -Fxxxz output.

System:    Host: ruslik-pc Kernel: 5.1.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 
           tk: Qt 5.12.3 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: P67A-C43 (MS-7673) v: 1.0 serial: <filter> UEFI: American Megatrends v: 5.4 
           date: 01/09/2013 
CPU:       Topology: Dual Core model: Intel Core i3-2120 bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 26411 
           Speed: 1600 MHz min/max: 1600/3300 MHz Core speeds (MHz): 1: 1600 2: 1601 3: 1600 4: 1600 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Gigabyte driver: nvidia v: 418.74 bus ID: 01:00.0 
           chip ID: 10de:1c02 
           Display: x11 server: X.Org 1.20.4 driver: nvidia compositor: kwin_x11 resolution: 1920x1200~60Hz 
           OpenGL: renderer: GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 418.74 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Device-2: NVIDIA GP106 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f1 
           Sound Server: ALSA v: k5.1.1-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8168 
           v: 8.047.01-NAPI port: d000 bus ID: 06:00.0 chip ID: 10ec:8168 
           IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.13 TiB used: 476.70 GiB (41.3%) 
           ID-1: /dev/sda model: IRP-SSDPR-S25B-240 size: 223.57 GiB speed: 6.0 Gb/s serial: <filter> rev: 01.7 scheme: GPT 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EALX-009BA0 size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 1H15 scheme: GPT 
Partition: ID-1: / size: 28.71 GiB used: 19.03 GiB (66.3%) fs: ext4 dev: /dev/sda3 
           ID-2: /home size: 182.80 GiB used: 153.19 GiB (83.8%) fs: ext4 dev: /dev/sda4 
           ID-3: swap-1 size: 7.81 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 33.0 C mobo: N/A gpu: nvidia temp: 49 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 195 Uptime: 17m Memory: 7.74 GiB used: 2.22 GiB (28.7%) Init: systemd v: 242 Compilers: gcc: 8.3.0 
           clang: 8.0.0 Shell: fish v: 3.0.2 running in: yakuake inxi: 3.0.34 

The OP is complaining he only has 100, not Gigabit speeds. You "fixed" yours by setting it to a permanent 100 speed according to your inxi output. This does not exactly help solve the problem being discussed on this thread. The OP has no problem achieving a speed of 100, he wants the full 1000.

You would probably get better speeds by uninstalling the r8168 driver and using auto-negotiation with the r8169 driver (or set a fixed speed of 1000 if your hardware supports that).


LAN troubleshooting tips:


  • The first step in troubleshooting any LAN issue should always be rebooting the router and computer.
  • Have you tested other Manjaro live boot disks, or boot disks from other distros for comparison.
  • Have you tried installing and testing different kernels.
  • On a laptop (or desktop) a hard power down is sometimes required.
  • Power down,then remove any battery and disconnect all power sources. Wait a couple of minutes, then restart.
  • See if unplugging the network cable after shutdown makes any difference. Try plugging/unplugging it after restarting.
  • Have you tested different ports on the switch/router.
  • Have you tested different network cables. Cabling is often a source of connectivity and speed problems.
  • Bad cables/connectors can cause speeds to be throttled down to 100 (even if working properly in Windows).
  • Try a Cat6e cable if you are using only cat5. Linux can be very finicky about the quality of the cables sometimes.
  • Is there a bios update available for your computer, (if so, install it).
  • Is there a firmware update available for your router, (if so, install it).
  • Resetting your router to the factory default default is a good idea.
  • Have you considered your router could be overheating, failing, or simply flaky.
  • Some routers require regular restarts or their speed progressively drops over time (consider a restart timer in this case).
  • Do you have another router, or can you borrow a router to test for comparison.
  • If your NIC is in a laptop have you tested it on alternate networks such as at a friends or neighbors.
  • Resetting your computer bios to the factory default settings can be also be very helpful.
  • It is best to have your NIC speed set to "auto-negotiation" in Network Manager, (but test other settings as well).
  • Disable IPv6 in your router and (or) in Network Manager (or enable it if already disabled).
  • Try assigning your computer a static IP address via MAC address association through your router configuration settings.
  • Ensure there is no MAC address or IP filtering enabled in the router (and all new devices are allowed).
  • Ensure no IP addresses or hostnames are duplicated and conflicting on your network.
  • Disable one NIC in the bios of dual NIC motherboards. Troubleshoot each NIC individually.
  • Try removing the LAN card (if not onboard) and swap it to another slot (if available).
  • Ensure your system is fully up to date with:
sudo pacman -Syyu
2 Likes

Forum kindly sponsored by Bytemark