App no longer runs in Manjaro XFCE - Behringer X-Air Edit

Tried both the direct download of the .gz file from Behringer, extracted it clicked on the executable (it’s ALWAYS worked before) nothing happens, at all!

So thought aha, I’ll enable AUR and get it from there, did that ran the install routine, tried to run it, again, nothing! This is a fresh install of XFCE. I read somewhere the file manager may be the cause of not running the first effort but as I said this has worked with no issues previously, hence trying the AUR version.

Any ideas or suggestions on what I can try?


Why not include the exact name of the package, and the errors you get? That will help us determinate if is indeed XFCE issue, or we have to move this to #support:aur

AUR page for xairedit shows package was updated to v1.7 recently

Flatpak version appears to still be using v1.5 X Air Edit -

Maybe you could use the older version v1.6 if it was working for you previously

A previous discussion on here showed AUR package build failed because EULA download failed
Any way to force package manager to continue despite 404 error?

If you run package from terminal it would respond with error messages if application fails to load

1 Like

I can’t - there are none…as I wrote NOTHING happens! oh and the package from Behringer name, X-AIR-Edit_LINUX_1.7.tar.gz

Nope, ran the 1.7 it came from the Behringer website (and this was the version I was using previously)

And as I wrote I ALSO tried the install route via add/remove and it did exactly the same thing, nothing!!

I was able to build package no problem with pamac build xairedit so I expect you have managed to install the package one way or another

When I tried to run xairedit from terminal I got this response

xairedit: error while loading shared libraries: cannot open shared object file: No such file or directory

I installed libcurl-gnutls

pamac install libcurl-gnutls

And when this package is installed xairedit in terminal can launch the mixer GUI successfully
The start menu launcher /usr/share/applications/xairedit.desktop works too
but I do not have compatible hardware to confirm the mixer software is working


Brilliant! Sorry for long delay I was away trying a new distro…but had MAJOR issues with bluetooth midi, so have just come back to Manjaro as I was advised when it installs Bluez it automatically installs and activates BT-Midi - haven’t got that far yet, still setting up a lot of basic stuff.

But what you posted did the trick re XAir Edit, so thanks much!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.