Anyone else tried kwin on Deepin lately?

Reading through the forum, I noticed that @oberon has expressed his frustration at the rapid rate of change as regards the Deepin DE - he said, I believe, that he wasn't going to be packaging Deepin anymore until it stabilised. I'm still receiving Deepin updates, though, so I decided, more for fun than anything else, to install Kwin again and see where it takes me. I'd had Kwin before and was horribly disappointed. Not sure if anything has changed - I don't recall the version number I used then...

but I tried it yesterday and I actually liked it. Performance is drastically improved. Manjaro now eats up something like 800MB of core with no apps running; when I was running Mutter, it ate between 1.2-1.5GB. Animations are more polished - for example, dragging an open window makes it translucent, in keeping with Deepin's blur fetish. Workspace switching is easier. Pamac looks good now (I hated how it looked with mutter). Windows now "snap" properly, to the left edge of the screen (but I have been having problems with the right edge forever - even under Ubuntu).

Downsides: The blur checkbox in Terminal still doesn't work. Small frustration, but it's there. Worse is the fact that Kwin's animations etc. degrade over time, start to stutter horrifically, and I have had to log out and back in twice over two days, just to keep the computer usable. I don't know if it's something specific that triggers it, or if it simply "rides up with wear". Will experiment to find out.

All in all, kwin coöperates nicely with Manjaro-Deepin now and would actually be a good environment in my opinion for someone who likes to live dangerously. I'm not sure if I'll be keeping it on my production machine, but I'm leaning towards yes. Has anyone had this experience recently, good or bad?

Yes I have been using it for the past 3 weeks, its very buggy at he moment, probably why its not officially been released, well, on archlinux at least.

Good news is terminal blur is back so you will get that when @oberon does an update, don't hold yer breath though :wink:

What gfx card are you using, Mine is nvidia and runs fine, although i have added some extra code to the kwinrc file found in the .config folder, composite, wobbly windows, turned off startupfeedback icon etc

I also did a basic demo video on it:

I'm using a NVIDIA GeForce GT 330M with nouveau drivers - I tried vendor-supplied ones and then my computer just wouldn't boot up, black screen.

Oh, another thing - the transparency slider in the system settings doesn't do a thing. There's a certain level of transparency, and it's that or totally opaque.

Have you tried troubleshooting it, may fix the stuttering, blackscreen usually means wrong driver?

Works fine here, GTX970 although that did happen to me, only because I added something to the kwinrc file, after removing it, it came back.

This sounds promising. Just, as you see yourself, there are still bugs in current state of development and for that reason for now I am holding back on building new ISOs. This doesn't mean that I am not regularly updating packages and building our customized versions. :wink:
As soon as Deepin reaches a presentable stable version of consistent packages, we are good to go again for fresh install media, of course.

2 Likes

Oh, I understand now - you're not building new install media, but packages are still a go. And of course, since Manjaro is a rolling distro, you can always download the old installation iso and pamac will helpfully update it to latest. So we're not losing much - in fact, I don't understand why Manjaro releases versioned ISO files, anyway. In my mind, it should be one ISO for years and years - you can always connect to Internet to update.

Then your first update post installation would be HUGE ... and the larger the update the more prone to breakage it usually is.

Try installing and updating a 2 year old ISO ... not only are the packages very old but the default system config will be quite different too ... and may not even be compatible with latest packages.

1 Like

@oberon
More we stay off with this kwin update - better.

They have done tremendous amount of mistakes on 15.10 release, so it have insane amount of bugs to the point of unusable, including very serious ones which wasn't present in previous Deepin versions without deepin-kwin.

I estimate if we really lucky, it will take them something like 2-3 month to polish it at least for the previous state of quality (which was far from perfect, as you know).

Plus, hopefully they'll manage to fix arch/manjaro release process by the time... :zipper_mouth_face:

If it's buggy on your system, why not just uninstall kwin and keep using mutter? You're not forced to use it (it's not a dependency of Deepin, and probably won't be for a while yet). But not synching Manjaro's deepin-kwin package with its upstream version is imo a recipe for disaster.

Like out of the three options - "no kwin", "current kwin", and "3 month old kwin", the last of the three is always going to be the worst from a stability perspective. That's part of why I moved away from Ubuntu. The other two are a matter of opinion and a matter of your computer's configuration.

I'm glad to hear that I was wrong and Kwin is being synched with upstream after all - it does work well on my Mac, so I'll keep using it there, but don't think I wouldn't go back to mutter if it wasn't stable enough.


More importantly, and I did not put a fine enough point on it last time, Pamac finally LOOKS GOOD! Turns out the ugliness wasn't Pamac's fault at all, but the compositor's. Essentially, Pamac's GTK didn't match up with Deepin's customised version, so it looked out of place with attempts at 3d, sort of classical skeuomorphism in the controls. Deepin is very MS-like in its neoskeuomorphism: flat glass, nothing that looks like you can touch it, but illusions of depth everywhere.

I think you are right. I use both original and Manjaro version and revert even original back from kwin to mutter. There´s little bit too much going on in original Deepin, but I hope they get it work right soon.

What, specifically, is the problem you're experiencing? I have Kwin running great on my Deepin/Manjaro install.

How did you get wobbly windows to work?

I added some commands to the kwinrc file found in home/.config folder, if you want I can upload my config or you can install systemsettings pkg and that will give you the kde system control center but will install a load of extra pkgs. Only do this if your testing, as an official deepin-kwin release may br!ck your system, just sayin :wink:

sudo pacman -S systemsettings

If you could upload your config, that would be great!

Download the version 2 under files, rename your kwinrc to orig_kwinrc (just in case) and then drop mine into home/.config folder, logout login should get it working :wink:

1 Like

This works like a charm! Thank you!

1 Like

your welcome & thank you :wink:

1 Like

So I've been using @ant 's Kwinrc file, and... oh, wow, this takes me back to 2008-ish... erm, back to reality, no complaints. I'll probably be going a bit off topic here, but even with stock Kwin, the animations are absolutely masterful. For example, the pretty semi-transparency when you move a window, and the desaturation when a program crashes. Miles ahead of Mutter, but a bit Compizesque. I'm not exactly sure of the history between Kwin, Compiz, and Mutter, or why Mutter seems so simple compared to the other two, but there you have it.

I don't like the trend behind the heavy window border shadows on Kwin—reminds me of the philosophy of Material Design, and I hate Material Design (it's the wrong kind of skeuomorphic, almost atavistic).

I've also been having a strange sort of problem, but it also appears on Mutter, so I don't know what's causing it. It's as if the right edge of my monitor didn't exist. I have all four hot corners enabled, and only the left two "hit". When the mouse pointer hits the top, bottom, or left edge of my screen, it acts as if I hit a wall, on the right, it goes off the edge.

I think that's because you have more than one work space enabled, so essentially whats happening is your dragging the window to the other work space, that's why it happens on right and not the left, if you don't use work spaces, you can turn them off in dconf-editor, to check if you have work spaces enabled press Super key+right arrow / Super key+left arrow to get back.