Any way to install Manjaro other than with a bootable disc or stick?


#21

The problem with the USB keys occur even when there are no drives in the computer. I’ll have to fix that problem before worrying about my drives.


#22

I have an USB3 port somewhere on the motherboard but it’s not plugged in. I’ve been using the front panel USB ports since my initial key was an older key.

Might be good to try plugging in the USB3 port and installing via that one instead. I’ll add it to the list.


#23

this does actually matter sometimes, on my kids laptops(uefi) it will only install properly if i use the usb2 ports. you might also try kernel parameters to take care of the acpi errors, placed on the grub line beginning with “linux”

acpi_osi=Linux
acpi_osi=’!Windows 2012’
acpi=strict
acpi=force
pcie_aspm=force
take your pick, and try different ones


#24

Ooof, quite a list. Someone also suggested replacing “quiet splash” with “acpi=off”.

Ah well. These are all things I can easily try. I’ll add them to my list.


#25

i forgot that one :+1:


#26

You have been given advice you don’t take it use etcher no it does not it uses DD. why do you think you were advised to use etcher it never fails with Manjaro. But no you choose to go down the same road you have been down umteen times.
To move on use etcher it is proven if it fails then its hardware Bios motherboard till you try etcher you can’t move on.
Also playing with bios settings unless you know what you are doing can prove fatal, You are getting some good advice but you are also getting a lot of bad advice as well.


#27

Actually I can and did move on. I finally got onto the live environment and reinstalled Manjaro. I don’t know why you were so certain Rufus was to blame for my issues but it created the disk image just fine.

Small report in case some people might be interested:

Removing “quiet” added a few lines above and under “starting version 239”.

::running early hook [udev]
starting version 239
::running early hook [miso_pie_nbd]
::running hook [udev]
::triggering uevents…
_

And that’s where it hanged. I guess this could have been useful in finding out what was wrong, but as it turns out, I have no idea how I fixed it because I’m still getting the same error messages as before. Most of the ACPI lines did nothing, one removed the error lines but fixed nothing and one seemed to displace the problem somewhere else.

I switched the front panel from USB2 to USB3.1 and it didn’t work at all. Mostly I couldn’t even get onto the USB key’s menu (my BIOS is real finicky about boot order). The one time I did manage it and asked to enter the live environment, it didn’t even get to the error messages.

I switched back to USB2, set the boot order back, checked that I could access the USB key’s menu again, tried entering the live environment for the heck of it… and this time it worked. It still displayed the usual errors but it was somehow able to get past them.

Thanks to all who made suggestions. In the end I have no idea what fixed the problem, but trying again and again paid off. I can finally get off this old Windows machine and onto one that isn’t being powered by a vaguely hamster-shaped dinosaur in a square wheel.

Now I just gotta figure out how to safely get back my old stuff. Would dumping my old user folder into my new /home/ break anything? Is it possible to rename it?


#28

It is not advised, if you don’t know what you are doing.
OTOH you can safely copy over the individual not-hidden folders, like Documents, Pictures etc.


#29

Alright, I won’t risk it. I don’t have all that much stuff to reinstall anyway.

Thanks.


#30

Its all about the right tools for the job etcher Suse imagewriter are written for Linux and DD. Rufus is a windows program It used to be good but not now the last good was a year ago, When a user complained about DD not working correctly they were told rufus is smarter than you and knows what its doing, I think that says it all rufus is not aimed at Arch manjaro type installs any-more.
I’m glad you are up and running even if not right and you really don’t know if the problems are not down to rufus do you, Its simple “you can take a horse to water but you can’t teach it to drink” is a old but true saying.
USB3 on a lot of motherboards does not work till the machine is booted its to do with Ms and its secure boot ideals. but their are workaround for that sort of things check with google.


#31

Acpi errors can usually be ignored. They are the result of the Linux devs being hard at work, trying fix buggy, and bad implementations of acpi by the manufacturer.