Any way to install Manjaro other than with a bootable disc or stick?


#1

tl;dr version, see title.

Longer version:

I initially installed Manjaro from a bootable USB stick I made with Rufus, and it worked just fine. I used it for a week or two and liked it, I might very well have kept using it for years.

However, I messed up when I switched some HDs around, forgetting that I’d shut down using hibernation. Needless to say my installation got wrecked. This wasn’t actually a big deal, I simply thought I’d use the USB key to access the live environment and reinstall Manjaro again.

Thing is, now it can’t get past the GRUB menu where I select language and such. I select the option to boot the Manjaro live environment and just get a bunch of error messages. Mostly “ACPI Exception: AE_NOT_FOUND, Evaluating_PRS” followed by “starting version 239” which doesn’t actually do anything.

I remade the key a bunch of times, using two different versions, in DD mode, and always get that same result (one older version said “starting version 237” instead of 239, but that’s about it).

I tried Manjaro-Architect, but its menu is practically identical, so I got the exact same result again.

I wondered if my computer had some new issue booting from USB drives, so I tried Puppy Linux (specifically tahrpup64) real quick, and it entered its live environment just fine. Seems like the issue is specific to Manjaro.

So here I am, asking if there are other ways to install it.

Assuming there are no other ways to install Manjaro, I guess I’ll just have to go with a distribution that lets itself be installed. However it seemed callous to give up on an entire distribution that I actually liked without at least asking if there isn’t some alternative way to install it.

Or, on the off-chance that someone knows what could cause a Manjaro bootable USB stick to fail to get past the menu and into the live environment, and knows how to fix it, that would work too. But it seems like that would be a long shot.

Pretty sure there’s nothing to be done, but still, after I spent so much time trying to make it work again, I figured it was worth the fifteen minutes it took to post about it on the official forums.

If not, well, thanks for your time anyway.


#2

Have you done a checksum on the ISO you dowloaded.

Try using etcher to write the boot USB.

You could go old school and burn it to DVD.


#3

You may also want to try booting free/non-free drivers to see if either of those work

Also, if those don’t work, try the 18.0 ISO instead of 18.0.1, as the latter might have an issue similar to what you are describing…


#4

I verified it, yes, and since I used multiple ISOs and the resulting keys all behaved the same way, I would have been pretty sure that a corrupt ISO file isn’t the cause regardless.

I suppose I could try Etcher, is there a particular reason why it would work better than Rufus in this instance? I’ve made about 9 different keys already, and every time I make and attempt a new one knowing with 99% certainty that it won’t work, it’s sapping my will to even try. Getting tired of taking shots in the dark, you know?

Unfortunately I don’t have a DVD drive. I’m not sure it would have made a difference (data is data, the computer shouldn’t care about the media itself and is clearly able to boot via an USB key) but in any case I’m unable to try.

It’s been a disheartening couple of weeks with everything I’ve tried failing miserably. Fixing the booting crash issue would be ideal and I’d be willing to give it a few last shots if I get a solid lead on what the problem could be… but really, I’m doubtful anyone will figure out why it’s not working. At this point I’d just like a simple way to install the distribution.

Still, thanks for the suggestions. I might try Etcher if I get enough willpower to try yet another time with a USB key.


#5

I don’t remember trying non-free drivers. Don’t know if using the free drivers is what causes the crash (it worked perfectly well the first time), but I suppose that’d be easy enough to attempt. If I do make a new key with Etcher, I can try both at the same time. It’s easier on morale if one move lets me make two different tests. Thanks for the suggestion.

I’ve been using 17.1.6 (which is the one that originally worked) and 17.1.12. I always prioritize stability over cutting edge.


#6

Believe it or not I actually have had situations when a DVD worked and the flashdrive didn’t.

Etcher is pretty near foolproof.

Are you installing in UEFI mode?


#7

Ah, the crazy world of computers. When things that shouldn’t matter… do.

If I remember correctly, no. I’m using old USB keys and I actually had an issue where it wouldn’t even get to the GRUB menu on the key if I set the BIOS to load from UEFI USB keys first. Placing non-UEFI USB earlier in the boot device order allowed me to access the USB key and get to the menu, which was a major improvement, though again it failed to boot the actual OS and enter the live environment.

To be honest I don’t even know the difference. This is my first new computer in ten years and I’ve never even heard of all this new stuff.

I’m a pretty regular user. I can install an OS if I have a bootable media but everything else requires a lot of research and, worse, guesswork.


#8

You should try restoring your existing installation.
If you can boot to grub menu, edit menu (press E) and go to the line that starts with linux and delete the resume=UUID=alphanumeric...
Then press F10 to boot to TTY.

If it still doesn’t boot, reboot again and at grub menu “Edit” add 3 at the end of linux line.
When/If it works, check your partitions setup/UUID against /etc/fstabUUIDs. Correct them if wrong. Then recreate kernels and grub menu.

sudo mkinitcpio -P
sudo update-grub

#9

I did try restoring that installation. It would have left me with the worry that I couldn’t install Manjaro again later, but it would have been a good short-term solution.

Unfortunately, after hours of research online, I got a dozen wildly different solutions and none of them worked. In the end I formatted the disk to prepare for a future reinstallation, which is unfortunate since that didn’t pan out either. Your suggestion is far simpler than many others I’ve tried so I would have been happy to try it, but it seems, seeing no hope, I cut out one of the very few options I had left.

The one thing that frustrates me the most about this entire thing is the mysterious reason why the computer won’t boot onto the live environment anymore. What changed? What could have changed? I didn’t touch the BIOS between the time the USB key worked and the time it didn’t. With no disks or installations of any kind plugged in, the computer should have been identical to the first time I booted it and the key worked. Yet it’s not. Something was modified and I don’t know what. With my limited knowledge I didn’t even know you could modify anything other than the BIOS settings. There are so few possible culprits here it should be super easy to pinpoint the cause. The error messages should indicate exactly what’s going wrong. I just don’t have the knowledge. The workings of this machine are so alien to me they might as well be magic.

If this one thing wasn’t broken it would have been child’s play to just reinstall Manjaro. It still would be.

Tomorrow, I’ll try a 10th key made with Etcher to see if it works somehow. I’ll also see if selecting the non-free drivers instead of the free ones allows booting into the live environment. If neither of those things work, I really think I’m at the end of my rope here. It’s been two weeks of stumbling in the dark and nothing ever working, I feel like all my efforts are doing nothing but keeping me miserable. I really like Manjaro, but if it won’t install, there’s nothing I can do. At some point I need to cut my losses.

Sorry to spring an unsolvable problem on all of you. I really should have just sucked it up and installed another distribution right away.


#10

I hope you 've got your lesson… If you want to troubleshoot Manjaro you ask Manjaro! :wink:


#11

Two things come to mind:

  1. I see you mention usb keys in the plural. Have you indeed used multiple, different usb keys? If not, your usb key may have a defect. In that case, use a different usb key to check if that is the problem.

  2. Maybe something got messed up in the BIOS/UEFI settings? Check those, maybe reset them to default and/or check if there is a newer version of the BIOS/UEFI available that you can update to.


#12

I used mostly one key (the one that worked the first time I used it), but it reacted the exact same way all 8 times that I remade it with different .iso of different versions (loaded into the menu just fine, gave the same error message afterwards) and when I tested it with Rufus it showed no signs of being defective. It would have been exceedingly improbable that the key was the problem, but I used another key anyway just to make sure and got the same result.

Since my main suspect was the BIOS (what else is there to change on an “empty” computer?), I reset the it to default settings to see if it would restore the booting process to its original working state. It did not. There is a newer version of the BIOS available online, but since I’m told this is a somewhat risky procedure, one I’d have to do via USB key (which does not inspire me with confidence right now) and since I know for a fact that it’s not a necessary update (original installation was done without it), I really don’t want to risk it. The computer is salvageable right now, if I break the BIOS it won’t be. Plus, I don’t think Manjaro would have changed my BIOS settings behind my back, that’d be insane.

Ah well. I’ll make those couple of tests later today. I’ll use yet another key, and verify the process if Etcher has that option too. In the unlikely case where it works, I’ll never know which one of the changed variables will have made a difference, but that’s fine. Since the computer’s error messages don’t appear to specify what is really going wrong with the process, I think the source of the vandalism will remain a mystery for this machine’s entire lifetime regardless.

Thanks for all the suggestions. I really didn’t want to give up without giving it at least a couple more shots and now I suppose I’ll be able to say I tried everything I could, within reason, before giving up and installing some noob distribution. Clearly I’m not competent enough to use Manjaro.


#13

Failure is the surest path to knowledge :wink:

Rest assured that we all have bodged countless installs and eventually learned from it. Just a few weeks ago it took me at least 16 tries before I had figured out the only way to install Manjaro on a particularly tricky HP laptop. That involved messing both with the UEFI and massaging Manjaro Architect to do the right thing.

Maybe you have run into a particularly esoteric problem. If you manage to solve it and report back here, we are all learning!


#14

If you have reset the bios to default be sure to disable secure boot.


#15

I never enabled it and was initially able to install Manjaro, which means it was most likely off by default. And I did restore settings to default so it should still be off. But I can check it out real quick before I make my attempt with the latest key.

The more tests I can make with each attempt, the better. So thanks, I’ll add this one to the list.


#16

Alright, I absolutely didn’t solve it, but here’s my report for those who might be experiencing a similar issue and looking for clues.

I didn’t try Etcher because it never asked me if I wanted to make an ISO or DD. I used Rufus to make one last key (on a 2nd, more recent USB key rather than the one I’d been using). All the times I used those keys and Rufus seemed to yield normal results so I don’t think Rufus is the problem anyway.

I checked my BIOS to see if Secure Boot was on. There is no such option anywhere in the settings, and again I was initially able to install Manjaro the first time I booted up the computer, so it probably wasn’t on then and now that I’ve reset settings to default it’s just about as close to how it was back then.

Usual error messages with Manjaro. Trying with non-free drivers yielded the exact same error messages, just in bigger, old-style text.

Then I tried getting into the Antergos live environment. And it’s broken too. Same as with Manjaro, I get into the menu from the USB key, select the option to boot into the live environment, and the Antergos logo appears with dots indicating progress just underneath. Progress stopped at the 2nd dot of what I assume to be 5 dots. No error messages or anything, it just hanged there.

Then I figured it might be an issue with distributions based on Arch, so I tried MX Linux which is based on Debian. I kid you not, I got to the menu, asked to boot the live environment, pretty sure I briefly saw some of the same error messages (either “AE_AML_INVALID_RESOURCE_TYPE” or "ACPI Exception: AE_NOT_FOUND) before it moved on with the booting process but hanged at “[…] Waiting for /dev to be fully populated…_”.

It’s clearly failing at a very specific task in the booting process of most Linux distributions.

I say “most” because Puppy Linux (tahrpup64) gets through to the live environment without issue.

So I’ve got lots of hints here. A specific point in which the process fails, and a distribution that works (meaning whatever the others are trying to do, this one doesn’t). If I knew anything about the Linux booting process I’m sure it would be painfully obvious what the issue is, but I don’t.

What’s worse, my fancy new computer won’t let me install an OS on it, except maybe Puppy Linux (which is woefully inadequate as a permanent environment). It’s just a very expensive paperweight.

Everything is terrible.

In any case, thanks for all the suggestions, it got me to try a few different things and make sure that I’d done everything I reasonably could. It appears that my issue isn’t Manjaro-specific so I’ll take it somewhere else.


#17

Quick question: does this mean that not even the version that used to work is working anymore on the same computer?

If the same version that worked previously no longer works, it might be a hardware issue, especially if it can’t even boot the livecd environment anymore.

If the hard drive is going bad, it could be hanging on trying to read it. If the RAM is going bad, it may be hanging on copying the live environment to RAM to run it. You might want to try booting the livecd without the hard drive, or with different RAM.

Puppy linux is known for being small/lightweight. If the RAM is indeed bad, it may be small enough to fit on part of the RAM that’s still good, which could be why that one works while others don’t.

Same could technically go for the flash drive you’re using…


#18

Correct. I first got to the live environment and installed Manjaro using a USB key, broke my installation, and then the exact same USB key (didn’t touch it at all) didn’t work anymore. No key does, I’ve tried multiple ones.

I can’t get to the live environment even when there are no disks of any kind inside the computer. I tested the RAM and it’s fine, and besides, 16 gigs should be enough for any distribution.

I have absolutely no idea what those error messages are implying, so I can’t ignore the possibility that it’s a hardware issue, but right now I have no particular reason to think that it is.


#19

If you haven’t installed Puppy, it may mean that RAM is fine but not essentially the drive.
You may need to check drive cables to be firm and/or check the drives with Puppy.


#20

Do you have USB2 and USB3 Ports. Make sure you test the installation on both types in different ports… Also do not run from a USB hub, run directly from a port on the computer.