Any Firefox Updates past 88.1 Freezes The Whole System

I suspect that the theme has the issue, try to change other theme.


It is just a warning, so it might not be the case.
However, you should try with a new profile.

Run firefox -P in the terminal. You should see a new window with all your profiles, there you can create a new one.


Hi there, thanks for the feedback, maybe I should have started with that. I have already created a few new profiles.

I had to whenever I updated firefox and had to downgrade because whole system would freeze. After downgrading, it would tell me that my profile was not ok with this version, I had to create a new one. which I did, 7 times already…

I updated to every minor major version between the one I have now 88.1 and whatever most recent version there is now. I also tried using the plasma-browser-integration add-on for firefox suggested by someone on an slightly unrelated topic somewhere else on the web.
I just don’t know what to do. feels stuck for a reason I don’t even understand.

Try another browser - Brave, Opera, anything really. Firefox produces major issues every now and then. For example I had to completely move a small business, relying on FF onto Brave, because of a printing bug, which is still unresolved. On another note - if the whole desktop environment freezes - this is likely to be an issue with your HW GPU stack - browser GPU decoding spring to mind. Try checking your logs with “dmesg”, ex.: sudo dmesg | grep -E ‘firefox’.

Simply updating a browser should NOT be an issue.

1 Like

Is your whole system up-to-date (e.g. no package blacklisted for update)?

1 Like

Unless you are using a highly customized system - beyond default kernel and modules - this is a one of a million issues.

I suggest you do as follows - excerpt from [root tip] Update Manjaro the smart way

Reboot your system - and ensure you are landing in the grub menu. You may need to use a keypress to get there - either using Shift or Esc.

When at the grub menu - press e at the chosen entry - then using the or to navigate to the kernel arguments line - then add the number three (3) to the line and press F10 to boot to command line (previously runlevel 3).

Login and execute the command

sudo pacman -Syu

Respond to the prompts and when finished you should be able to reboot your system and login.

1 Like

yes there is a package blocked for update … firefox :smiley: the rest is up to date

I appreciate the idea but I am really attached to firefox and really hope to make it work.

I am using the default dark theme :frowning:

Try to run the command to refresh system. sudo pacman -Syyuu

Hi I tried this solution to no avail, there was nothing to be updated

I assume you mean checking logs after installing the update to see what the issue is. If I assume correctly, how would I do that when the system is frozen ?

This may be too obvious, but have you tried uninstalling and reinstalling Firefox to the current version? I’d use pamac.

Just an old reflex from a recovering Windoze user…

1 Like

If I understand your statement correct your system is fully updated - yet you don’t have the latest firefox in v90?

That is strange to me - if pacman says there’s no updates - yet your firefox is an older version?

This could indicate you are using an unmaintained mirror. Unfortunately there is mirrors responding with the repos but the repos hasn’t been updated for months.

Before refreshing your mirrorlist - it could be enlightening if you would kindly provide the text from the terminal after running pacman-mirrors with no arguments.


Hi, sorry I must have badly explained myself. No I can update if I want to, but any version newer than 88.1 freezes my system.

Local mirror status for stable branch
Mirror #1 OK 01:44 Belgium Index of /manjaro
Mirror #2 OK 00:44 Hungary Index of /mirrors/pub/manjaro/
Mirror #3 OK 03:13 Bulgaria Index of /manjaro/
Mirror #4 OK 00:12 Austria
Mirror #5 OK 02:43 Chile

Hey guys,

Just upping this topic, hoping to get an idea that could lead me in the right direction in order to be able to update firefox.


So when FF is totaly broken, I would:
delete ~/.mozilla drawer completely.
Then remove all versions of firefox including language-files - and reboot.
Install “Stacer” and use “System Cleaner” Tab to clean ALL “Application Caches”.
Maybe a conflict gets resolved so.
(less riscy than deleting contents of ~/.cache/mozilla)
?? => sudo pacman-mirrors --interactive --default && sudo pacman -Syyu

If no one has the solution - bumping won’t help - but it will cause the topic to be closed.

It has probably something to do with your Apple hardware.