Another TLP system startup/shutdown

Hi everyone!
I am sorry for the post, been looking around the entire forum but everything i had done lead to this cry for help....
I HAVE DONE EVERYTHING EVERYONE SAID! nothing works... canceled fast boot, canceled security boot...
been going from post to post, each post approaches the problem in a different way.
I am new to linux and want to try out manjaro..
cpu: i7 8750H
GPU: 1050 GTX
chose in the installation nonfree option but still the installation freezes when it gets to the point where it says Another TLP system startup/shutdown.

help me please :frowning:

select free drivers
in case of failure, select free again but add to boot parametres: nouveau.noaccel=1

1 Like

I have selected free drives also, did not work...
where do i put the parameters above?

Please confirm you did this too:
Edit the GRUB boot option on live media install and add systemd.mask=tlp.service

To edit grub boot menu, type e and in the kernel line replace quiet with it, or add it after that. Same with the parameter proposed by @openminded. Then press F10 to save and continue booting.

1 Like



1 Like

this is the only grub menu i have... no idea where to put the parameters...
It is either that grub screen or i can just press C and enter an empty grub menu...

do no have those... how do i get there...?

You are now booting from live media right?
So, when on this menu

Then you press e

And you add the arguments on this line

after quiet

1 Like

done as said... added "nouveau.noaccel=1" after "quiet", checked that spaces are okay and everything is written correctly... after pressing CTRL+X it starts running scripts on the screen as it should and again shuts down when it reaches TLP SYSTEM STARTUP/SHUTDOWN..

That was not said by me, but you can use both boot parameters.

:slight_smile:

I am sorry for asking the same question over and over but.. where do i put systemd.mask=tlp.service? in the grub boot menu after what? or before what..?
Edit***
I have done as said above, put it systemd.mask=tlp.service after quiet but it does not work

What is the error?

sorry for the horrible quality, took the photo in a middle of the video, hope it will be enough to understand, if not ill try my best taking another photo

It is the end of the reboot procedure, not a "stuck at TLP whatever". Wrong picture taken, in other words.
Given the fact that you obviously don't understand what you're doing, and assuming that your computer is a laptop with hybrid graphics, here comes the exact text that should be between driver=free and misobasedir=manjaro:

nouveau.modeset=0 i915.modeset=1
1 Like

So, I kinda feel stupid now....
Misread everything, all i had to do is to change the value of nouveau.modeset=1 to 0....
THANK YOU SO MUCH FOR HELPING EVERYONE!

No you read it right, I suppose your GTX1050 is just too capricious, for some reason this model tend to have more problems than others, and nouveau.noaccel=1 was not enough for it, but modeset=0 worked.

PS: I strongly believe that nouveau should be always disabled for all GPUs newer than GT7xx series (don't remember their dev name... Kepler?), because all it does for new GPUs is producing issues.

Forum kindly sponsored by