Another PCIe Bus Error when trying to boot into Manjaro KDE for the first time

I tried to install Manjaro KDE but when I try to boot into it, there will be texts like “Welcome to Manjaro Linux!” and lots of “OK” then the “PCIe Bus Error” would constantly apear on the screen. I’m dual booting it with Windows 10.

I’ve searched for similar problems like this and I have read that either I’d have to switch to older kernels or add some kernel boot parameter. But I don’t even know where to start or how to do those while in the GRUB Menu or if those are really the solutions for my problem.

By the way, I’m also having PCIe Bus Errors on my previous Linux Distros but the difference here is that I could boot and install them without encountering the errors yet, while in Manjaro KDE, I’d encounter those errors when trying to boot for the first time.

I’m using the laptop Asus VivoBook Max X441URK, with an i5-7200U CPU and NVIDIA GeForce 930MX GPU.

Stuff that I did:

  • I used Rufus 3.1 in Windows 10 with these settings

    and used the DD Image option.
  • I have disabled Compatibility Mode (CSM), Secure Boot, Fast Boot, Fast Startup and Hybrid Sleep.
  • I have cleaned up all dead data on my Windows System.
  • I have already updated my BIOS to the latest version.
  • I reordered the Boot Priority

    There seems to be two partitions for Manjaro KDE when I use the DD Image option to create a bootable USB, as you can see in the picture. Is that normal?

The version of Manjaro KDE that I’m installing is version 17.1.12 Stable and was downloaded via torrent. I have also verified the ISO file’s integrity and it matches with the correct SHA-1 hash.

I hope somebody could provide me a clear solution that even a complete Linux newbie like me could follow and understand. Thanks.

yes this is normal,
first partition is for install /boot bios
2nd partition is for install / boot EFI

1 Like

Thanks for clarifying that up. One question down.

The PCIe errors are probably not fatal to the system.
Did you get to the Grub menu screen?
Have you tried both BIOS entries to the installer?

maybe wait new dev iso with kernel 4.14 or 4.18
https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.67 ( See PCI changes )

1 Like

So this problem is indeed related to the kernel? I guess I’ll just have to go back to my previous distro and I will be trying the preview builds for Manjaro KDE on a Virtual Machine, to wait and see if any of them would work properly on my laptop.

I really hope those updated kernels would fix this “PCIe Bus Error” because I get the feeling that my laptop is not yet completely compatible with most Linux distros and I hope the developers are aware of this.

Yes I got to the GRUB menu, only after I select to boot into Manjaro KDE, I would encounter those errors. I’ve also tried both BIOS entries and still the same problem.

I’ll just probably wait for upcoming releases with possible fixes for this problem, assuming that I didn’t mess up anything with my preparations or the installation on my side and assuming that it’s only a compatibility issue with Manjaro KDE, since I’d at least want to feel that “works out of the box” treatment.

Probably not. It should be because of the GPU drivers.
Have you tried both free and non-free options?

Have you read Manjaro Manual?

You might try adding grub parameters (there should be an option in Installer’s menu) like


and/or

nvidia.modeset=0
nouveau.modeset=0
i915.nomodeset=0
i915.nomodeset=0 nouveau.modeset=0
nvidia.modeset=0
nouveau.modeset=0
nvidia.modeset=0 nouveau.modeset=0
nomodeset nvidia.modeset=0 nouveau.modeset=0

or use Manjaro Architect ISO installer.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark