Сan’t fix keyring password at every launch, the browser doesn’t work (synchronization and opening links)

Another surprise after the Manjaro update (DE Cinnamon). When I start the browser, it’s asking for keyring password at every launch. No autologin, but a password login.

What I’ve already done:

  1. Seahorse - deleted it, didn’t help, installed it again.
  2. I tried to delete default keyring from the command line, as a result I have several dozen or even a hundred default keys, it’s not clear which of them to delete.
  3. I tried to find the default keyring in Seahorse, but it does not see any, there are only PGP and SSH keys, but during one of the launches it showed the default keyring, so I deleted it, installed an empty. Did not help.
  4. I added the --password-store=basic parameter to the browser launch file in /usr/share/applications

As a result, every time browser is asking for keyring password, I have to log in to the browser (google account) and synchronize the data and passwords, and at the same time opening links from other applications has stopped working - you click on the link in Mattermost, WPS Office, Thunderbird, whatever, it opens another instance of browser with the default page, but not the page via the link in the open version of the browser.

This is not Manjaro specific but user related.

Close all open applications

Delete all keyrings with seahorse.

Open a browser - when it query for a password to the keyring - leave it empty.

You will get a warning that credentials will be stored in cleartext - accept it.

1 Like