Amdgpu USB 3 Displaylink

Hello. I have a displaylink monitor and I cannot make it work with Ryzen 5800u via USB 3.
Please note that I followed the arch wiki page and it worked just fine for this monitor on another (Intel) laptop.

inxi -Gx

  Device-1: AMD Cezanne vendor: Hewlett-Packard driver: amdgpu v: kernel
    bus-ID: 05:00.0
  Device-2: DisplayLink MB16AC type: USB driver: N/A bus-ID: 1-2.2:6
  Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 3-2.3.6:6
  Device-4: Luxvisions Innotech Limited HP HD Camera type: USB
    driver: uvcvideo bus-ID: 3-4:3
  Display: x11 server: X.Org driver: loaded: amdgpu,ati
    unloaded: modesetting resolution: 1: 1920x1080~60Hz 2: 1920x1200~60Hz
  OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.7-1-MANJARO LLVM 13.0.0)
    v: 4.6 Mesa 21.2.5 direct render: Yes

There is no modesetting provider.
xrandr --listproviders

Providers: number : 1
Provider 0: id: 0x56 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 4 associated providers: 0 name:Unknown AMD Radeon GPU @ pci:0000:05:00.0

Displaylink service is up and running, evdi-git is installed.


[    2.286478] usb 1-2.2: New USB device found, idVendor=17e9, idProduct=4374, bcdDevice=31.01
[    2.286484] usb 1-2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.286486] usb 1-2.2: Product: MB16AC
[    2.286487] usb 1-2.2: Manufacturer: DisplayLink
[    2.286488] usb 1-2.2: SerialNumber: 5194761M1893

Can you please help to setup this monitor, maybe some extra config is missing ?

I have some progress:

  1. Kernel 5.15.7-1 with evdi-git. Does not work
  2. Downgraded to 5.10.84-1 and installed evdi. Works

So I guess this is smt related to kernel version vs evdi combination.

This fork worked for me

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.