Amdgpu / RX550 / boot screen unreadable

amdgpu

#1

Hi!

When I boot with amdgpu in the initramfs and kernel parameter amdgpu.cik_support=1,
I cannot read the boot screen anymore…
The font is completely wrong (like only one half of the character is displayed) and 1 of 2 characters is completely missing…
I think i did it like it is described here: https://wiki.archlinux.org/index.php/AMDGPU

Is the RX550 not supported yet?

Or is it my monitor (it is quite wide (2560x1080); but the resolution with the RX550 in text mode is 1920x1080, which is the same with the APU (A10))?

Thx. Bye.


#2

with the help of batch/#manjaro/freenode/irc i found out,
that i need the kernel parameter video=HDMI-A-1:1920x1080@60
or it will create a big mess…
https://wiki.archlinux.org/index.php/kernel_mode_setting

same with Xorg…

now i need to find out how to get the modeline right…
havnt done that for 10yrs or so… giggle

that was easier with the catalyst and the APU’s HD7660D… :slight_smile:

-arne


#3

some people say, that i need a dual link DVI-D cable…

currently i use my old trusty HDMI cable, that could deliver 2560x1080@60Hz from the HD7660D to the same monitor…

is it a good idea to use such a DVI cable instead of my HDMI cable?

according to AMD the RX550 can deliver 4K60 via that HDMI connector…

or should I try amdgpu-pro?
but then i had to uninstall a lot of packages, because they are conflicting…

-arne


#4

at least that is not too expensive to try out


#5

why you do this anyways?
cik support is for sea island generation (GCN1.1), your Rx550 is polaris 12 (GCN4)

install linux 4.12 or 4.13 and your card should work.


#6

@Tids:
now i use
amdgpu.si_support=1 amdgpu.cik_support=1 amdgpu.audio=0 video=HDMI-A-1:1920x1080@60
at least one of these parameters is necessary to make the console (boot messages like “Starting blah/Started blah”) readable…

and i already use linux413…

is there maybe something in the amdgpu driver, that limits the resolution to 1920x1080?

-arne


#7

Amdgpu, or better the kernel sets the mode according to the monitors EDID informations. So maybe something is fishy in there. Can you tell us the monitors model?
Are you sure that you’re using amdgpu at all? Maybe you tried fglrx at some stage and this ■■■■■■ it up :joy:


#8

i found an almost perfect workaround:

cvt 2560 1080 40
2560x1080 39.93 Hz (CVT) hsync: 44.25 kHz; pclk: 147.25 MHz
Modeline “2560x1080_40.00” 147.25 2560 2680 2944 3328 1080 1083 1093 1108 -hsync +vsync
# lsmod|grep radeon
# lsmod|grep fgl
# lsmod|grep amdgpu
amdgpu 1941504 6
i2c_algo_bit 16384 1 amdgpu
drm_kms_helper 131072 1 amdgpu
ttm 81920 1 amdgpu
drm 303104 7 amdgpu,ttm,drm_kms_helper

yesterday i only tried 25Hz, 30Hz and 50Hz, which all did not work… doh! :slight_smile:

The monitor reads (according to Xorg.0.log) as: “Manufacturer: AOC Model: 2963”; and on its package it says Q2963PM; and I connected the HDMI output of the RX550 to the HDMI input of the Q2963PM.

it seems to be purely software related, so that i just cancelled that “dual link DVI cable” order…

-arne


Dual GPU crashing at boot of live CD and instal
#9

Maybe its still your cable. Is it at minimum a HDMI1.3 one? I’d totally go for DisplayPort1.3/1.4 of course :joy:

Because its strange somehow, that your display can go for 2560x1080@60Hz, but it will not use that native resolution. So something limits the bandwidth and that could be that cable you use right now, But could also be amdgpu without DisplayCode enabled, not sure if this limits features like this.


#10

the amazons say, that they cannot cancel that order anymore, because: they r already wrapping it in protective paper… :slight_smile:
so i will be able to try it…
sending it back is too harsh, i think…
1 spare gfx cable is not too much, i guess…

the monitor manual recommends HDMI 1.4…
that same my HDMI cable worked fine with the HD7660D at 2560x1080@60 (i cross-checked that via the monitor’s OSD)…

-arne


#11

seems like amdgpu has a problem with EDID parsing…
https://bugs.freedesktop.org/show_bug.cgi?id=103141
so the DVI cable wont help…
maybe a DP cable could help… :slight_smile:
-arne


#12

with the proprietary amdgpu-pro driver i not only get 2560x1080@60Hz
but also OpenGL compliance:
OpenGL version string: 4.5.13474 Compatibility Profile Context 17.10.2

here is my upstream bug report:
https://bugs.freedesktop.org/show_bug.cgi?id=103141

Thx. Bye.