AMDGPU improvements for Manjaro OUTDATED


#867

can confirm

Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics]
           Display Server: X.Org 1.19.3 drivers: amdgpu (unloaded: modesetting) Resolution: 1366x768@59.79hz
           OpenGL: renderer: Gallium 0.4 on AMD KAVERI (DRM 3.15.0 / 4.12.4-2-MANJARO, LLVM 4.0.1)
           version: 4.5 Mesa 17.1.5


#868

coming
http://www.phoronix.com/scan.php?page=news_item&px=RADV-Fixes-GCN-1.0-1.1


#869

Hey mate, forgot I posted this thanks for the help. I had to remove ocl-icd package and about 20 packages that depended on it that didn’t seem important to install opencl-catalyst. And NO-WAY! Its working perfectly now and more solves per sec than I have had before! You just saved me a heaps of work. I can’t beleive it works. I have 1x7950 and soon to put in 2x7970 for mining should be able to run it on linux now instead of windows. I tried for so long to get this working under ubuntu and it only worked on 15.10 which was unsupported.


Is somebody still using the Catalyst drivers?
#870

Cool. You can thanks @philm for this wide support.

So… TL;DR ocl-icd should be made to conflict with opencl-catalyst?


#871

I tried to switch to amdgpu with a gcn1 card, but it just stops at the “starting systemd” message. I switched to vt and installed kernel 412 (was on 411) and only change was that now last message was something about irq domain (edit:this was reported several times in the latest stable update topic, so i believe it is unrelated to amdgpu). Am i missing something?

edit: journalctl seems to think everything is fine in regards to amdgpu, no errors and ok initialization messages. Then it fails at: kernel: sddm[663]: segfault at 3 ip 0000000000000003 sp 00007ffe3ba55a28 error 14 in sddm[400000+72000]


#872

please always attach your xorg log. thats the most important part in here (as well as journalctl -r -b -p err)


#873

Hi all, I’ve just found this conversation and realised I don’t have an Xorg file either. I have a Radeon 560 card and have been having some problems with the compositor (can’t run KDE at all because the panel keeps freezing) and tearing. Can anyone please advise me what to do here? I am about to do a fresh install back to Xfce as Plasma is no good for me (the freezing). What should I do once I have installed it? Should I run the MHWD tool with any options?


#874

because you dont need one at all.

Rx560? X5600? Whats your card?

Create a topic about this problem with the correct informations :joy: So its easier for us to help.


#875

sorry, Rx560


#877

Looks like there’s a certificate error?

$ sudo pacman -Syyu amdgfx/mhwd-addon-amdgfx-hwe
    :: Synchronizing package databases...

    ....

    error: failed retrieving file 'amdgfx.db' from flatchest.org : SSL: no alternative certificate subject name matches target host name 'flatchest.org'
    error: failed to update amdgfx (download library error)
    error: target not found: mhwd-addon-amdgfx-hwe

#878

This repo is down for a half to a full year or so :joy: remove it from your pacman.conf


#879

it may be a good idea to update the original post or put an OUTDATED header


#880

I want know which video card is working? Or both?
How to check it?
There’re Intel UHD Graphics and AMD RX550 on my laptop.


#881

Please create a new topic for this.


closed #882