AMDGPU improvements for Manjaro OUTDATED


#806

What do you mean?


#807

Hi @Tids did you try to get the new open source OpenCL driver fro AMD (released this Week-end) working on Manjaro?


#808

I’ve tried, but sadly the LLVM part fails to build for me :frowning:

Lets hope someone will make a working AUR package


#809

That would be great indeed :slight_smile: I also tried to compile the patched LLVM/Clang wihtout success until now. But first results on reddit for rendering with Blender are promising. So it’s definitely worse pursuing.


#811

could you guys try out a “new” version of the mhwd-db? This includes the configuration-less xorg setup, as well as mesa-prime configurations for mwhd.

More you can find in here:

Would be nice if this already works :smiley: Sadly I can’t test this by myself at the moment, because I’m stuck on my AMD only system.

You can install the package with

pacman -U mhwd-db-0.6.0rc1-4.1-any.pkg.tar.xz 

and then go to your manjaro settings, and reinstall video-ati;amdgpu;intel;noveau or one of the -prime things


#812

I think it would be better to start a new topic so that more attention is paid to it. :slight_smile:


#813

Yes I think so. 807 posts :grinning: It is getting hard to follow for new readers.


#814

It’s in unstable now. So no need for it anymore. But of course it needs testers :smiley:


#815

Would like to test.

inxi -G
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480]
           Display Server: X.Org 1.19.3 driver: amdgpu
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD POLARIS10 (DRM 3.10.0 / 4.11.3-1-MANJARO, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.1.1

I’m actually on testing, do I need to switch to unstable? Not new Linux, but not much familiar with Manjaro.


#816

Please just take a look in mhwd it there is even an entry for your Card. I dont think we ship polaris ID yet.


#817

is that enough? Still on testing though

edit: same screen with mhwd-db-0.6.0rc1-2 from unstable


#818
mhwd -li -d
   NAME:	video-amdgpu
   ATTACHED:	PCI
   VERSION:	2016.08.22
   INFO:	X.org amdgpu video driver. Standard open source driver for AMD graphic cards.
   PRIORITY:	3
   FREEDRIVER:	true
   DEPENDS:	-
   CONFLICTS:	-
   CLASSIDS:	0300 0380 
   VENDORIDS:	1002

#819

So Polaris was already in. Nice to see :smiley:
More IDs will be added later at some point. For now the most interesting part would be if the prime support works.

Because in this case we can remove bumblebee for intel/amd; intel/nouveau systems


#820

Any way to install the video-amdgpu-experimental+ ?, my card is GCN 1.0 (HD7850), at the end of the installation this message: error: invalid argument: -setgl.

When reboot the system the lxdm works without problem but when choosing a desktop the screen goes black, the same happens if I wait a few seconds in the lxdm doing nothing. I try to start in console but it doesn’t appear in the correct resolution and I cannot do anything.

I’m stuck in kernel 4.10 with catalyst drivers :(, the video-ati is not a option, many games have poor performance with this drivers :frowning:


#821

Both, radeon (video-ati) and amdgpu use radeonsi for Opengl support. You will mostly not get better performance with a different kernel driver.

video-amdgpu-experimental will stay broken for a while, because many parts of the -hwe package will integrated into the manjaro standard package and i’ll also try to integrate experimental as option later.

However, you can try to uninstall everything from mhwd, remove all xorg.configs and then

pacman -Syu amdgpu-experimental

this should still work that way. :slight_smile:


#822

Thanks for reply but not work for me :neutral_face:


#823

@Tids Hello, I’m using KDE manjaro and I have a sapphire R9 270x. Is it possible to try amdgpu with my card ?. I understand that it is from GCN 1 and as my language is Spanish I do not understand much although I use the translator. Here is the info of the inxi -G command and the mhwd. Thank you

inxi -G

Graphics:  Card: Advanced Micro Devices [AMD/ATI] Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X]
           Display Server: X.Org 1.19.3 driver: radeon
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD PITCAIRN (DRM 2.49.0 / 4.9.31-1-MANJARO, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.1.2

mhwd
> 0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
NAME VERSION FREEDRIVER TYPE
--------------------------------------------------------------------------------
network-r8168 2016.04.20 true PCI

> 0000:01:00.0 (0300:1002:6810) Display controller ATI Technologies Inc:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
        video-catalyst            2017.03.12               false            PCI
             video-ati            2017.03.24                true            PCI
            video-vesa            2017.03.12                true            PCI


#824

Yes, but right now you have to do it all by yourself.

wich means:

  1. block radeon kernelmodule from loading
  2. force amdgpu kernel to load
  3. remove radeon(ati) xorg driver
  4. install amdgpu xorg driver
  5. run mkinitcpio -P

I cant find time to work on it for now (maybe on the weekend - mostly testing it…). :frowning:


#825

@Tids. Thanks for your help. I follow this instructions for me:
1- Crearte a blackclist file “radeon_blacklist.conf” in /etc/modprobe.d/ with this contain:

# This file is Part of the amdgpu-experimental package
# DO NOT EDIT OR REMOVE
blacklist radeon

2- Force amdgpu with create a file “amdgpu.conf” in /etc/modules-load.d/ with this contain:

# This file is Part of the amdgpu-experimental package
# DO NOT EDIT OR REMOVE
amdgpu

3- Remove the radeon(ati) with option in mhwd.
4- Install xf86-video-amdgpu with pacman.
5- I run “mkinitcpio -P” with root option.

Now me inxi -G is:

Graphics:  Card: Advanced Micro Devices [AMD/ATI] Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X]
           Display Server: X.Org 1.19.3 driver: amdgpu
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD PITCAIRN (DRM 3.8.0 / 4.9.31-1-MANJARO, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.1.2

Before this i have two problems:
1- SDDM view small in login screen. I solve it with edit /usr/share/sddm/scripts/Xsetup with option dpi and HDMI off.
2- View line purple in the left screen in HDMI output. I solve it with edit /usr/share/sddm/scripts/Xsetup with --set audio off.

Is it possible to operate the audio output via HDMI ?. With the radeon controller working properly, but with this one it does not work for me. Thank you.


#826

@Tids. How back to the radeon drive?.

I try with this:
1- Remove radeon_blacklist.conf
2- Remove amdgpu.conf
3- Uninstall amd-gpu
4- Install video-ati
5- run mkinitcpio -P

But before run this command, stuck in login screen, don’t charge the screen SDDM. I solve install again amdgpu with your instructions and now work fine, but i install video ati again. Thanks