AMDGPU improvements for Manjaro OUTDATED


#786

Mine is an Asus Strix (the fancy model) also 8GB. I’m too on kernel 4.10.4. Mi profile is always outdated hehehe

The cpu model is i5-4670K 3.4GHz at stock, I never oc it (I thought i was gonna do it when I bought it). I have yet to try that wow option (cpu mask). Wow is on the data hdd (seagate st1000dm003 which is pretty fast ~200read ~180write).

I’m lazy and I still have some things to try out, and, except for the cpu mask I don’t see any much improvement on the others (unless it heavy relies on loading from storage instead from ram, in which case hdd/ssd speeds would impact fps).

Maybe it’s the PoL script.

Thanks.


#787

well, OC’ing my CPU from 4 to 4.5GHz already made a huge impact.
Setting the processaffinity helps, but most of the game is still in one single thread, so single-core performance is still important for WoW.

You can also try to sudo cpupower frequency-set -g performance before you start WoW - it gave me much more stable fps - but I am not sure if it is available for your cpu. Try cpupower frequency-info -g - it should list all available governor’s for your CPU.

Also, according to some optimization guides, changing the disk scheduler to deadline has an impact, so I guess that drive speed (and in those terms, access speed) matters for WoW.
Access speed != read-write speed :wink:


#788

@Tids after the last changes and updates of mesa I decided to try one more time amdgpu-experimental+ from manjaro-settings-manager (unistalling first radeon+) but I had the same issues which I mentioned in the previous post. System refused to boot (it stopped at “started TLP system startup/shutdown”). Anything new regarding this?


#789

Did you try to look at the xorg log? maybe there is something in it - also the kernel log. It works for me just fine (on testing)


BTW. I’ve tried the Vulkan-Beta of Mad Max today. Usually my System is to weak to run Mad Max. -> 10-20FPS. Now with Vulkan i can play on “Very High” with >40FPS :grin:. Sadly, right now it requires Mesa-git. So i’ll buy the game again when it’s out of Beta status and Mesa 17.1 is released. But that’s so awesome!


#790

Mad Max is already running great here on OpenGL, will be glad to see how Vulkan skyrockets :wink:

Edit: And it seems like Vega will still run without DC/DAL:
http://www.phoronix.com/scan.php?page=news_item&px=AMDGPU-Linux-4.12-Pull-Vega

http://www.phoronix.com/scan.php?page=news_item&px=Radeon-Vega-10-Support

and a comment from the Phoronix-active AMD dev:

Or… hey, here’s a crazy thought… we will finish refactoring DC as discussed and it will be accepted upstream.


#791

It was so CPU bound, thats why it was really not playable for me on a A8-7600 - But thats fixed with Vulkan. :grin: An yeah, good news for Vega! (but it still sucks for many without HDMI-Audio)


#792

You mean for TV’s and monitors with built-in speakers? I thought no one would care when you can buy decent speaker systems for ~40-50€ Or is it something else entirely?


#793

Yes, but more in the case of Home Theater PC. A nice HTPC-setup will just not work like it could.


#794

About that message @BS86 reported a couple of months back:

amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff

I’ve been reading about it but I can’t find anything concrete and a solution.

Is this something to worry about?


#795

Not at all. It’s often just some Windows-UEFI related thing. Because graphicscards have some more windows related boot features.

If you have UEFI enabled, try to look for a button on your graphicscard that switches the card in UEFI mode. That might help (or does make things worse :slight_smile:). As long as it works correct, everythings OK.


#796

I’ve never heard nor seen such button in graphics cards… I guess I can live with the message (If it ain’t broke, don’t fix it :smile:)


#797

It’s not windows specific, and in some cases it doesn’t even seem UEFI related.

[quote=“Chazy, post:796, topic:7890, full:true”]I’ve never heard nor seen such button in graphics cards… I guess I can live with the message (If it ain’t broke, don’t fix it :smile:)[/quote]If you aren’t on an APU/laptop though, you may want to report your details here.


#798

quick benchark results (Unigine-supperpostion) minimum settings 512X512

Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics]
           GLX Version: 3.0 Mesa 17.0.3
           Display Server: X.Org 1.19.3
"Driver": "Radeon",
"Max": "24.04",
"Avg": "15.06",
"Min": "11.77"
"Driver": "AmdGPU",
"Max": "27.24",
"Avg": "16.77",
"Min": "13.01"

#799

i just switched back to radeon for testing (getting abyssimal fps in dirt-rally and can’t find the cause -.-)
after switching back to amdgpu (and installing va and vdpau drivers if that matters ^^) inxi -G now says:

Graphics: Card: Advanced Micro Devices [AMD/ATI] Hawaii PRO [Radeon R9 290/390]
Display Server: X.Org 1.19.3 drivers: amdgpu (unloaded: modesetting) Resolution: 1920x1080@60.00hz
GLX Renderer: Gallium 0.4 on AMD HAWAII (DRM 3.9.0 / 4.10.10-1-MANJARO, LLVM 3.9.1)
GLX Version: 3.0 Mesa 17.0.3

i see that many have (unloaded: modesetting) in their output and on the games that worked before everything seems fine…but as it wasn’t there before, i’m just wondering if something changed or what the deal is?


#800

modesettings is the Xorg Fallback driver for all the hardware with working Kernel Mode Settings and OpenGL support. It will be loaded before radeon/amdgpu. Because Xorg sees that there is radeon/amdgpu available, it will unload modesettings.

Why it now shows up in inxi? Maybe because there was an update for it - but i don’t know…


#801

ah, now i get it, modesetting is unloaded…my first thought was that amdgpu is unloaded because of modesetting :sweat_smile:


#802

Just to leave this here.

the newly Polaris 12 architecture (RX 500 series) does not work right now on Linux because of THIS. It will be fixed with Mesa 17.2 (and hopefully they will backport it also to Mesa 17.1 that will be released later this month)


#803

works fine for phoronix


#804

Phoronix is using git versions :wink:


#805

Will this work on my Setup?