AMDGPU improvements for Manjaro OUTDATED


#766

Dont use unstable right now, yep :wink:.
I really have no idea how all that GLVND works and will start to work with it when it comes to testing.

The latest

is this one: https://github.com/manjaro/packages-community/pull/276


You could try to remove amdgpu-experimental from pacman, uninstall all the video-* in MSM and only re-install amdgpu-experimental xf86-video-amdgpu It should work that way


#767

I tried but didn’t boot. The problem appears when I’m trying to change the drivers although it works perfectly with radeon+.

Ok I’ll stay with radeon+ until you’ll ready to work with it. :slight_smile:


#768

Halleluja, AMD is going strong:
http://www.phoronix.com/scan.php?page=news_item&px=140-Patches-Vega-RadeonSI

http://www.phoronix.com/scan.php?page=news_item&px=AMDGPU-GFX9-LLVM-5.0-More-Patch


#769

Can someone with a wow client (no matter if vanilla, tbc or wotlk) confirm if the hardware cursor is working ok? It was working fine with manjaro 17-alpha1 and wine 2.0-rc1 (or something like that). Then I fresh installed 17-rc1 and it stopped working, now the cursor blinks and disappears when it’s moving…

It’s annoying to play without that hardware cursor option. Is it possible that it’s the new xorg or mesa version? I’m using the amdgpu+ profile.

Btw, @Tids you may want to update your PR since latest changes are conflicting.


#770

no such issue here with PlayOnLinux on a 64-bit Wine 2.4 setup. You can not have those versions any more if you play the official client, it’s all 7.1 Legion. The load screen just depends on the content you are currently in.


#771

I’m aware of that, I use those versions cuz sometimes I help with the open source projects that powers the server side of those versions, so I play them (for both testing and fun).

Can you really play retail on linux? Last time I tried it was impossible, the loading times take forever… More or less like on Windows but then the lag doesn’t let me play… I can play fine with older versions except for the hardware cursor option. I don’t want to lower the graphics settings more than the ones recommended, what level of settings do you have? The one I always set to max is the max view distance.

Anyone knows how to fix the hardware cursor option for older versions?

Also, does wine need any special configuration (like disable or change order of libraries) either for retail (legion) or the older versions?

Thanks.


#772

Thanks :sunny: should work again.


#773

I just found out that the sloopy and lagged cursor (without hw cursor) is caused by vertical sync, so disabling it solves the problem and hw cursor can be enabled (but no huge difference as when disabling vsync).


#774

I have absolutely no issues with retail WoW on my AMD/AMD system. However, I had to tell WoW to use more threads with that: http://wowwiki.wikia.com/wiki/CVar_processAffinityMask

and switching to a ck-kernel OR setting the governor to performance while playing results in a much more smooth framerate.
On windows, I would have more frames, but it works fluent on my 2k screen in Linux (I had some areas where fps dropped to 20 today, but those are not appearing often.

Back when I still used a 32-bit PoL Wine, it lagged a bit.


#775

I tried retail and I got max 20-25 fps but that’s without PlayOnLinux (that configures wine). I can’t fly or move on open areas without lagging (less than 5 fps).

Another thing would be the wow graphics settings, do you have something maxed out? Also do you use dx11 or dx9?

I’ll SET processAffinityMask "15" and see what happens.

I guess I’ll have to give PlayOnLinux a try (or search for the configs).


#776

Playing on Preset 7 of 10 on 2560x1440 and Antialiasing off (check render scale setting in the advanced settings, reducing it from 200% to 100% gives a lot of fps)
Using DX9 as the option for DX11 is not offered here - if there is a way to make it work, I would really like to give it a try :wink:

My fps are between 25 and 160 depending on the area I am in. General flying gives between 30 and 50 fps.

edit: Today’s update to Mesa 17.0.2 in testing branch seems to have improved the fps a little bit (definitely not much, but still)

Well, I used the PoL Battle.net script, modified it for 64bit, added some things that are installed in WoW, SC2 and Diablo III scripts, and manually installed vcrun2015 with winetricks during the installation as it still is not available in PoL :sleeping:


#777

You can try and set the API using the config file SET gxApi "D3D11". I don’t know why but it gives me a error:

World of Warcraft was unable to start up 3D acceleration.

I have to set it to D3D9. I made some adjustments and is playable.

Thanks.


#778

Well, I guessed that :wink: actually, I tried that, but DX11 is still not really functional in Wine 2.4 - but each update gets closer to it.


#779

But why DX11? I’d use DX9 + wine-gallium-nine on radeonsi, So you can use native direct3d support instead of the direct3d -> opengl layer of wine


#780

Any guide on how to do that?


#781

install wine-staging-nine run

winecfg

on staging tab there should be

“Enable Gallium Nine for better D3D9 graphic performance”

I dont know if this works, otherwise you need to build aur>wine-gaming-nine


#782

is gallium-nine support already in amdgpu/radeonsi? The last guide I checked still mentioned that one needs a modified driver to use it with mesa.

Edit: Blizzard App, formerly known as Battle.Net Launcher does not start on my machines with staging, no matter which one I try.

edit2: Holy ****, wine-staging-nine works when starting WoW directly, and it’s performance just skyrocketed … THX @Tids for the hint


#783

It always was. Radeonsi is a gallium3D driver from the start, so was the R600 before. The last non-gallium was R300 and even this was has made the port back then. :slight_smile:

I’ve also set the version to “Windows 7”. But I can not test for WoW :frowning:


#784

I wonder what you did to get that performance with preset 7/10 and 2560x1440… My resolution is 1080 and I had to put preset 1 but environment at 10 to stop the lag and fps < 25. Maybe it’s the mesa version? I’m on stable.

Thanks @Tids it really improved performance.


#785

Stable also has Mesa 17.X, there is not so much difference in there.
I did nothing special, but I have one of the fastest RX480’s (the MSI RX480 8GB X) - the 4GB versions have slower memory which slows down the card noticeably (I had one for a few days).
Also, I am using Kernel 4.10 (switching to the newsest mainline kernel as soon as possible, most of the time when rc4 or rc5 is out) - Intel and AMD cards benefit a lot from newer kernels, especially 4.9 received a lot of optimization and you are still using 4.8 according to your profile.

Also, it could be a CPU limit, your profile does not state which i5 you are using (My FX8350 is currently running at only 6 cores but with 4.5 GHz per core)

Edit: And of course, WoW is on a SSD :wink: