AMDGPU improvements for Manjaro OUTDATED


#745

[quote=“Tids, post:743, topic:7890”]
So everyone has only developed for Nvidia (because of working drivers) and so it is Nvidia optimized.
[/quote]“Being optimized” and “to optimize” are different things. And the active action of “to optimize” doesn’t happen simply because others suck.
If when you have an nvidia card, you don’t stumble on bugs and everything goes, this doesn’t mean you “optimized®” their software with gameworks or what. Or worse, the implied “destroy performance for others”.

And I say this knowing a dev that yes, has an nvidia card… But he uses nouveau nevertheless.

[quote=“BS86, post:744, topic:7890, full:true”]Let me quote myself here:
[/quote]Man, world isn’t black and white.
Nvidia stinking with its proprietary stuff (which I never negated, fiy), doesn’t mean other aren’t blamable for their problems.

Now, I don’t know all the ins and outs of Dolphin specifically, but I could link you a handful of HUGE issues with other emulators (with intel and amd windows driver). Mesa instead lacks of multi-thread optimizations, so you see there’s a reason if the world seems to revolve around green team, for as much I can despise them.


#746

small progress, although the title promises more than there is really there: Experimental Patches Revised For AMDGPU HDMI Stereo 3D, DAL/DC Now Supported


#747

Hi there - i’m a bit confused ^^
I’d like to switch to amdgpu on my r9 290 (encountering the strange performance-regressions in some games :confused: ), but the initial post seems “outdated” and when skimming through the thread i found several - sometimes contradicting - updates…so i’d like to ask what the current status/how-to looks like?
And if things should go south, i would think that i should still be able to boot to tty and revert back to radeon, right?

thanks in advance :wink:

oh and if the first post is still relevant:
inxi -G:
Graphics: Card-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
Card-2: Advanced Micro Devices [AMD/ATI] Hawaii PRO [Radeon R9 290/390]
Display Server: X.Org 1.19.1 driver: radeon Resolution: 1920x1080@60.00hz
GLX Renderer: Gallium 0.4 on AMD HAWAII (DRM 2.49.0 / 4.10.0-1-MANJARO, LLVM 3.9.1)
GLX Version: 3.0 Mesa 17.0.0
mhwd:

0000:06:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:


              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

0000:01:00.0 (0300:1002:67b1) Display controller ATI Technologies Inc:


              NAME               VERSION          FREEDRIVER           TYPE

    video-catalyst            2016.09.03               false            PCI
         video-ati            2016.08.22                true            PCI
        video-vesa            2012.09.18                true            PCI

#749

It is. Sorry I didnt found the motivation to create the new topic :joy:

It should be easy: you install mhwd-addon-amdgfx-hwe, when thats done, you go to the settings manager and there should be video-amdgpu-experimental+ for you to install.


#750

well, that’s easy :smiley:
and am i right in the assumption, that if things don’t work out i should be able to boot into terminal and simply do “mwhd -i pci video-ati” to switch back to radeon? would rather not have to re-install :sweat_smile:


#751

first

mhwd -r pci video-amdgpu-experimental+

otherwise radeon is still blacklisted (:


#752

always good to ask ^^
but if i try to install i get:
Error: config ‘video-amdgpu-experimental+’ conflicts with config(s): video-ati
should i force-install it? remove video-ati first? or is something wrong?
Don’t know if the removing of video-ati as in a post from aug 16 is still the way to go :confused:


#753

:+1:

Never force anything in mhwd :joy:


#754

never had to tinker with mhwd, so better save (and ask) than sorry xD
but seems to work, performance in bioshock infinite went up - all good :slight_smile:
thanks for the info and the work you put into this! :smiley: :+1:


#755

With all newer versions we are able to have OpenGL version 4.5, but I don’t see this anywhere. For example, in the compositor I can only select “OpenGL 3.1” as rendering backend.

Looking at glxinfo:

$ glxinfo | grep version
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.0.0
OpenGL core profile shading language version string: 4.50
OpenGL version string: 3.0 Mesa 17.0.0
OpenGL shading language version string: 1.30
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.0.0
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

Why is that, the max compatible version is 3.x? Where’s the improvement in having support for OpenGL 4.5 but not be able to use it?

My gpu is amd rx 480 using the video-amdgpu+ profile. Is it not compatible yet? If it is, how can I test the 4.5 version?


#756

I was confused about this in the beginning, too ^^
The important part is the “OpenGL core profile version string”, and thats 4.5 for you, too :slight_smile:


#757

Yeah, but that does mean that applications that support 4.5 will use it? Or will still use the 3.1? That’s my concern.


#758

Thats a bit hard to explain, since i dont fully understand it myself. With OpenGL 3 there was in switch, a bigger cleanup withing the OpenGL protocolls. After that there are 2 sorts of OpenGL

###OpenGL Compatiblity Profile
This one is still based on the old API, has all the depricated functionality and is mostly not used, but still around for compatiblity reasons

###OpenGL Core Profile
This is the cleaned up version, without compatibility to the old API

Mesa dont supports the depricated funktionality. So the maximum OpenGL version is indeed 3.x. But mesa supports the core profile, so within this modern “path”, it supports up to OGL 4.5


In short:
Your used by application OpenGL Version is 4.5.
Your OpenGL depricated API version is 3.0.


#759

They could have just forked it and not mess it up… I hope they at least have two branches… :smile:


#760

Just a little notification. Many Radeon RX 470 and 480 seems to be at a all time low today. You can get the 470(8GiB) for around 210€ and the 480(8GiB) for 240€

:wink:


#761

yes, the announcement arrived that at the beginning of April, RX580 and 570 will be revealed, later that month RX560 and RX550 will follow (all further optimized Polaris and Polaris 12) - Vega will come somewhen before the end of June.


#762

@BS86 Is that a conference? Official? Share a link plz


#763

This question is for everyone on an amd card and plays games, How is the performance and are there any major problems? I know back when i had a 290x i was so frustrated with getting games to work properly i just went back to windows.
This is the reason i switched to nvidia and since the 1080ti was just announced i want more information on the amd side before i pull the trigger.


#764

@Chazy there are several, the one I read was german, so not really good to be posted here, but for example this one, although they say that Vega launches about a month earlier: http://wccftech.com/amd-reportedly-launching-rx-500-series-april-vega/

the Polaris12 is only an assumption from my side, because there is already kernel code available for that one, but no cards yet released with that


#765

@Tids i’m using radeon driver but sometimes switching to amdgpu-experimental without installation issues. Two days ago I tried to do the same but the system refused to boot (it stopped at “started TLP system startup/shutdown”).

I tried to chroot and remove amdgpu-experimental from manjaro-settings-manager but not deleted (the message was something like “amdgpu-experimental doesn’t exist”). I tried to install radeon but not installed. I tried also with cli commands to unistall amdgpu-experimental and install radeon and ati drivers but all failed. I was forced to restore the system from a clonezilla backup.

I’m on unstable branch and I think that may be related with this. What is your opinion?
I see also that I’ve installed mhwd-addon-amdgfx-hwe 20161231-1, is that the latest one with the recent changes in your script?

╰─ inxi -Gx
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 OEM]
           bus-ID: 01:00.0
           Display Server: X.Org 1.19.2 driver: N/A
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD OLAND (DRM 2.49.0 / 4.10.2-1-MANJARO, LLVM 3.9.1)
           GLX Version: 3.0 Mesa 17.0.1 Direct Rendering: Yes