AMDGPU improvements for Manjaro OUTDATED


#1

As an AMD user (and supporter) i want to have the best support for the AMD graphicsstack in my system. Thats why i’ve started a little project called “amdgpu hardware enablement”.

There are multiple goals to reach

  • Enable OpenCL, VAAPI and VDPAU support for AMDGPU(Opensource) and Radeon :heavy_check_mark:
  • Activate AMDGPU support for some experimental “Sea Island”(GCN 1.1; Gen2) Cards :heavy_check_mark:
  • ??? :heavy_multiplication_x:
  • Integrate this into Manjaro :heavy_multiplication_x:

If you want to have amdgpu support for your card, i need your help, because this is experimental i only enable it separately for every single card.

what do i need?

following infos

inxi -G
mhwd

i need those infos because i need to add PCI-ID fors your Hardware to a file to support it. i Also will check if this hardware is GCN 1.1. Because only GCN 1.1(Gen2) is supported in experimental

After this i will update the pkg so the support will be enabled for you to test

how to install this?

You need to add our Repo. Since this is a “manjaro only”-thing we can not ship in AUR.
You can use this command to add it

echo -e "[amdgfx]\nSigLevel = Optional TrustAll\nServer = https://flatchest.org/s/manjaro/\$repo/\$arch" | sudo tee -a /etc/pacman.conf
or add following code to the end of your /etc/pacman.conf

[amdgfx] SigLevel = Optional TrustAll Server = https://flatchest.org/s/manjaro/$repo/$arch

after this you can just install it

sudo pacman -Syyu amdgfx/mhwd-addon-amdgfx-hwe

now go to your manjaro settings manager and install “video-amdgpu-hwe” (or video-ati-hwe for older cards)

Additionals

for R600 and RadeonSI users there will be some adjustments via Env-Variables
R600_DEBUG="precompile llvm sisched forcedma sbcl"
that will hopefully improve the openGL performance in some games. You can find this in the file /etc/profile.d/10-amdgfx_r600ops.sh after installing video-amdgpu-hwe; video-ati-hwe.

##FAQ
Q: what kernel is supported
A: i always want to support the latest stable kernel. Right now only Linux47 is supported.
please check yourself

zgrep -I "CONFIG_DRM_AMDGPU_CIK" /proc/config.gz

only if there is CONFIG_DRM_AMDGPU_CIK=y it can work


Q: does it work for sure?
A: for GCN1.2(Gen3) it should always work. for GCN1.1(Gen2) it depends, since this is very experimental

Q: will you support GCN1.0 (Gen1;southern Island)?
A: there is work going on to support this in future releases of linux. so if there is official (experimental) support for “SI” i’ll try to support this too, yes :slight_smile:

Q: there now is tearing, what can i do?
A: ask me & revert to the default config in manjaro :wink: (for GCN1.1 tearing will happen)

Q: is MultiGPU(PRIME/Bumblebee) supported?
A: No

Q: Why is steam broken now?
A: if you switch back from fglrx there could be a library conflict with the optnsource parts. Run

find ~/.steam/root/ ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

to fix this.


Q: Will there be Support for AMDGPU-Pro?
A: No.

###Bugs & improvements?
just tell me!

###known bugs

  • For GCN1.1(Gen2) there is tearing around your mouse pointer on Xorg-Server

I need help installing the new opensource Amd graphics driver = AMDGPU
AMD Users: removal of Catalyst an option now?
Unable to update. xorg/catalyst conflict?
What is the best driver for an A10 APU Black (Kaveri)?
[Stable Update] 2016-09-13 - Xorg-Stack, Firefox, Plasma5, KDE Apps, Manjaro Tools, GCC
Gnome 3.22.1 and Catalyst drivers [Testing update 2016-10-14]
FGLRX picks wrong resolution after turning off the monitor
FGLRX picks wrong resolution after turning off the monitor
Radom crash x server
AMDGPU PRO drivers support / Kernel question
AMDGPU on Sempron 3850 APU with Radeon R3 ( HD 8280 )
AMD Users: removal of Catalyst an option now?
FGLRX picks wrong resolution after turning off the monitor
#2

[quote=“Tids, post:1, topic:7890”]
i need a few people who want to destroy their systems by testing AMDGPU kernel driver and xorg driver on GCN1.1 Systems.
[/quote]I do not need help with destroying my system[quote=“Tids, post:1, topic:7890”]
inxi -G
mhwd
[/quote]I do not know why you would mhwd but here it is:master-andreas@master-pc:~$ inxi -G

[details=Summary]master-andreas@master-pc:~$ inxi -G
Graphics: Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics]
Display Server: X.Org 1.17.4 driver: fglrx
Resolution: 1366x768@59.79hz
GLX Renderer: AMD Radeon R7 Graphics
GLX Version: 4.5.13399 - CPC 15.201.1151
master-andreas@master-pc:~$ mhwd

0000:00:01.0 (0300:1002:130f) Display controller ATI Technologies Inc:


              NAME               VERSION          FREEDRIVER           TYPE

    video-catalyst            2014.02.04               false            PCI
         video-ati            2016.08.22                true            PCI
        video-vesa            2012.09.18                true            PCI

0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:


              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

[/details]

shouldn’t there be a new option after install the file or am i missing something(is kaveri not supported?)


#3

Nope. i always need to add a specific PCI-ID to the list of supported “things”. thats wha i need the info :slight_smile: please now test again. the option should be there now. (make sure you use linux 4.7)


#4

i am using 4.7.2-1 unstable branch not there


#5

still not there? have you reinstalled the pkg?
please try again, also close and re-open manjaro settings manager after installation.


#6

ok tried it and … it bricked… it couldnt load some kernel module or something


#7

Please take a photo or something. maybe i can work on it :slight_smile:


#8

I do not own a camera(and i have dislexia therefore i cant write it down and report it here also i am lazy)


#9

:wink: hehe


#10

@master_andreas right now we can not support GCN1.1 because we’re again missing support for “experimental AMDGPU” in kernel: see https://bugs.manjaro.org/index.php?do=details&task_id=15

also there is now a AUR pkg https://aur.archlinux.org/packages/mhwd-addon-amdgpu-hwe/ (:slight_smile: i’ll enable support for your System when it’s possible again. So maybe we can make it work then :smiley:


#11

sure make sure it wont break again


#12

Now there also is “video-ati” support. it will enable VAAPI,VDPAU,OpenCL (for supported hardware) and will force glamor acceleration for all cards.


so maybe, if you use this on some older cards there could be more tearing or everything will be much smoother. Please test if possible (:


#13

I have Cedar at my work HD 5450 (I gues because inxi -G say 5000 6000 etc series I tried catalyst and it says HD 5450) and unstable branch I want give a shot. Does It suits this card. I wonder if possible like rt-kernel for GPU improvement :slight_smile: I made some things from Arch Wiki but I m not sure those works.
Thanks for your effort.
I like AMD :slight_smile:


#14

in case of video-ati-hwe (in words: videodecoding acceleration) it should work.
you will also notice a performance ++ on desktop usage (or bad tearing ;))

in case of video-amdgpu-hwe there is nothing i can do. its not supported and will never get support.


#15

My GPU sensors say after 10 minute bootup about 70°C after watching some videos around 72 75°. I hope this works. By the way there are some interesting. When I use Catalyst CPU sensors heatup around 60 75°C but Ati gives me around 35-40°C and Ati performanse much better than Catalyst.
This is so cool project
Thanks.


#16

Hey thanks, I installed

I wonder that why no config file in X11/mhwd.d/ or in /xorg/


#17

cat /etc/X11/xorg.conf.d/90-mhwd.conf
should bring something up.


#18

`[onem@onem-pc ~]$ cat /etc/X11/xorg.conf.d/90-mhwd.conf
cat: /etc/X11/xorg.conf.d/90-mhwd.conf: No such file or directory
[onem@onem-pc ~]$

[onem@onem-pc ~]$ cd /etc/X11/mhwd.d/
[onem@onem-pc mhwd.d]$ ls
[onem@onem-pc mhwd.d]$ cd /etc/X11/xorg.conf.d/
[onem@onem-pc xorg.conf.d]$ ls
00-keyboard.conf
[onem@onem-pc xorg.conf.d]$

`

But everything works fine even better.


#19

Thats because you dont really need a xorg.conf file with the free drivers. but there should be one :sweat_smile: can you re-install video-ati-hwe in your settings?

€dit:
it now conflicts ‘video-ati’. the mistake (maybe) was when you firstly installs video-ati, then install video-ati-hwe and then removes video-ati it’ll also remove the xorgconfig.


#20

I first uninstalled video-ati then installed video-ati-hwe and reboot. Reinstall solved the problem. Thanks :smiley:

`[onem@onem-pc ~]$ cat /etc/X11/xorg.conf.d/90-mhwd.conf

Generated by mhwd - Manjaro Hardware Detection

Section "Device"
Identifier "Device0"
Driver "radeon"
BusID "PCI:1:0:0"
Option “DRI3” "1"
Option “DRI” "3"
Option “AccelMethod” "glamor"
EndSection

Section "DRI"
Group "video"
Mode 0666
EndSection

Section "Extensions"
Option “Composite” "Enable"
Option “RENDER” "Enable"
EndSection

Section "InputClass"
Identifier "Keyboard Defaults"
MatchIsKeyboard "yes"
Option “XkbOptions” "terminate:ctrl_alt_bksp"
EndSection

`