Amdgpu Error while booting

I have an issue with amdgpu, I get the following error: ibb.co/DWBT2qY
I can’t continue to boot by pressing enter.

The first boot worked fine as well as one boot with the fallback initframes, now both (regular and initframes) do not work anymore.

Even though I chrooted into the installation and added amdgpu, amdgpu_b10 and acpi_video10 to modules array of mkinitcpio.conf: ibb.co/3WDx7fY

I have a LUKS encrypted Manjaro Gnome System on Linux 5.8, running on a ThinkPad T14 AMD.

Any ideas?

PS.: The Forum doesn’t let me embed images and links, why is that?

see this

Thank you, I followed this and I could again boot once.
Now I only get the second error for every consecutive boot-up which reads:
[FAILED] Failed to start Load/Save ■tness of backlight:amdgpu_b10.

Okay, I seem to have fixed it.
I added acpi_backlight=native to GRUB_CMDLINE_LINUX_DEFAULT AND GRUB_CMDLINE_LINUX
in /etc/default/grub

Thank you @stephane for showing me the other forum article

Nevermind, after three reboots, I still get stuck at [FAILED] Failed to start Load/Save ■tness of backlight:amdgpu_b10.

Every time I chroot into the installation, and change something and update-grub, it works once, or the last time for thee reboots. I can’t figure out what the problem is

Weird that it prevents you from booting. I also had that issue that the settings could not be applied, but it just continued booting anyways.

After adding amdgpu to the modules in mkinitcpio.conf, did you run: sudo mkinitcpio -P ?

Anway, you can temporarily mask/disable the service also:

systemctl mask systemd-backlight@backlight\:amdgpu_bl0.service

btw. I’m on unstable and the issue seems to be fixed now with 5.8.9 kernel.

I didn’t run sudo mkinitcpio -P at first!

While running, I got some errors:

==> ERROR: module not found: `amdgpu_b10'
==> ERROR: module not found: `acpi_video0'

But still, after running the command, it seems to be stable. I’d report back here if I get problems again. Otherwise I guess 5.8.9 will fix this for other people and also for me in the long run, thanks!

Remove those two from the modules line (as it says there are no such modules), you only need the amdgpu one.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.