Amdgpu driver not working with RX 5600 XT


I just bought a new computer with RX 5600 XT and wanted to try Manjaro on it.

However, I did have a problem installing. Booting from usb stick ended up on black screen (monitor went to standby) after a few seconds.
I managed to install in the end by using the Architect edition and adding nomodeset to boot options in grub.

Now that I have the system installed, I have the same problem. Just after boot starts, the screen turns off.

What I tried:

  • Setting nomodeset. This gets the system to boot, X does not work, but I can get to a different TTY and login to CLI. I did find that nomodeset disables the amdgpu driver, so this is not a solution anyway.
  • Installing vesa with mhwd -i pci video-vesa. This does get me to Gnome desktop, but uses vesa.
  • First booting normaly (I get the screen off issue), then rebooting with nomodeset and checking the logs of previous boot. This is in the logs:

Can anyone help with this?

I did not install video-vesa. I am using the default driver video-linux (mesa) in the hardware configuration. It works fine for me.

I too have video-linux installed. I tried both with vesa uninstalled and installed. I also tried reinstalling video-linux (it got installed by architect installed) to no avail.

can you provide

inxi -Fxxxza 
sudo mhwd -li

have you updated your bios ?

~ >>> inxi -Fxxxza                                                             
  Kernel: 5.8.0-2-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=28744c1a-0ed8-44ca-84ae-81ff0189b9a4 rw nomodeset 
  Desktop: GNOME 3.36.4 tk: GTK 3.24.22 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-I GAMING v: Rev 1.xx 
  serial: <filter> UEFI: American Megatrends v: 3004 date: 12/16/2019 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S 
  serial: <filter> charge: 10% (should be ignored) rechargeable: yes 
  status: Discharging 
  Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701013 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86438 
  Speed: 2196 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 2218 2: 2190 3: 2200 4: 2200 5: 2192 6: 2201 7: 2200 8: 2200 9: 2214 
  10: 2191 11: 1963 12: 2200 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  vendor: Sapphire Limited driver: N/A alternate: amdgpu bus ID: 09:00.0 
  chip ID: 1002:731f 
  Display: x11 server: 1.20.8 compositor: gnome-shell driver: vesa 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: llvmpipe (LLVM 10.0.1 256 bits) v: 3.3 Mesa 20.1.5 
  compat-v: 3.1 direct render: Yes 
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 09:00.1 chip ID: 1002:ab38 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0b:00.4 chip ID: 1022:1487 
  Sound Server: ALSA v: k5.8.0-2-MANJARO 
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb 
  v: 5.6.0-k port: d000 bus ID: 04:00.0 chip ID: 8086:1539 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: ASUSTeK 
  driver: rtw_8822be v: N/A modules: rtw88_8822be port: c000 bus ID: 05:00.0 
  chip ID: 10ec:b822 
  IF: wlp5s0 state: down mac: <filter> 
  Local Storage: total: 465.76 GiB used: 17.40 GiB (3.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B2QEXE7 scheme: GPT 
  ID-1: / raw size: 465.26 GiB size: 456.96 GiB (98.22%) 
  used: 17.40 GiB (3.8%) fs: ext4 dev: /dev/nvme0n1p2 
  Kernel: swappiness: 10 (default 60) cache pressure: 50 (default 100) 
  ID-1: swap-1 type: file size: 8.00 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 55.6 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 310 Uptime: 2m Memory: 15.62 GiB used: 987.7 MiB (6.2%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: pacman: 1138 
  lib: 302 flatpak: 0 Shell: Zsh v: 5.8 running in: gnome-terminal 
  inxi: 3.1.05 

~ >>> sudo mhwd -li
> Installed PCI configs:
              NAME               VERSION          FREEDRIVER           TYPE
        video-vesa            2017.03.12                true            PCI
       video-linux            2018.05.04                true            PCI

Note that I installed video-vesa just now so I could get to desktop and copy-paste this. If I run this from CLI when vesa is not installed, the Display line under Graphics changes a bit to:

 Display: server: 1.20.8 driver: ati,radeon unloaded: modesetting alternate: fbdev,vesa tty: 160x45

I have not tuched the BIOS on either my motherboard or GPU.

you have an error with drm amdgpu , not loading Firmware of IP block
on init phase with video card

have you done something on your video card ( flash firmware ) ?

make a report

I found the cause of the issue. It was a bad (old/incompetable?) displayport cable :confused:

The full story:

Following @stephane’s reply, I first wanted to check if it’s not perhaps the card’s fault before reporting this as a bug. I installed Windows 10, which went without a hitch, but then the same issue happened while installing AMD drivers. The monitor went black at the point at which the installed switches to AMD driver.

At this point I thought the card was faulty. Still I wanted to try everything I could think of before RMAing it. After some other stuff I tried the other card outputs thinking perhaps the driver switched to different one then the one my displayport cable was plugged into. I also tried connected via HDMI which supprisingly worked :astonished:. This was the clued that lead my to try another displayport cable and then everything worked, both in Manjaro and Windows.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.