AMD USB 4 Weirdness, most devices only seen as USB 2

Good, that confirms what I suspected. I believe though marketed as backward compatible, usb 4 really isn’t truly backward compatible, unless the usb 3 device has a usb C connector, AND the cable is not switching from any connector that is not usb c, AND that the cable is true usb 3 compatible.

I’ve had weird usb connector issues, and have found connectors that claim to do something often do not work at all, for example, a usb A female to usb A female adapter to male A to male usb c cable totally failed, and I got no connection at all. But a usb female A to usb c male worked fine.

Also note that newegg did not list any usb 4 flash drives, making this very new. Did have some usb 4 enclosures though.

Judging from your case, which is just one instance so not enough to draw conclusions from firmly, it appears that it’s possible that usb devices that do not use connector C natively on both ends if a cable, and on one end if not, will not work as usb 3 or 4 devices when inserted into a true usb c connector usb 4 connector,

This still does not explain why no usb 4 hub at all appears in your data, that may be either driver/firmware/hardware issue, or, more likely to me, that usb 4 hubs do not activate until there is a reason for them to be there. Nor does it explain why the pixel which would be usb C to C connector cable failed to show as usb 3. Unless you without realizing it used a usb 2 C to C cable. I have yet to discover or determine if there is a non usb 3 c to c cable, or if c to c by definition supports usb 3 and 4.

This will require more user data however over the coming year, and more than one single case to determine.

But this is a good start, appreciate it.

I took a deep dive, decided to do some usb 4/usb 3.x research for inxi usb feature, and I can correct a few misconceptions:

  1. lspci didn’t confirm anything, it showed some strings, which are provided by t he vendor. So that was a red herring unfortunately. It does confirm the devices exist on the system, but does not confirm the system actually is supporting usb 4.
  2. Reading some stuff on tom’s hardware I think it was, can’t remember, sorry, they noted that as of July 2022, amd had physical support for usb 4 in their apu, ryzen 6xxx series, but the firmware hadn’t shipped yet, so that makes it quite likely that the firmware simply isn’t there yet, ASUS isn’t particularly great about firmware updates if I remember right, so that might take a while.
  3. USB 3.2 and 4 only work with type C connectors, period. I assume anything else will get kicked down to USB 2 as we’re seeing there. I don’t know what happens when a type A using a type C adapter is inserted, or when a type C cable connection that doesn’t have the USB 4 wiring is used, I would guess it gets treated as type 2 there as well, though that needs some empirical data from multiple systems to confrm.
    If I understand that right, it suggests that any usb A to C adapter may have wildly erratic outcomes when inserted into a usb 3 type c port. This explains I think why my phone simply doesn’t show up with a type c to type A cable when put into usb 3 port hubs, but does with a usb 2 hub. I double checked that, and it is in fact a usb 2 rated cable. It may also explain when a USB 3 type A female/female adapter with a usb a to c cable also fails totally to connect.

It’s hard to find real info on this because the tech is too new.

I’d have to do some more tests with real usb c connector cables that are definitely usb 3 rated to see if I can find any patterns there.

I think the only way to confirm this on this system however is to have a usb c connector, male, usb flash drive, that is also usb 3, and see how it appears when inserted into the usb 4 port. If it, and it’s hub, suddenly appears, as usb 3 at least, then that is how it works. I’m still not sure if all usb c male to male or male to female cables have that 2 lane minimum wiring, or if early usb c cables maybe only had one lane, but that might be an issue. But most likely is that the laptop vendor has not actually added the real usb 4 support yet.

Too many unclear bits to be sure, then of course, there’s always the possible hardware / chip failure to make it even more complicated to diagnose. Always best to have a known good test case to determine where the bad stuff is.

At this point, I’m perplexed, and I can pretty much rule out Linux as the culprit.
I’ve tested the USB-C to DP adapters on Windows as a sanity check, and neither of them work…
They also get recognized only as their USB 2 billboard.
An interesting side note is that if I plug the Adapter into the non-DP port, the system warns me of possible bandwidth problems, so at least something is happening under the hood.
Sadly, that’s as far as I got.
Any thoughts?

I think this almost confirms that it’s one of 2 things:

  1. hardware chip is dead
  2. The article I read that usb 4 support being physically in AMD apus last july but not actually supported in firmware is correct.

Having dug a bit, I currently roughly believe that there’s a mechanism in a usb 3/4 hub that physically passes or tunnels usb 1,2 to a usb 2 hub up the chain, that is, i suspect this is part of the usb 3/4 wiring possibly.

I did use this as an excuse to start figuring out my own annoying cabling issues I’ve been working around for a year or two now, and after checking my cables, which I had actually assumed were usb 3 (if real usb 3, they have the usb symbol plus SS or the speed rating of the cable, like 5, 10, 20, 40, 80 Gbps, ss for super speed and ss+ were for 5 and 10 gbps I think, I researched it but the usb group does not want vendors to use those, they want them to use the gbps speed rating along with the usb symbol.

When I checked my usb A to C male to male cables, none of them were usb 3.

So cabling really matters with this stuff, but since you got Cable Matters, you probably don’t have that issue.

I would contact the laptop vendor, I hope your experience with ASUS (non) support is better than mine was.

Being able to test it in windows makes the support call easier since they can’t blame linux.

But no worries, here is the answer:

Question 1. Do the ROG laptops of year 2022 with AMD Ryzen 6000 series processors support USB4?

Answer 1. AMD models of year 2022 do not yet formally support USB4 features due to this feature still under developing. If you would like to test, download a beta BIOS and PD firmware for supporting USB4 to Install it.

This conforms to what I read, you kind of jumped the gun on this laptop, similar to people who bought an Intel Alder lake CPU 6 months before linux or windows 10 added support for it.

But taking what I learned, to get these speeds, you can’t use any usb A to C converters, it has to be straight usb c only. This is useful information, and applies to USB 3.2 and 4 and all future USB versions until a new connector type appears.

This was a very useful moment to dig into usb 3 > 4 issues, I’ve integrated what I learned, roughly, into next inxi:

pinxi -Jaz
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s 
    lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-8:5 info: SanDisk Ultra type: Mass Storage driver: usb-storage
    interfaces: 1 rev: 3.0 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    power: 896mA chip-ID: 0781:5581 class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900

Which means that inxi -Ja feature will roll out roughly when real users start to get actual USB 4 support, which is nice, it’s not common for inxi to actually get the support or feature before wide spread support happens.

There are some real unknowns however, particularly when ti comes to how the kernel will report this data, so I probably won’t know if I guessed right until sometime next year I’d guess.

The ‘mode:’ thing only became a term with usb 3, and the weird use of generation and version by the usb consortium shows that sometimes groupthink isn’t that great a way to make decisions re naming etc, sigh. Adding the ‘lanes:’ item permitted more accurate mode detection, so that should be working fine now, barring some odd modes not yet seen.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.