AMD ryzen 3000 series?

Hello, everybody,
has anyone here had any experience with the AMD Ryzen 3000 Series?
Had once dared me to try Manjaro xfce on a system with Ryzen 3500U (Vega 8 mobile). Unfortunately, it's not even possible to boot the live system.
I tried it with the boot parameters : "iommu=soft" and "amd_iommu=on iommu=pt". Unfortunately no success.
I tried manjaro 18.0.2 fxce stable, as well as 18.1.0-pre1

Anybody got another idea?

Many greetings

You should make sure to create the live system in a way that works.
As far as I know, rufus in dd mode works. I always use the SuSe image writer that is present in the Manjaro Repositories for creating boot sticks, that one works too.

Thank you very much for the answers.

  1. live image was created directly with dd and is executable (tested on other hardware)
  2. Uefi boot mode is activated and required.
    3 Fast Boot and Secure Boot are both disabled.

I also get into the config window of the USB image (i.e. time, language and layout selection etc.) but from the moment manjaro live-system boot the screen turns black.
I suspect that the required drivers of the ryzen 3000 series are still missing on the image.

  1. i have already tried out free and nonfree drivers.

Specs:
CPU : AMD Ryzen 5 3500U Processor 4x 2.10 GHz
GPU from APU : Radeon Vega 8 Mobile
Motherboard : n.a.
Cooler : n.v.
Ram : 16 GB DDR4 2400 MHz (2/2)
Fans : n.a.
SSD : M.2 (PCI E 3.0) SSD 512 GB

Many greetings

try the new kde-dev iso which will be released soon today.
as its new hardware so requires new kernel.

So this is a Laptop? Whats the Model?

Wait for the kernel to catch up to your brand-spanking-new-just-released hardware, and then wait for a Manjaro installer image which has a compatible kernel.

3 Likes

Modell: HP ENVY x360 15-ds0000ng

Sorry:
this is the correct modell:

15-ds0002ng

what?

No not the correct specs:

See here -> Specs:
CPU : AMD Ryzen 5 3500U Processor 4x 2.10 GHz
GPU from APU : Radeon Vega 8 Mobile
Motherboard : n.a.
Cooler : n.v.
Ram : 16 GB DDR4 2400 MHz (2/2)
Fans : n.a.
SSD : M.2 (PCI E 3.0) SSD 512 GB

Sorry, this is the correct Modell: 15-ds0002ng

windows is a fatal error :smiley:

I'd like to go straight with Xfce.
In case of doubt I have to switch manually from kde to xfce.

The Manjaro xfce 18.1.0-pre1 comes with kernel 5.0x.

live image still does not boot.
After clicking on Boot in Grub -> black screen and that's it

I tried it with the boot parameters : "iommu=soft" and "amd_iommu=on iommu=pt"
Whats this got to do with install other than should be on?
All of this is set:
secure boot. off
fast boot. off
CSM. or other OS compatibility. auto.try enabled if auto doesnt work:[ if not try off.(off is rare but ive seen it)]
Virtualisation ON. intel-virt / or AMD iommou ON.
delete boot profiles.
data execution prevention off.
Drive lock off.
i/o security OFF.
onboard GPU off. + gpu boost switch off on board.

Hey, is windows still installed?
Your not duel booting. Clean install.
Did you access bios through fully booted Windows setting procedure.

try installing with architect and select 5.2 rc kernel and see if it helps

1 Like

secure.boot is off
fast.boot . no option
bios and uefi mod-> both not working
amd iommou i've set in the boot option before ( tried: immou=soft and "amd_iommu=on iommu=pt" - same result - black screen
no drive lock, so security blubb,
no extern gpu chipset, its an apu

there is no chance to boot, so i can't user architect to install

He cant boot the live USB to install?
"it's not even possible to boot the live system." its the first accessBios through booted windows settings thing. Then run amok! the secureboot side of secure boot.

windows is installed, i need dual boot :frowning:
can't delete windoof

architect is text based installer so it doesnot need graphics

1 Like

######TRY THIS ########
I've done my post limit???
Was hoping you could take the glory...

https://www.google.com/search?q=haw+access+bios+through+windows+10+hp&oq=haw+access+bios+through+windows+10+hp&aqs=chrome..69i57j0l2.21367j0j7&sourceid=chrome&ie=UTF-8#kpvalbx=1

This is what i think issue is. goes for 60seconds. enter bios through windows?

So when you try to boot your going into F9 after reset then selecting?
And usb is an allowed bootable device in bios?

Opening the Startup Menu from within Windows on the computer

Follow these steps to open the Startup Menu from within Windows.

  1. In Windows 10, click Start.

In Windows 8, press the Windows and I keys simultaneously.

In Windows 7, click Start.

  1. In Windows 10 and Windows 8, click Power and hold down the Shift key while you click Restart. Continue holding down Shiftuntil the Choose an Option screen displays.

In Windows 7, select Restart from the drop-down menu. As the computer reboots, press F11 continuously until the Choose an Option screen displays.

  1. From the Choose an Option screen, click Troubleshoot.
    From the Troubleshoot screen, click Advanced options.
    From the AdFrom the UEFI Firmware Settings screen, click
    Restart.vAvanced options screen, click UEFI Firmware Settings.
    The computer restarts and the Startup Menu opens.

Your not going to believe this stand by!

Forum kindly sponsored by