Amd_pstate - cpu stuck at max clock speed

After the stable 6th dec. update, the scaling driver on my Zen4 system has switched from acpi-cpufreq to amd-pstate, which, with my current ‘performance’ scaling governor leaves the CPU pegged at maximum clockspeeds.
According to cpupower frequency-info the usable range is 400Mhz to 5.88Ghz except it’s stuck at max speed.

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver                                                                ✔ 
amd-pstate

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor                                                              ✔ 
performance

How to revert back to acpi-cpufreq or get the CPU to clock down while retaining performance mode?

I tried adding amd_pstate=disabled to grub, but that did not have any effect.

For now have rolled back the update and would appreciate any help.

You can change the governor

sudo cpupower frequency-set --governor ondemand
also available are powersave and schedutil
might be some others available.

1 Like

So I checked the config and it appears that kernel options have changed.

Kernel 6.0.11-1

cat config | grep PSTATE            
CONFIG_X86_INTEL_PSTATE=y
CONFIG_X86_AMD_PSTATE=y
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ_CPB=y

Switched to 6.1.0rc7-1 and things are back to normal.

CONFIG_X86_INTEL_PSTATE=y
CONFIG_X86_PCC_CPUFREQ=m
# CONFIG_X86_AMD_PSTATE is not set
# CONFIG_X86_AMD_PSTATE_UT is not set
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ_CPB=y

Thank you for the tip!
I did change the governor initially, but after looking at some phoronix articles on the topic, I’d rather stay on acpi_cpufreq for now, at least until 6.2 hits.

1 Like

no problem.
Yes it seems work in progress currently.