AMD GPU Not Turning On

I am running Manjaro Linux Plasma (5.16.11-2-MANJARO) on my HP Laptop (8 GB RAM) with dual video cards:

[sal:lap:~] lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series]

and following drivers are installed:

[sal:lap:~] pacman -Qs xf86-video
local/xf86-video-amdgpu 22.0.0-1 (xorg-drivers) amdgpu video driver
local/xf86-video-ati 1:19.1.0.r9.g5eba006e-2 (xorg-drivers) ati video driver
local/xf86-video-intel 1:2.99.917+916+g31486f40-2 (xorg-drivers) Intel i810/i830/i915/945G/G965+ video drivers
local/xf86-video-nouveau 1.0.17-2 (xorg-drivers,)
    Open Source 3D acceleration driver for nVidia cards

When I render any file (on Kdenlive) then after few seconds the AMD GPU is turned on (to lift extra system load).
However, when I run other (multiple) applications simultaneously, including Firefox, Thunderbird, Dolphin, Konsole, Google Chrome and Virtualbox (with Windows-8.1 inside, with 2-CPUs and 3 GB RAM allocation), then my AMD GPU does not turn on (to life extra system load). Instead my system starts to hang/freeze, and I am left with the only option of killing some applications (like Firefox and Google Chrome) in order to retain back the system control.
So, my question is that if my AMD GPU is running properly while using Kdenlive, then why it does not run (turn on) when my system starts to freeze in the usage of multiple (simultaneous) applications? And how can I change this behavior and make my AMD GPU turn on every time on heavy system load?

Firefox and Chrome and especially a virtualized Windows don’t use the GPU for most tasks.
This is gone by your CPU and will use your memory.

How can I fix this issue?

Use less memory? I don’t know what else you could do.

Do you have swap set up?

Yes, swap is 2.0 GB:

[sal:lap:~] free
               total        used        free      shared  buff/cache   available
Mem:           7.7Gi       1.6Gi       4.3Gi       422Mi       1.8Gi       5.4Gi
Swap:          2.0Gi          0B       2.0Gi

Which is set in the form of swap-file:

[sal:lap:~] grep swap /etc/fstab
/swapfile    swap    swap    defaults    0    0

and the value of “vm.swappiness” is 60.

[sal:lap:~] cat /proc/sys/vm/swappiness

Do you think that I need to change this value?