AMD card boots into live disk but not installed/encrypted filesystem

I've just added an Asus HD 7770 2gb to my system. everything worked perfectly before.
but now, after i've successfully unlocked the encryption it does the "exception, no handler for IQR vector" (or whatever that is), then the monitor says there's no signal for a second, and finally it shows a blank terminal with a single, static underscore. I have to hard reboot to try again.

but it works just fine in the manjaro live disk.

switching back to the integrated graphics works.

the card has spent a few years sitting in a bucket in a closet, and I didn't transport it in the absolute safest way. I hope that doesn't have anything to do with it. I doubt it would, seeing as how it's fine in a live system, but i'll mention it just in case.

I'm using a dvi cable for the connection. the gpu i was using before was an integrated radeon r5 3000, it's done the same thing with two different monitors. can't think of any other relevant details.

thanks in advance.

Jury's out

inxi -Fxxxza --no-host

Would be a good start.

would I type that in the terminal of the live system or the main one with the integrated graphics enabled?
also what is that?

sorry this probably should have gone in noob corner.

[edit]
oh duh. just system info :slight_smile: I'm an idiot.

From the live system.

System:
Kernel: 5.4.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
misobasedir=manjaro misolabel=MJRO1814 quiet systemd.show_status=1
apparmor=1 security=apparmor
Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: Gigabyte model: GA-78LMT-S2P v: x.x serial:
BIOS: Award v: F3 date: 10/18/2012
CPU:
Topology: 6-Core model: AMD FX-6100 bits: 64 type: MCP arch: Bulldozer
family: 15 (21) model-id: 1 stepping: 2 microcode: 600063E
L2 cache: 2048 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 39789
Speed: 1413 MHz min/max: 1400/3300 MHz boost: enabled Core speeds (MHz):
1: 1416 2: 1510 3: 1413 4: 1456 5: 1446 6: 1542
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
disabled, RSB filling
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Cape Verde XT [Radeon HD 7770/8760 / R7 250X]
vendor: ASUSTeK driver: radeon v: kernel bus ID: 01:00.0
chip ID: 1002:683d
Display: x11 server: X.Org 1.20.6 driver: ati,radeon unloaded: modesetting
alternate: fbdev,vesa resolution: 1680x1050~60Hz
OpenGL: renderer: AMD VERDE (DRM 2.50.0 5.4.2-1-MANJARO LLVM 9.0.0)
v: 4.5 Mesa 19.2.7 direct render: Yes
Audio:
Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel
v: kernel bus ID: 00:14.2 chip ID: 1002:4383
Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000
Series]
vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 1002:aab0
Sound Server: ALSA v: k5.4.2-1-MANJARO
Network:
Device-1: Qualcomm Atheros AR8161 Gigabit Ethernet vendor: Gigabyte
driver: alx v: kernel port: df00 bus ID: 02:00.0 chip ID: 1969:1091
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 126.79 GiB used: 111.5 MiB (0.1%)
ID-1: /dev/sda vendor: PNY model: CS900 120GB SSD size: 111.79 GiB
block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
serial: rev: 0112 scheme: MBR
ID-2: /dev/sdb type: USB vendor: Generic model: Flash Disk size: 15.00 GiB
block size: physical: 512 B logical: 512 B serial: rev: 8.07
scheme: MBR
Partition:
ID-1: / raw size: N/A size: 5.83 GiB used: 111.5 MiB (1.9%) fs: overlay
source: ERR-102
Sensors:
System Temperatures: cpu: 6.9 C mobo: N/A gpu: radeon temp: 28 C
Fan Speeds (RPM): N/A
Info:
Processes: 209 Uptime: 5m Memory: 7.77 GiB used: 1.23 GiB (15.9%)
Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11
running in: xfce4-terminal inxi: 3.0.37

actually, after watching the live disk boot up again, it does still take a lot longer than usual, and it does do the monitor turn off then on again thing, and it also shows the underscore screen, but it moves on from there.

Looks like you're using the radeon drivers? Maybe try the open source drivers instead.

First make a backup, timeshift or whatever. Then try running

sudo mhwd -a pci free 0300

(from your actual install, not the live disk)

Will do after supper.

it said this:
Skipping already installed config 'video-linux' for device: 0000:01:05.0 (0300:1002:9616) Display controller ATI Technologies Inc RS780L [Radeon 3000]

does that mean it's already using it?

testing the gpu again now.

That means it's installed but not necessarily that its using it. I was hoping that command would switch it over. I'm not that familiar with mhwd over the command line, it's nearly 3am so I'm not going to get familiar with it in this session :grin:

I'm not that familiar with xfce either but let's see if we can confirm it in the gui. Go to system settings and then hardware, it should show available graphics adaptors. Take a screenshot and post it here.

Edit: decided to get a bit familiar

mhwd -li -d

Running that will list all your installed drivers. Essentially, what we want to do is ensure that you're running the free driver, and if you're running the non-free driver, remove it.

So, it is using the standard ones.

Sweet, confirms that you didn't destroy your card by keeping it in a bin and that you're running the correct drivers. Double win.

Old ass card so try an old ass kernel. 4.19 would be a good call, install it and reboot.

Slightly related anecdote; I actually found an old 7770 in a bin a few months ago, guess somebody built a new PC as was getting rid of the old one.

wait, I did that with the integrated graphics.
does that still confirm I didn't destroy it?

Oh my dude you are killing me, why would I want to know about your integrated graphics? :sweat_smile:

Install 4.19 and reboot using your 7770. I wanted to confirm that the card was alive first but whatever, it's late maybe it'll work.

:slight_smile:
ok. i'll be back in like, 10 minutes.

oorr a little bit longer.

installing the kernel didn't help.

here's the graphics info for the actual card from the live system:

Also, I couldn't find the gui kernel switcher anywhere on my installed system or on the live disk. did they remove it for the latest version?

Just seeing your latest post, what the heck are Nvidia drivers doing there? Get rid of em. No wonder you're having trouble booting, you've got a mess of conflicting drivers. It's ridiculously late so I'll leave you a list of things to try.

Disclaimer, have a backup ready before trying any of this.

1- Remove the Nvidia driver, all you want/need for the AMD card is modesetting, ie the drivers cooked into the kernel. No Catalyst, no Nvidia, definitely no Bumblebee.

2- Update your hilariously old bios (2012!).

3- last resort if nothing else works, this is a hacky work around for suppressing PCI error messages at boot Edit the following line in /etc/default/grub. I don't think it's related to your boot troubles, the drivers will be doing that but it should get rid of that error message you was seeing. Try updating your bios first though as that will likely fix the bug and make this step unnecessary

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3 pci=nomsi,noaer"

Have a looky here for details on configuring graphics drivers via the command line:

https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards

Good luck and good night!

Thanks a ton.
Good night and God bless.

just noticed you said that was from the live system so it doesn't relate to your actual install (i'm really tired)

so try updating your bios first and then making that change to /etc/default/grub if you're still having issues

Oh yeah. Took me a bit too.
I'll still be here in the morning. don't feel obligated to get this figured now.

How do you switch ? Since is a Desktop PC, disable the iGPU from BIOS, connect all monitors to the dGPU and should work with the video-linux drivers.

Because is using this kernel boot flags:
i915.modeset=1 radeon.modeset=1
that help in your case on live media.

Are you sure this is necessary ?

I wasn't aware you need to disable the igpu in bios...
actually i'm pretty sure my bios is so crappy that there's not even an option for that. :slight_smile:
How do I change those kernel boot flags?

Forum kindly sponsored by