Amarok forever

I'm not that good to fully understand what this does, but it fixed Amarok for me.
I've read man page for ln, but still xD
It's a shame that we still have this issue not fixed, and installing Amarok from community repo leads to broken application.

It essentially makes /usr/lib/libmysqlclient.so the same file as /usr/lib/libmysqlclient.so.18. What that does is make the current version of the lbmysql look like an older version of libsql.

This will only work so long as libmysql* remains fully backwards compatible with older versions.

A better long-term solution is to rebuild it against the current libraries. It should be reported here if hasn't already.

1 Like

Since the last upodate Amarok doesn't work anymore!

A downgrade from libssh 3 months ago worked temporarily.
Then it worked by creating two symlinks.

sudo ln -s /usr/lib/libmysqlclient.so /usr/lib/libmysqlclient.so.18 sudo ln -s /usr/lib/libmysqld.so /usr/lib/libmysqld.so.18

Now there's nothing left. The database is not found.

Here is the error description and previous efforts in German:
https://manjaro-forum.de/viewtopic.php?f=3&t=1791

Good morning.
Install the AUR version; then you must "tell" OCTOPI or PAMAC to ignore the community version.

Regards

Paulo

1 Like

Forum kindly sponsored by Bytemark