Amarok forever

…And you want people to force keep old versions of packages? Thats not a great idea already. But its even worse when you are keeping things like samba and ssh held back.

As others have mentioned, this git version you speak of is in the AUR, not the repos. Install amarok from the repos, and report if you have issues then.

Is Amarok still being developed actively ?
It is an amazing music player no doubt…

No, I talk about current Amarok in the community repo:

There is broken:

Qt4-Amarok, for comparsion:

MAYBE current Qt5-Amarok will work correctly some time, but I can’t hope for it :slight_smile:

I think simple: user’s data is most important for him, and system has no right force to drop their due changes in repos.

My solution is no different from AppImage in fact.

Maybe this is lost in translation.

But to me it is simple as well.

This is a bad idea. It falls under ‘partial upgrades’ which is not supported and also a Bad Idea.

Further - this is even worse when you are talking about network/security software [such as SSH]. This recipe calls for you keeping such things out of date and therefor vulnerable and insecure.

If the ‘users data is important’ then these things are of paramount importance.

If their collection/data is important enough that it must be ported then that is another matter. In this case not only is the software still available without these unstable workarounds, but I’m relatively sure amarok support exporting such data and/or it is available file-side so that it could continue to be functional for usage otherwise.

That is all beside the point that the proposed actions are;
Based on false presumptions and bad actions,
Ill Informed,
Not Necessary,
and Dangerous (to stability of system and general security)

It falls under ‘partial upgrades’ which is not supported

It is not partial upgrades. The system is updating fully as usual. Amarok with deps are not related to the system.

Non-updating Amarok, Qt4, kdebase, etc, its a paltry security threat.

Actually it is.
There are at least 2 packages I can see, which are system packages and needs to be up to date to be secure.
libssh and smbclient.

needs to be up to date to be secure

To be secure when Amarok connect to local database or local storage via Samba? Hmmm, I don’t think so.

Samba is not only for amarok. It is also for LAN sharing in general.
Which other users might use, although you might not. So making them keep it out-dated is a security risk.

And SSH is pretty obvious, not even gonna explain that one.

What? That Samba is for Amarok. Other programs use system Samba from repos.

In my script “app-run”:

export PATH="$pathes"$PATH
export LD_LIBRARY_PATH="$lib_pathes""/usr/lib64/mysql:"$LD_LIBRARY_PATH
export XDG_DATA_DIRS="$data_pathes"$XDG_DATA_DIRS
export QT_PLUGIN_PATH=""$deps_dir"/qt4-4.8.7-25/usr/lib/qt4/plugins:"$deps_dir"/kdebase-runtime-17.08.3-4/usr/lib/kde4/plugins:"$deps_dir"/kdelibs-4.14.38-4/usr/lib/kde4/plugins:"$deps_dir"/phonon-qt4-gstreamer-4.9.0-4/usr/lib/kde4/plugins:"$deps_dir"/phonon-qt4-4.10.1-3/usr/lib/qt4/plugins"

exec "$app_exe"

Wrong. The other programs use whatever smbclient is installed on the system. And you can’t have 2 packages named the same installed at the same time.

It sounds like you don’t quite understand have Linux packages work.

I’m just saying. Keeping old packages installed, while “updating” the rest is called a partial update. And Arch Linux and Manjaro does not support partial updates.

Samba in the folder ~/app/amarok-2.9.0-2/deps is not installed on the system, that’s the point. As well as other Amarok’s deps.

The “system” is environment which determined by global environment variables like PATH, LD_LIBRARY_PATH, etc. Directory in the /home is not a part of global system environment.

So what you are saying its a portable self contained package built in your home directory complete with all deps required,
If that is the case that seems fine to me

1 Like

its a portable self contained package built in your home directory complete with all deps required

Exactly!

Thank you a lot for this effort!
Would be nice if you could make a new build which incorporates MariaDB as well: libmariadbclient-10.1.37-1-x86_64, mariadb-10.1.37-1-x86_64 and mariadb-clients-10.1.37-1-x86_64.
MariaDB 10.3 does break Amarok again.

Try this:

sudo ln -s /usr/lib/libmysqlclient.so /usr/lib/libmysqlclient.so.18
sudo ln -s /usr/lib/libmysqld.so /usr/lib/libmysqld.so.18
1 Like

I'm not that good to fully understand what this does, but it fixed Amarok for me.
I've read man page for ln, but still xD
It's a shame that we still have this issue not fixed, and installing Amarok from community repo leads to broken application.

It essentially makes /usr/lib/libmysqlclient.so the same file as /usr/lib/libmysqlclient.so.18. What that does is make the current version of the lbmysql look like an older version of libsql.

This will only work so long as libmysql* remains fully backwards compatible with older versions.

A better long-term solution is to rebuild it against the current libraries. It should be reported here if hasn't already.

1 Like

Since the last upodate Amarok doesn't work anymore!

A downgrade from libssh 3 months ago worked temporarily.
Then it worked by creating two symlinks.

sudo ln -s /usr/lib/libmysqlclient.so /usr/lib/libmysqlclient.so.18 sudo ln -s /usr/lib/libmysqld.so /usr/lib/libmysqld.so.18

Now there's nothing left. The database is not found.

Here is the error description and previous efforts in German:
https://manjaro-forum.de/viewtopic.php?f=3&t=1791

Good morning.
Install the AUR version; then you must "tell" OCTOPI or PAMAC to ignore the community version.

Regards

Paulo

1 Like