AltGr stopped working for European accents

I want to be able to type accents for French on my US keyboard on an ASUS X555 laptop, running Manjaro i3 (kernel 5.10.70-1). So I changed the keyboard from ‘US default’ to ‘US International AltGr unicode combining’ in settings. It worked well for maybe 20 minutes (I was typing on the DuoLingo website), then stopped working and started essentially doing the same things the left Alt does (activating menu shortcuts etc) instead of producing accents. I wasn’t running any other applications.

❯ xmodmap -pke | grep ‘Alt’
keycode 64 = Alt_L Meta_L Alt_L Meta_L
keycode 108 = Alt_R Meta_R ISO_Level3_Shift
keycode 204 = NoSymbol Alt_L NoSymbol Alt_L

❯ cat 00-keyboard.conf
'# Written by systemd-localed(8), read by systemd-localed and Xorg. It’s
'# probably wise not to edit this file manually. Use localectl(1) to
'# instruct systemd-localed to update it.
Section “InputClass”
Identifier “system-keyboard”
MatchIsKeyboard “on”
Option “XkbLayout” “us”
Option “XkbModel” “pc105”
Option “XkbVariant” “intl-unicode”

❯ localectl status
System Locale: LANG=en_US.UTF-8
VC Keymap: us-acentos
X11 Layout: us
X11 Model: pc105
X11 Variant: intl-unicode

I tried the trick of trying to ‘unstick’ the AltGr key by holding Shift-AltGr, but that didn’t make it better, and restarting the system also doesn’t resolve the issue. I also tried changing to a different layout then changing back, but to no avail.

Any ideas on what I can try to have it functioning as it was?

I’m coming back to this issue after some time, and I tried the following:

  1. Using Manjaro settings to change the keyboard (to US international AltGr) is no longer persistent. After rebooting, it just goes back to being default. This wasn’t the case 2 months ago.
  2. I tried remapping key 108 (the right Alt key, confirmed using xev) to ISO_Level3_Shift using xmodmap -e “keycode 108 = ISO_Level3_Shift”. Running xmodmap -pke tells me that key 108 is successfully reassigned, yet it still won’t type accents. This remapping is also not persistent and reverts after rebooting.
  3. I don’t see in my xmodmap -pke anything that would type an accented character… e.g.
    keycode 26 = e E e E
    keycode 30 = u U u U
    keycode 31 = i I i I
    keycode 32 = o O o O