Alt + Shift shortcuts not working in Manjaro 16.06 Gnome

Hello. I have a fresh instal of Manjaro Gnome, and have problems with keyboard layout. It seems that for some reason if I press alt, the system does not detect me pressing shift and vice versa (tested using layout display from Gnome settings). Anyone have any ideas what might cause this problem?

Stratch that. Misunderstood you.

That is indeed weird, it works on XFCE as far as I know.

Yeah, there’s something with gnome shortcut system that sometimes just doesn’t work. I think the easiest way to fix it is to delete the config and start afresh. Just delete the ~/.config/dconf/user. Also, delete the /etc/skel/.config/dconf/user and restart your system. You should then get a fresh Gnome and start changing things to your liking. I found out the problem is happening with the default setting Manjaro offers by putting it in the /etc/skel/ for new users. I know this because my T and S shortcuts most of the time just stop working after reboot while W always works. There’s something weird with the default config manjaro gnome edition.

@Ste74 you should take a look at this.

Nope, did not help :frowning:

Yes , when problem appear can you check in dconf-editor or in a tweak tool what say for this shortucut ? I’m not into manajro now but this evening check desktop setting …

No, the problem does not appear and disappear, it’s there constantly. I cannot use or set any shortcut consisting of both shift and alt.


The image above was taken while pressing both alt and left shift. As you can see it does not detect shift being pressed. If I press shift first it will not detect alt being pressed. This happens for both shift keys. However I can weirdly see them both as pressed when I also press ctrl, so ctrl+alt+shift seems to be working fine, but I cannot set such combination as shortcut in the keyboard settings app or other apps (it is then detected as ctrl+alt even though shift is pressed).

Just to help narrow the problem down: it works on my manjaro gnome but I’ve installed it from 16.04 I believe. I have not deleted the specific dconf settings, but did make some changes in the shortcuts.

http://imgur.com/ziUhDJB

Cheers,

I’m here :slight_smile: i have tested my installation and when i use the layout is true alt + shift not appear ( alt disable shift and viceversa ) but alt + shift shortcut is used to change the keyboard layout and in my case work : when press alt+shift my keyboard layout change ( italian to english and viceversa ) so is a problem only of layout screen ? :pensive:

No it’s not just layout screen, I cannot use or set any shortcut consisting of alt + shift. I also have only one keyboard layout, but this might actually be the problem, any idea how to remove this shortcut?

God dammit, I solved it :angry: It was the shortcut to change layout, it made all other shortcuts not work. For anyone with the same issue: the solution was to go to gnome keyboard shortcut settings and in the typing section change ‘Modifiers-only switch to next source’ to another shortuct, or disable it.

I still think that it is a bug though, because I wasn’t able to use any shortcuts with this setting set to default.

1 Like

If is an issue i can commit in our gnome profile to disable the shortcut .
I not use more shortcut but i know gnome is know for the powerfull shortcuts so i need to know if gnome user’s want this … :slight_smile:

In May case my second layout is Arabic and I think this should apply to languages in which writing start from right to left.

Go to manjaro settings and choose keyboard

Forum kindly sponsored by