Alma Freezes While Installing Packages

I wanted to make a persistent USB image and found Alma thanks to @philm. I also checked out @andreas85’s tutorial. Thus, I ran the following command in root after installing Alma and cloning its presets.

export ALMA_USER=dar ; alma create --presets ./alma/presets/xfce-manjaro

I tried it twice at the moment, both times it stopped for hours (I left it overnight) during installing packages.

This time it stopped at

(194/608) installing avahi                                   [########################---------]  75%

while the other time it stopped at the 200-something package.

I didn’t like breaking from it the other time because I’m in root, and when I shut down the PC after the last time, it gave

[FAILED] Failed unmounting /home.
[FAILED] Failed unmounting /tmp/.tmpJBbzKD.
[FAILED] Failed unmounting /Temporary Directory /tmp.

and it kept trying to unmount them for hours on end till I had to unplug it. (I know, stupid!)

Edit: Here’s the inxi command output. I’ll also try to understand dmesg and/or journalctl till someone reply.

  Kernel: 5.17.1-3-rt17-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-rt-x86_64
    root=UUID=2acd979d-0c15-4b5e-9c03-b03b59fb8c93 rw quiet apparmor=1
    security=apparmor resume=UUID=cf2d2dcd-ce25-4873-b38b-6b2edc6ccf64
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Hewlett-Packard product: HP ProDesk 600 G1 TWR v: N/A
    serial: <superuser required> Chassis: type: 6 serial: <superuser required>
  Mobo: Hewlett-Packard model: 18E7 serial: <superuser required>
    BIOS: Hewlett-Packard v: L01 v02.75 date: 05/04/2018
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard Dell WK636
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse Dell WM116
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 5.69 GiB used: 2.65 GiB (46.6%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-4570 bits: 64 type: MCP arch: Haswell family: 6
    model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 3065 high: 3193 min/max: 800/3600 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3188 2: 2689 3: 3193
    4: 3193 bogomips: 25542
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx
    vnmi vpid x2apic xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: Hewlett-Packard driver: i915 v: kernel ports: active: VGA-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:0412
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1680x1050 s-dpi: 96 s-size: 444x277mm (17.48x10.91")
    s-diag: 523mm (20.6")
  Monitor-1: VGA-1 model: Lenovo LEN LT2252pwA serial: <filter> built: 2014
    res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2 size: 474x296mm (18.66x11.65")
    diag: 559mm (22") ratio: 16:10 modes: max: 1680x1050 min: 720x400
  OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2) v: 4.6 Mesa 22.0.4
    compat-v: 3.1 direct render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.1-3-rt17-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Ethernet I217-LM vendor: Hewlett-Packard driver: e1000e
    v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8192EE PCIe Wireless Network Adapter
    driver: rtl8192ee v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000
    bus-ID: 02:00.0 chip-ID: 10ec:818b class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.42 TiB used: 161.96 GiB (11.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000AVCS-612DY1 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 0A01
    scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EZEX-75WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A02 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Kingston model: DT 101 G2
    size: 59.42 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: PMAP scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  ID-1: / raw-size: 456.96 GiB size: 448.72 GiB (98.20%)
    used: 36.66 GiB (8.2%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 2acd979d-0c15-4b5e-9c03-b03b59fb8c93
  ID-2: /home raw-size: 931.51 GiB size: 915.81 GiB (98.31%)
    used: 124.01 GiB (13.5%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: Eris
    uuid: c7581184-8813-4804-a5f3-d5e0cddd97dd
  ID-3: /tmp/.tmpzy8ziG raw-size: 59.18 GiB size: 57.94 GiB (97.92%)
    used: 1.3 GiB (2.2%) fs: ext4 dev: /dev/sdc3 maj-min: 8:35 label: N/A
    uuid: 704dd6ed-d3ff-4df2-a358-3cac12884a3b
  ID-4: /tmp/.tmpzy8ziG/boot raw-size: 250 MiB size: 246.1 MiB (98.46%)
    used: 1 KiB (0.0%) fs: vfat dev: /dev/sdc1 maj-min: 8:33 label: N/A
    uuid: B282-10DD
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 2.8 MiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2 label: swap
    uuid: cf2d2dcd-ce25-4873-b38b-6b2edc6ccf64
  ID-1: /dev/sdc2 maj-min: 8:34 size: 1024 KiB fs: <superuser required>
    label: N/A uuid: N/A
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8008 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-5:13 info: Kingston DT101 G2 type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA
    chip-ID: 0951:1642 class-ID: 0806 serial: <filter>
  Device-2: 3-6:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Hub-6: 4-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
This text will be hidden

  Processes: 2145 Uptime: 11h 50m wakeups: 64 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1405
  lib: 383 flatpak: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.16

Should I stop the current Alma session? And how? Should I use Alma again?

Gentle shut down a suddenly hanged PC to minimize a chance of getting a broken filesystem and data loss:

Try using sync before shutting down

How big is your usb-stick ? 64GB :heavy_check_mark:

Try using kernel 5.15 :wink:

Thanks for the “soft” reset tip.

I actually don’t know what you mean be sync and Googling it did not get me anywhere related.

Yes, it’s a 64 GB thumb drive.

OK, I already have kernel 5.15, I’ll try using it and tell you the results.

AFAIK that’s just the command sync:


in the terminal, when done with everything just before unmounting and removing the drive.

1 Like

OK, sync froze. And when I try to unmount the USB stick, I get:

umount: /[PATH] target is busy.

And umount -l froze as well.

BTW, @andreas85 would it be that different when using kernel 5.15 when it comes to Alma?

How long did it “freeze”?

If it was for very long, I suspect a faulty USB drive.

Is 2 hours long enough?

I’m guessing so. So let’s test the drive for errors:

  1. Find the Device identifier. (This is optional if you know the device identifier.)
    Insert the thumb drive and execute:
fdisk -l

1.2. Identify your device from the output, for example /dev/sda.

  1. Now, to test the drive, execute:
sudo badblocks -w -s -o /tmp/sda-errors.log /dev/sda


  • -w: Use write-mode test to scans for bad blocks by writing some patterns on every block of the device, reading every block and comparing the contents.
  • -s: Show the progress of the scan.
  • -o /tmp/sda-errors.log: Write the list of bad blocks to the error.log file in the current working directory.
  1. Inspect the output log for any errors:
cat /tmp/sda-errors.log

This will show you thee log, if any. Feel free to provide it here if it’s not obvious to you. But do it as preformatted text. (See tip below if unsure what this is.)


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

1 Like

Thank you for the detailed reply, and don’t worry, I know how to provide the information. I just don’t know how to use it in a super tech savvy way.

Badblocks gave

/dev/sdc is apparently in use by the system; it's not safe to run badblocks!

OK, let’s try and unmount it, quite forcibly:

sudo umount -l /dev/sdc

If that doesn’t work, then try turning off/rebooting your computer and on startup before Manjaro loads, remove it. Then let Manjaro start, log in, and when ready insert the flash drive, but don’t mount it, and try again.

I’, glad you know, for my own eyes’ and my brain’s sake, I rather explain to everyone I’m not certain knows what to do, so I’ll try and remember that you do.

Although I have tried umount -l unsuccessfully before, I decided to do as you say.

And the terminal kept saying that the password I provided is wrong, and I had to reboot. I am certain the password was right though, can this happen due to some faulty thingy!?

And should I try Alma again after all this trouble?

It can, so a restart is recommended. Mine was faulty as well, and if all else fails, you should be able to change/correct the password from a chroot environment.

The reason I suggested sudo umount -l is because it being run with sudo and not just as a normal user, forces it more. Almost like it says, to hell with you, i’m just going to do what I’m told. And it seems you didn’t use it with sudo:

That’s completely up to you.

OK, I got what you mean. I actually used sudo. Anyway, thanks for your help so far.

1 Like

OK, Mods! IDK if anyone else can help solving this. Do I just leave it this way? mark the most helpful reply as the solution?

Actually, if anyone gonna reply, do you have any idea how to make a persistent live USB other than Alma. Because I don’t think it’s working very well at the moment. That said, I am trying it for one last time.

1 Like

Only if it is not USB2, or otherwise very slow (for example slow internet …)

In my case it needed more than 30 minutes

(on a AMD-16-core with 32 GB RAM)

Maybe look into htop wehter it is working

OK, it worked. IDK if it’s because third time is a charm or using kernel 5.15 did the trick.

I reformatted the USB stick using KDE Partition Manager. Choose bfrts.
Used a 64 GB USB stick.
Booted using kernel 5.15.
Then use the following commands. (Surely after installing Alma and cloning its presets.)

sudo su
export ALMA_USER=dar ; alma create --presets ./alma/presets/xfce-manjaro
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.