All vulkan games failing to launch

I initially thought it was just Proton games, but after trying to fix it from that angle for a while I found out that even native linux games running proton are failing to launch. I’ve already tried running AMD_VULKAN_ICD=RADV after finding out it could be something to do with AMDVLK vs RADV but that doesn’t seem to have fixed anything. Here’s all the relevant error logs

Proton game: Pastebin
Native Vulkan Game: Pastebin

Both have WARNING: radv is not a conformant Vulkan implementation, testing use only. pop up multiple times, which I think it the main problem, but I have no idea what’s causing it.
For reference, vulkaninfo --summary gives this

$ vulkaninfo --summary
WARNING: radv is not a conformant Vulkan implementation, testing use only.

Vulkan Instance Version: 1.2.194

Instance Extensions: count = 19
VK_EXT_acquire_drm_display             : extension revision 1
VK_EXT_acquire_xlib_display            : extension revision 1
VK_EXT_debug_report                    : extension revision 10
VK_EXT_debug_utils                     : extension revision 2
VK_EXT_direct_mode_display             : extension revision 1
VK_EXT_display_surface_counter         : extension revision 1
VK_KHR_device_group_creation           : extension revision 1
VK_KHR_display                         : extension revision 23
VK_KHR_external_fence_capabilities     : extension revision 1
VK_KHR_external_memory_capabilities    : extension revision 1
VK_KHR_external_semaphore_capabilities : extension revision 1
VK_KHR_get_display_properties2         : extension revision 1
VK_KHR_get_physical_device_properties2 : extension revision 2
VK_KHR_get_surface_capabilities2       : extension revision 1
VK_KHR_surface                         : extension revision 25
VK_KHR_surface_protected_capabilities  : extension revision 1
VK_KHR_wayland_surface                 : extension revision 6
VK_KHR_xcb_surface                     : extension revision 6
VK_KHR_xlib_surface                    : extension revision 6

Instance Layers: count = 4
VK_LAYER_VALVE_steam_fossilize_32 Steam Pipeline Caching Layer 1.2.136  version 1
VK_LAYER_VALVE_steam_fossilize_64 Steam Pipeline Caching Layer 1.2.136  version 1
VK_LAYER_VALVE_steam_overlay_32   Steam Overlay Layer          1.2.136  version 1
VK_LAYER_VALVE_steam_overlay_64   Steam Overlay Layer          1.2.136  version 1

        apiVersion         = 4202678 (1.2.182)
        driverVersion      = 88088579 (0x5402003)
        vendorID           = 0x1002
        deviceID           = 0x73bf
        deviceType         = PHYSICAL_DEVICE_TYPE_DISCRETE_GPU
        deviceName         = AMD RADV SIENNA_CICHLID
        driverID           = DRIVER_ID_MESA_RADV
        driverName         = radv
        driverInfo         = Mesa 21.2.3
        conformanceVersion =

And I’m on the 5.13 kernel if that makes a difference and I’m running a 6900xt, so definitely a vulkan compatible card

Hello @Admiralthrawnbar :wink:

[1112/] InitializeSandbox() called with multiple threads in process gpu-process
[1112/150603:INFO:CONSOLE(0)] "The specified value '!' does not conform to the required format. The format is '#rrggbb' where rr, gg, bb are two-digit hexadecimal numbers.", source: file://localhost/home/daniel/.local/share/Steam/steamapps/common/Total%20War%20WARHAMMER/share/FeralUI/PGOW/Core/feralUI.html (0) 
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
[1112/] The GPU process hung. Terminating after 10000 ms.
TotalWarhammer: dumped to "/home/daniel/.local/share/feral-interactive/Total War Warhammer/crashes/130acfe1-f439-b957-78ee4df3-0c55444c.dmp"
TotalWarhammer: crash reporter "/home/daniel/.local/share/Steam/steamapps/common/Total War WARHAMMER/bin/feral_linux_crash_reporter" launching
Game crashed, if possible email [] with the crash file [/home/daniel/.local/share/feral-interactive/Total War Warhammer/crashes/130acfe1-f439-b957-78ee4df3-0c55444c.dmp] and details

So the gpu process hung…

[1112/] The GPU process hung. Terminating after 10000 ms.

You shoud be able to get more information by running:

sudo dmesg --follow

and then start Total War Warhammer again. There must be something printed which relates to this error.

That command really seems to dislike either my logitech keyboard or mouse, there were several thousand errors about that even though they work fine before I even launched the game, and only about a half-dozen lines about trying to launch it, here’s those lines

[ 8135.924000] audit: type=1701 audit(1636750747.115:292): auid=1000 uid=1000 gid=1000 ses=2 subj==unconfined pid=64852 comm="WinMain" exe=2F686F6D652F64616E69656C2F2E6C6F63616C2F73686172652F537465616D2F737465616D617070732F636F6D6D6F6E2F546F74616C205761722057415248414D4D45522F62696E2F546F74616C57617268616D6D6572 sig=11 res=1
[ 8135.937521] audit: type=1334 audit(1636750747.128:293): prog-id=66 op=LOAD
[ 8135.937602] audit: type=1334 audit(1636750747.128:294): prog-id=67 op=LOAD
[ 8135.937657] audit: type=1334 audit(1636750747.128:295): prog-id=68 op=LOAD
[ 8135.938418] audit: type=1130 audit(1636750747.128:296): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-coredump@13-64853-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 8141.385556] audit: type=1131 audit(1636750752.575:297): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-coredump@13-64853-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 8141.510559] audit: type=1334 audit(1636750752.702:298): prog-id=68 op=UNLOAD
[ 8141.510566] audit: type=1334 audit(1636750752.702:299): prog-id=67 op=UNLOAD
[ 8141.510568] audit: type=1334 audit(1636750752.702:300): prog-id=66 op=UNLOAD

Here’s the pastebin of the whole thing as well, but most of it is just logitech-djreceiver 0003:046D:C537.0006: Unexpected input report number 128 repeated over and over again

Tip: When pasting terminal output on Discourse forums, one can either…

  • Use the Preformatted text </> toolbar button–NOT the Quote " button.

  • Add three backticks ` above and below the text (Markdown):

    type or paste code here

  • Use HTML:

    type or paste code here

Please edit your posts accordingly.

1 Like

About the mouse input errors: That might be an error with the internal extra keys with a new kernel…

Well about sr0 errors, that is related your Optical Drive. Should be a bad DVD/CD.

About Vulkan… does this render a cube?




If so, then Vulkan works in general. The error must be related to the game then. Do as suggested:

Maybe try also to run steam with runtime:

killall steam

Kernel 5.13 is EOL to my knowledge. Might help to run newer kernel (such as 5.15) or a LTS kernel (such as 5.10).
All other than that, this problem is way over my knowledge.

Both commands render a cube, however it isn’t this game, it’s all games with vulkan, and by extension all proton games, so sending a dump log to Feral isn’t gonna do anything. The only reason I included the error from that specific game is because it’s the first one that came to mind that had a native vulkan version when I realized it might not be proton that was broken but vulkan as a whole. And I was running steam with runtime the whole time, I tried it again specifically enforcing it with your command but no dice.

I suppose if Vulkan works it could be steam? But I’ve reinstalled it twice, plus a couple native OpenGL games work fine with it, so I don’t understand how it could be that. I’m also gonna download another native vulkan game, I suppose it’s possible it’s just a problem with proton and Total War has a seperate, unrelated issue.

I did install another one and that one did work, so it appears it’s not a vulkan issue and the radv errors were red herrings, and Total war just happens to have an unrelated error.

Even further update, I’m just an idiot. It was an issue with the permissions from the NTFS drives I was mounting that most of my games were installed on, and I was just unlucky in the games that I decided to explicitly install on my ext4 drive, Total war had some unrelated issue and SCP Secret Lab had an update since I last played that broke proton compatibility, not only was there apparently never a vulkan issue, but there was also apparently never a proton issue, RIP the last couple days I spent trying to troubleshoot that

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.