All of my files are in read only mode

I was coding in VSCode then when I tried to save the file, it showed me an error. I tried booting to windows and I saw that all of my files are in read-only mode. Unchecking them one by one will take a lot of time. What should I do to fix this fast? Thanks in advance


██████████████████  ████████   soumi@Hori 
██████████████████  ████████   ---------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: Aspire A514-53 V1.16 
████████            ████████   Kernel: 5.14.2-1-MANJARO 
████████  ████████  ████████   Uptime: 3 hours, 14 mins 
████████  ████████  ████████   Packages: 1389 (pacman) 
████████  ████████  ████████   Shell: bash 5.1.8 
████████  ████████  ████████   Resolution: 1366x768 
████████  ████████  ████████   DE: Plasma 5.22.5 
████████  ████████  ████████   WM: KWin 
████████  ████████  ████████   Theme: Breeze Light [Plasma], Breeze [GTK2/3] 
████████  ████████  ████████   Icons: breeze [Plasma], breeze [GTK2/3] 
████████  ████████  ████████   Terminal: konsole 
                               CPU: Intel i3-1005G1 (4) @ 3.400GHz 
                               GPU: Intel Iris Plus Graphics G1 
                               Memory: 3845MiB / 7630MiB

What error, and where you saved the file? Your home directory should be always rw for you but system file aka / is not.

What filesystem are you using?

(Unknown (FileSystemError): Error: EROFS: read-only file system,

This is the error showed. I run windows on SSD and Manjaro on HDD

We are not understanding each other … Please provide:

lsblk -f


cat /etc/fstab

1 Like

lsblk -f

NAME    FSTYPE          FSVER  LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0   squashfs        4.0                                                        0   100% /var/lib/snapd/snap/gtk-common-themes/1515
loop1   squashfs        4.0                                                        0   100% /var/lib/snapd/snap/snapd/12883
loop2   squashfs        4.0                                                        0   100% /var/lib/snapd/snap/gnome-3-28-1804/161
loop3   squashfs        4.0                                                        0   100% /var/lib/snapd/snap/core18/2128
├─sda1  ntfs                   Luna     D8D4C804D4C7E2BC                                    
├─sda2  ext4            1.0             3e711149-8ebe-45af-8e9a-78a1cdacff3f  326.4G    12% /
├─sda3  swap            1               d27dc7f4-ce4f-48b8-ba69-9971d9cc4ca0                [SWAP]
└─sda4  vfat            FAT32  NO_LABEL 3DC6-A581                             510.7M     0% /boot/efi
nvme0n1 isw_raid_member 1.4.01                                                              
nvme1n1 isw_raid_member 1.4.01                                                              

cat /etc/fstab

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=3e711149-8ebe-45af-8e9a-78a1cdacff3f /              ext4    defaults,noatime 0 1
UUID=d27dc7f4-ce4f-48b8-ba69-9971d9cc4ca0 swap           swap    defaults,noatime 0 0
UUID=3DC6-A581                            /boot/efi      vfat    umask=0077 0 2

The reply in the other topic should fix this issue too.

1 Like

@bogdancovaciu has pointed you in the right direction

Let’s take it one more time for Prince Charles

When you are dual-booting Windows and Manjaro - and the folder you want to write to is on a Windows partition (NTFS) - then you must ensure that Windows is not using features like hibernation, sleep or Fast Startup as such features leaves an open filesystem which the Linux ntfs-3g module - because it creates a filesystem corruption in NTFS - will refuse to write to.


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.