All mirrors returns error 404

When i update pacman -Syu, or -Syyu, or -Syy, all mirrors returns me error 404, but internet work.Whats wrong? im on raspberry 4

Hi friend,
I think maybe you missed this announcement:

[ ach. @scachemaille schtatimille. :racing_car: :stuck_out_tongue_winking_eye: ]

:sweat: :sweat: :sweat:
And how i update the pacman-mirrorlist?sorry i m a newby

sudo pacman -U http://ftp-osl.osuosl.org/pub/manjaro-arm/repo/stable/aarch64/core/pacman-mirrorlist-20200211-1-any.pkg.tar.xz

5 Likes

Thanks a lot!

I'm also seeing this problem. And get the following error when trying to update mirror list:

loading packages...

"error: '/var/cache/pacman/pkg/pacman-mirrorlist-20200211-1-any.pkg.tar.xz': package missing required signature"

Moved from raspian to manjaro around 2 hours ago.. so it's most likely some amateur mistake!

Try deleting that package and download it again by running @philm command above.

1 Like

That worked, thanks!

I tried all of this and still get the error "failed to retrieve file" followed by a bunch of files. I'm on Rpi4

You might be missing one step.

First you have to update pacman-mirrorslist by issuing:

sudo pacman -U http://ftp.osuosl.org/pub/manjaro-arm/repo/stable/core/aarch64/pacman-mirrorlist-20200217-1-any.pkg.tar.xz.sig

After it finishes type:

sudo pacman-mirrors -g

To generate the new mirrorlist and you should be good to go if I remember correctly.

That osuosl.org link is now also 404'ing. So the pacman -U isn't working because that URL is also 404'ing.

I updated the link to the newest package. Thanks!

2 Likes

Forum kindly sponsored by