All display managers fail to load and X can't start a server

I’ve only been using Linux for around a month so I’m pretty much complete newb.
I tried to boot the computer the other day but I got the error ‘Failed to start Light Display Manager’.
I looked on the forums and tried a variety of things but none of them have worked.
I have tried:

to update the entire system using pacman -Syyu

reinstalling LightDM as well as running it in debug-mode, but I don’t really know what to look for haha

using SDDM

changing kernel

updating the graphics drivers using mhwd -a pci free 0300

running xstart and xstartxfce4

then I looked on the X wiki and then in my X11 conf dir. Inside that there was only 00-keyboard.conf, (which I thought must be an error, why would there be just a conf for the keyboard?) so I made a skeleton conf using the command on the Xwiki Xorg -configure and moved it into the conf dir. And it still wouldn’t run

I can upload some photos of logs if that helps
TYIA! :slightly_smiling_face:

well I ended up just backing up everything from a live boot and then reinstalling, works fine now.

1 Like
  1. Congrats on solving your own problem and sharing with the community!
  2. Next time, please mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.
  3. You might be interested in this:


Ah right I will remember and thanks for the article! :grin:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.