ALC294 Analog - Audio card detected, but no sound internaly or headphones


#1

Hi everyone, I got this new laptop ASUS Zenbook S UX391UA, and I still haven’t manage to make the sound work. The card gets detected, the pavucontrol shows audio bar moving, but I don’t get any sound from the speakers, everything looks fine and still nothing… This is a fresh install, I tried just with alsa then I have installed pulseaudio… still nothing :frowning:

  1. I have try with the latest kernel 4.18, didnt work
  2. I have tried adding these settings options snd-hda-intel model=laptop-dmic,headset-mic to /etc/modprobe.d/alsa-base.conf - didnt work
  3. I installed pulseaudio, still didn’t work
  4. I unmuted these channels using amixer and it didn’t work
$ amixer sset Master unmute
$ amixer sset Speaker unmute
$ amixer sset Headphone unmute
  1. Based on another user with the same problem, I will try this: [SOLVED] Asus UX430U sound card not working with kernel 4.16 / 4.14 / 4.9, leave the computer to run out of battery… sounds weird, but I will try. -Didnt work for me
  2. Trying alsa-base.conf with different configurations…
$cat /etc/modprobe.d/alsa-base.conf 
options snd-hda-intel model=asus
  1. Reset BIOS to default - didnt work
  2. Add this changes https://wiki.archlinux.org/index.php/ASUS_Zenbook_UX390 - didnt work

This issue is similar to this user that has the same model: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1784485

Can anyone help me how I can solve this ?

Thank you

Claudio

# inxi -Fxzc0
System:    Host: claudio-pc Kernel: 4.14.57-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.1.1 
           Desktop: i3 4.15.0.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: ZenBook S UX391UA v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: UX391UA v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: UX391UA.203 date: 04/02/2018 
Battery:   ID-1: BAT0 charge: 39.3 Wh condition: 51.0/50.0 Wh (102%) model: ASUSTeK ASUS Battery 
           status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake 
           rev: A L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 801 3: 801 4: 800 
           5: 800 6: 800 7: 800 8: 800 
Graphics:  Card-1: Intel UHD Graphics 620 driver: i915 v: kernel bus ID: 00:02.0 
           Display: server: X.Org 1.19.6 driver: intel unloaded: modesetting 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 18.1.4 
           direct render: Yes 
Audio:     Card-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.14.57-1-MANJARO 
Network:   Card-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel bus ID: 01:00 
           IF: wlp1s0 state: up mac: <filter> 
           Card-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 1:2 
Drives:    Local Storage: total: 476.94 GiB used: 10.26 GiB (2.2%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW512HMJP-00000 size: 476.94 GiB 
Partition: ID-1: / size: 451.35 GiB used: 10.26 GiB (2.3%) fs: ext4 dev: /dev/dm-0 
           ID-2: swap-1 size: 17.07 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 205 Uptime: 1h 14m Memory: 15.52 GiB used: 2.34 GiB (15.1%) Init: systemd 
           Compilers: gcc: 8.1.1 Shell: bash v: 4.4.23 inxi: 3.0.18
# /usr/bin/alsa-info.sh

[Results from alsa-info.sh] link(http://www.alsa-project.org/db/?f=0c1c1b79ed7a78d4cce7231c1711e65d995e946c)

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC294 Analog [ALC294 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xec228000 irq 134
 $  hwinfo --sound
13: PCI 1f.3: 0403 Audio device                                 
  [Created at pci.378]
  Unique ID: nS1_.CMWMjFG1cGE
  SysFS ID: /devices/pci0000:00/0000:00:1f.3
  SysFS BusID: 0000:00:1f.3
  Hardware Class: sound
  Model: "Intel Audio device"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x9d71 
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x10a1 
  Revision: 0x21
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xec228000-0xec22bfff (rw,non-prefetchable)
  Memory Range: 0xec200000-0xec20ffff (rw,non-prefetchable)
  IRQ: 134 (666 events)
  Module Alias: "pci:v00008086d00009D71sv00001043sd000010A1bc04sc03i80"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Driver Info #1:
    Driver Status: snd_soc_skl is active
    Driver Activation Cmd: "modprobe snd_soc_skl"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

[RESOLVED in 4.19.10] Realtek ALC294 @ Intel Sunrise Point-LP PCH - No sound (speakers and headphones)
[Testing Update] 2018-08-03 - Kernels, Jade, Adapta, Haskell
[Testing Update] 2018-08-03 - Kernels, Jade, Adapta, Haskell
#2

Try this:


#3

Thank you for the information, I have tried but without success.

I am suspecting this issue as to do with the model of the Audio card.

I will keep this updated with the tests I will be doing.

Again thanks

Claudio


#4

Hi Claudio,

look here:


#5

Hi Ara,

I tried all the recent ones using mhwd-kernel without success.

cat /var/log/pacman.log|grep MANJARO
[2018-08-03 13:46] [ALPM-SCRIPTLET] ==> Starting build: 4.14.57-1-MANJARO
[2018-08-03 13:46] [ALPM-SCRIPTLET] ==> Starting build: 4.14.57-1-MANJARO
[2018-08-03 16:10] [ALPM-SCRIPTLET] ==> Starting build: 4.18.0-1-MANJARO
[2018-08-03 16:10] [ALPM-SCRIPTLET] ==> Starting build: 4.18.0-1-MANJARO
[2018-08-03 19:28] [ALPM-SCRIPTLET] ==> Starting build: 4.17.9-1-MANJARO
[2018-08-03 19:28] [ALPM-SCRIPTLET] ==> Starting build: 4.17.9-1-MANJARO
[2018-08-05 04:27] [ALPM-SCRIPTLET] ==> Starting build: 4.17.9-1-MANJARO
[2018-08-05 04:27] [ALPM-SCRIPTLET] ==> Starting build: 4.17.9-1-MANJARO
[2018-08-05 04:28] [ALPM-SCRIPTLET] ==> Starting build: 4.16.18-1-MANJARO
[2018-08-05 04:28] [ALPM-SCRIPTLET] ==> Starting build: 4.16.18-1-MANJARO
[2018-08-05 04:29] [ALPM-SCRIPTLET] ==> Starting build: 4.15.18-3-MANJARO
[2018-08-05 04:29] [ALPM-SCRIPTLET] ==> Starting build: 4.15.18-3-MANJARO

I have also change pavucontrol to use different profiles, etc…

Also if I have a video in the background, I can see the sound bar moving, but no sound coming out of the speakers…

I also tested the new kernel
[2018-08-05 05:04] [ALPM-SCRIPTLET] ==> Starting build: 4.17.12-1.1-MANJARO. No success

I will reinstall windows to make sure again the speakers is working and then reinstall again Manjaro with the new kernel.

Thanks again

Claudio


#6

Then your issue is something different. You may test kernels from here.


#7

Hi Philm

I manage to load windows 10, and an interesting thing happen there too… I didnt have any sound too, only after I download and installed the drivers for Realtek the sound worked well on windows.

I did another reinstall of manjaro, and load kenel linux417-4.17.12-1.2, and still didn,t work. It could be that this issue I am having needs some snd_pci_quirks for a specific laptop, similar to this patch http://tomoyo.osdn.jp/cgi-bin/lxr/source/sound/pci/hda/patch_realtek.c?v=linux-4.17.12

I will keep trying more…

All the best

Claudio


#8

Does windows device manager show any advanced options for Realtek driver? if advanced options are switched off is sound still ok in windows?

First post is unclear - you say you tried playing audio using ALSA only, then installed Pulseaudio.
But Pulseaudio should already be installed
I just wonder if you were actually bypassing Pulseaudio and only using ALSA

amixer mute commands were unlikely to work
With no card number in command it would just try to change default (virtual Pulseaudio controls)

suggest you remove model name from alsa configuration
then use alsamixer -c 0 --view Playback or amixer -c 0 (text version)
post screenshot or text here
and confirm what you are using to test ALSA only audio


#9

Hi nikgomic,

Hopefully the information below will make things more clear.

$ ls /etc/modprobe.d/
alsa-base.conf  i915.conf
$ cat /etc/modprobe.d/alsa-base.conf 
options snd-hda-intel index=0

No pulseaudio is installed on my computer, so it should running only with Alsa

$ pacman -Qi pulseaudio
error: package 'pulseaudio' was not found
$ amixer -c 0
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [30.00dB]
  Front Right: 3 [100%] [30.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 63 [100%] [30.00dB] [off]
  Front Right: Capture 63 [100%] [30.00dB] [off]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
$ alsamixer -c 0 --view Playback 

There is no sound coming out of the speakers

I have installed Pulseaudio after

$ sudo pacman -S pulseaudio pavucontrol pulseaudio-alsa pulseaudio-bluetooth
[sudo] password for claudio: 
resolving dependencies...
looking for conflicting packages...

Packages (4) pavucontrol-1:3.0+23+g335c26c-1  pulseaudio-12.2-1  pulseaudio-alsa-2-4
             pulseaudio-bluetooth-12.2-1

Total Installed Size:  6,90 MiB

:: Proceed with installation? [Y/n] y
(4/4) checking keys in keyring                                [##################################] 100%
(4/4) checking package integrity                              [##################################] 100%
(4/4) loading package files                                   [##################################] 100%
(4/4) checking for file conflicts                             [##################################] 100%
(4/4) checking available disk space                           [##################################] 100%
:: Processing package changes...
(1/4) installing pulseaudio                                   [##################################] 100%
Created symlink /etc/systemd/user/sockets.target.wants/pulseaudio.socket → /usr/lib/systemd/user/pulseaudio.socket.
Optional dependencies for pulseaudio
    pulseaudio-alsa: ALSA configuration (recommended) [pending]
(2/4) installing pavucontrol                                  [##################################] 100%
Optional dependencies for pavucontrol
    pulseaudio: Audio backend [installed]
(3/4) installing pulseaudio-alsa                              [##################################] 100%
(4/4) installing pulseaudio-bluetooth                         [##################################] 100%
:: Running post-transaction hooks...
(1/4) Compiling GSettings XML schema files...
(2/4) Reloading device manager configuration...
(3/4) Arming ConditionNeedsUpdate...
(4/4) Updating the desktop file MIME type cache...

I still don’t get any sound coming out of the speakers or headphones.

Regarding your other questions…

Does windows device manager show any advanced options for Realtek driver? if advanced options are switched off is sound still ok in windows?

I didn’t check it, I just installed windows 10, sound was not working then I installed the realtek drivers, once the sound was working I deleted everything again and installed Manjaro…

If you need more screenshots of more configuration details, please let me know, I am happy to do that…

Thank you

Claudio


#10

Thanks for clarifying
so initial state was ALSA only - no sound
Pulseaudio appears to be working ok, but still no sound due to unresolved ALSA problem
This was what confused me as could not see any logic to adding extra audio layer above non-working layer

I did websearch on “Linux ALC294”

This from may 2016 - codecs support for ALC234/ALC274/ALC294 - 4.6 Kernel
and almost no results of user reporting Linux sound problems suggest it works for most Linux users

except this page and another two:

these 2 and previous linked launchpad bug show windows 10 connection to all of them
Askubuntu post indicates problem caused by windows shutdown process

Other forum posts on here about dual-booting / windows may help


Sound randomly stopped working
#11

Hi Nikgnomic,

Thanks for the links and help.

Just a bit of background regarding of this laptop. Initially I didn’t have dual booting, I just bought this computer that was preloaded with Windows 10 and I completely deleted it and installed Manjaro.

All this time, I have been running only Manjaro.

Like you said, it seems it is related with the windows shutdown…

I delete everything again, and now I am doing dual boot, (manjaro and windows 10).
Still the sound is not working on Manjaro, but works fine on Windows.
I also disabled windows FAST BOOT…
I have also reset the BIOS via its option…

No success yet. I will run more tests on it to see if I can make it work.

All the best

Claudio


#12

sudo nano /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model==generic

sudo alsa reload

Also check this: https://bbs.archlinux.org/viewtopic.php?id=235291

ZenBooks are not Linux friendly in general. But I recommend to start totally fresh with Manjaro 18.0 and format your whole disk as mostly Windows creates issues with this.


#13

Hi Philm,

I have tried with generic and different model, still no result.

Based on the other user results, what was working and not working:

>  ~  systool -vm snd_hda_intel                 
13c12
<     refcnt              = "4"
---
>     refcnt              = "3"

Currently on mine

systool -vm snd_hda_intel

refcnt = 1

if there was a way to force it to 4, maybe that is the solution?!

I will keep testing other versions (Manjaro 18) and other distros and in the end, if all doesn’t work, I will have to just “bite the bullet” and use Bluetooth headphones since that is the only way I could get sound.

Thanks for the help

Claudio


#14

Just got notified of an answer on Stack Exchange, one of the links I posted earlier, and OP has marked it as solution:

I found that this problem is common in windows/linux dual boot systems and the solution for me was putting system into suspend mode by running systemctl suspend in linux system and when you get back everything is ok, sound is working again


#15

Thanks Nikgnomic

I have been using that trick to get my mouse to work when I boot Manjaro or recently in ubuntu. But in both distros the mouse worked, but the sound didn’t work.

But now that you point out as a potential hack for the sound to work, I will try to change to some different snd_hda_intel models, in combination with different kernels and that suspend command to see if works…

I will keep you updated if I get this solved

Again thanks

Claudio


#16

Hi @claudfernandes,

I have also run into the same problem, I’m using Ubuntu Budgie 18.04.
The audio works in Windows whereas it doesn’t in Linux (i’ve tried various distros).
Did you happen to figure out anything more about this issue?

Thanks,
Nitish


#17

Did anybody solve this issue? I have the exact same problem

Thank you,

A


#18

Looks like nothing confirmed as solution yet

If you have similar situation with audio codec and dual-boot, suggest you start an new topic
post your system information from aplay -l and hwinfo --sound
and explain what happened with anything you tried from comments here


#19

The problem is not with dual boot since I have only linux as an operating system. I’ve tried all the suggestions above, nothing works. I’ve also tried installing windows (on windows sound works).


#20

still nothing? nobody got it working?