Alarm sound on all audio playback

When I play any youtube or spotify audio, it is interrupted by an alarm sound , a loud steady tone, after a few minutes, so far less than a minute to about 7 minutes. This happens consistently. The tone continues until I close the browser tab. In youtube it may correspond to when the stream is buffering, but it could also be that whatever is causing the tone is preventing playback. I get a circling indicator as if the stream were buffering.

This is happening on a system where I just installed manjaro on a Dell C11 3120 chromebook. This has a Baytrail processor and the board name is Candy. I have used it with chromeOS for years without this audio interruption issue ever occurring. I’ve used it for zoom/avaya meetings under chromeOS as well. I also used crouton under chromeOS without this issue. Google stopped supporting this chromebook this month.

To install manjaro, I updated the firmwware by removing the WP screw from the motherboard and using the build from Do I have to put that screw back in? I left it out.

I’m getting the alarm both under Firefox and Chromium. I’m using Firefox 92.0 installed through the manjaro gui package manager. Chromium is 93.0.4577.82.

The chromebook sound buttons work.

The buffering is new too. I am on the same network and buffering was not an issue previously. It seems like the problem gets worse with each iteration in a given browser session. So I start one tab - get the alarm noise after 7 minutes, close the tab and open a new one and then the alarm starts in 4 minutes. I close that second tab and open a third, and the alarm starts in 1 minute, etc.

Here are various sound related command results

arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: max98090 [sof-bytcht max98090], device 0: PCM (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: max98090 [sof-bytcht max98090], device 0: PCM (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: max98090 [sof-bytcht max98090], device 1: PCM Deep Buffer (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
aplay -L
    Discard all samples (playback) or generate zero samples (capture)
    Rate Converter Plugin Using Samplerate Library
    Rate Converter Plugin Using Speex Resampler
    JACK Audio Connection Kit
    Open Sound System
    PipeWire Sound Server
    PulseAudio Sound Server
    Plugin using Speex DSP (resample, agc, denoise, echo, dereverb)
    Plugin for channel upmix (4,6,8)
    Plugin for channel downmix (stereo) with a simple spacialization
    Default ALSA Output (currently PulseAudio Sound Server)
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
    HDA Intel PCH, HDMI 1
    HDMI Audio Output
    HDA Intel PCH
    USB Stream Output
    sof-bytcht max98090, 
    Default Audio Device
    sof-bytcht max98090
    USB Stream Output
00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0e)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0e)
00:1b.0 Audio device: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)
00:1c.0 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 1 (rev 0e)
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0e)
01:00.0 Network controller: Intel Corporation Wireless 7260 (rev bb)

Is this only with Chromium and Firefox? Have you tested if the same behaviour occurs using a local media player, such as VLC or mpv?

I just tested it with mpv and the same thing happens. I used the Schubert test file from hyperion “free downloads for testing” website. (I’m not allowed to post urls) It stops with this alarm noise at 1:40 with 2:00 minutes left to play.
As with the browser tab, the alarm sound continues until I close the app and then stops 5 to 10 seconds after it is closed.

I should clarify that the chromebook buttons work only to control the audio before the alarm sounds. When the alarm sounds the only way to turn it off is to close the tab with the player, or the mpv player that was playing audio.

I saw that there are alarms generated by kernel and controlled by the bios. Are they audible? Is there a way to see what particular alarm might be triggered by mp3 (or other audio / video) playback?

I don’t have a /etc/modprobe.d/modprobe.conf file. Some solutions to a different problem (no sound) say to add a line to this file, but I don’t have one at all. How is it generated?

Manjaro does not usually have any /etc/modprobe.d/modprobe.conf files preinstalled like some other distributions

But if a user needs to add modprobe options they can create their own file. For audio modprobes the name usually does not matter. It can be called anything as long as it has .conf suffix

1 Like

I like to use 99- to denote custom changes I made, which always take less priority than system- and package-created ones.

As an example, 99-audio-fix.conf

Ordering modprobe options alphanumerically is usually not necessary for one or two audio options

I used to just suggest using alsa-base.conf but now I try to use unique names for suggesting modprobes on here so they are easier to find on forum search (and I might even remember it)

for example:

echo 'blacklist pcspkr' | sudo tee --append /etc/modprobe.d/nobeep.conf > /dev/null

The "99-" thing is mainly a reference to keeping track of your own custom .conf files, to mentally separate them from distro and package defaults.

1 Like

If the folder already has numbered files the order of execution does need to be considered

The ordering is important for audio when changing udev rules:
The default rules are located in /usr/lib/udev/rules.d/90-pulseaudio.rules
If a user wanted to add a custom rule they may need to create a file 89-pulseaudio.rules to work ahead of the usual rules
OR 91-pulseaudio.rules to override an existing rule

Many thanks for these insights into conf files and rules. I ended up installing xubuntu 21.04. This has no alarm sounds in audio playback. BUT voices are shifted much lower in pitch, so sound is still unusable.

1 Like