[Akoya E4254] Touchpad not working


#14

You only had to run, the commands i mentioned, just once …

AFAIK you don’t need synaptics, and that’s not the code i said to use for the 30-touchpad.conf file.
this is:

Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "TappingButtonMap" "lmr"
EndSection

If you follow the discussion on the post i linked previously, you will see that i asked to see if the /etc/X11/xorg.conf.d/10-edev.conf exists and how to deal with it, what needs edited, and why we created the 11-evdev.conf instead, and should only have this code:

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

When you edit them, pay attention to have it opened just once, save once is modified and then close the file.

If the above doesn’t help after you check them and reboot, let me see the output of:
for i in /etc/X11/xorg.conf.d/*; do printf "$i:\n%s\n" "$(<$i)"; done
it seems you might have another conf there that prevents the touchpad to work.


#15

hello dear bogdancovaciu,

many many thanks for the reply and the ongoing and sustainable support.

i will apply all the changes later the weekend (as i am in office now and do not
have the Notebook with me)

i ll keep you reported everything that happens.

have a great day!!

greetings


#16

dear bogdancovaciu many thanks again -

well did get you right - we need to have the following code in the file!?

love to hear from you

greetings


#17

by the way - when i want to store the file - then i see that it is in the following path

/var/tmp/

is this correct - i guess that this is not correct!?


#18

sudoedit creates and edits a temp file before moving changes to the actual file. This is by design - simply ignore the random string it shows as the save location (accept it).


#19

hello dear all,

instead of making use of the terminal i editet them while looking for the relevant file in dolphin…

SUDO_EDITOR=kate sudoedit /etc/X11/xorg.conf.d/30-touchpad.conf

in other words - i used dolpin to find out the corresponding files:;

here in this path i have the both files:
see the path; /etc/X11/xorg.conf.d/

see the files:

[martin@martin-pc xorg.conf.d]$ ls -l
insgesamt 4
-rw-r--r-- 1 root root 266 24. Jul 23:52 00-keyboard.conf
-rw-r--r-- 1 root root   0 26. Jul 22:38 30-touchpad.conf
[martin@martin-pc xorg.conf.d]$

first i edited this


Section "InputClass"
        Identifier "touchpad"
        Driver "libinput"
        MatchIsTouchpad "on"
        Option "Tapping" "on"
        Option "TappingButtonMap" "lmr"
    EndSection
  • after the process of editing i did a newstart :slight_smile:
    result - the mouse and tracking functions of the touchpad do not work…

then i edited this

Section "InputClass"
            Identifier "evdev pointer catchall"
            MatchIsPointer "on"
            MatchDevicePath "/dev/input/event*"
            Driver "evdev"
    EndSection
  • after the process of editing i did a newstart :slight_smile:
    result - the mouse and tracking functions of the touchpad do not work…

conclusion: nothing helped here - i restarted the notebook
but this did not help …

only the cable based mouse works well - the thouchpad does not work - with both code above.

then i tried out to get more insights: i entered this code:


for i in /etc/X11/xorg.conf.d/*; do printf "$i:\n%s\n" "$(<$i)"

this only gives back this sign…,:
>

what do you suggest now - what can i do now?


#20

Ok @malaga, better that way, but:

  1. Do NOT edit the 00-keyboard.conf
  2. The 30-touchpad.conf should have only this lines:
Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "TappingButtonMap" "lmr"
EndSection
  1. You forget about the 11-evdev.conf file that needs this entry:
Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

I honestly don’t know how to make this more clear.

Because you need the entire line i mentioned:

Do you see the difference ? :slight_smile:

EDIT: had to correct a mistake in copy/paste/copy/paste from the forum …


#21

hello dear bogdancovaciu, many thanks for the continued support. i did as you adviced - i have added the 11-evdev.conf file with the above mentioned content…

i restarted the notebook - but the mouse and the clickpad only functions with the wire-Mouse.

i entered the command you mentioned above - see the results:



[martin@martin-pc xorg.conf.d]$ su
Passwort: 
[martin-pc xorg.conf.d]# for i in /etc/X11/xorg.conf.d/*; do printf "$i:\n%s\n" "$(<$i)"; done
/etc/X11/xorg.conf.d/00-keyboard.conf:
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
EndSection
/etc/X11/xorg.conf.d/11-evdev.conf:
Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection
/etc/X11/xorg.conf.d/30-touchpad.conf:
Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "TappingButtonMap" "lmr"
EndSection
[martin-pc xorg.conf.d]#

well - what can we do now - did i do something wrong?

i look forward to hear from you

regards


#22

Two Mouse devices or you refer to trackball ?
If you unplug the wired mouse and reboot, is the touchpad detected?
Does you laptop have a “Fn+F5” or other combination to turn off the touchpad?
what is the output of:
xinput -list


#23

good evening dear bogdancovaciu

many thanks for the continued support and help. i do not have two mouse devices - i referred to the trackball

  • i have the Fn & F5 keys on my notebook - but if i press them (togehter ) then i get a linux based search window in the (top-) center of the screen.

the command xinput -list gives back the following


martin@martin-pc ~]$ xinput -list
bash: xinput: Kommando nicht gefunden.
[martin@martin-pc ~]$ su
Passwort: 
[martin-pc martin]# xinput -list
bash: xinput: Kommando nicht gefunden.
[martin-pc martin]#

Kommando nicht gefunden - > command not found

look forward to hear from you again -


#24

Let’s install the required packages to be sure
sudo pacman -S xorg-xinput xf86-input-libinput libinput
reboot and see xinput -list


#25

hello and good day,

executed the above mentioned commands - and got back the following




[martin@martin-pc xorg.conf.d]$ sudo pacman -S xorg-xinput xf86-input-libinput libinput
[sudo] Passwort für martin: 
Warnung: xf86-input-libinput-0.28.0-1 ist aktuell -- Reinstalliere
Warnung: libinput-1.11.2-1 ist aktuell -- Reinstalliere
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (3) libinput-1.11.2-1  xf86-input-libinput-0.28.0-1  xorg-xinput-1.6.2-2

Gesamtgröße des Downloads:           0,02 MiB
Gesamtgröße der installierten Pakete:  4,52 MiB
Größendifferenz der Aktualisierung:  0,05 MiB

:: Installation fortsetzen? [J/n] j
:: Empfange Pakete...
 xorg-xinput-1.6.2-2-x86_64                                           25,4 KiB   634K/s 00:00 [#######################################################] 100%
(3/3) Prüfe Schlüssel im Schlüsselring                                                        [#######################################################] 100%
(3/3) Überprüfe Paket-Integrität                                                              [#######################################################] 100%
(3/3) Lade Paket-Dateien                                                                      [#######################################################] 100%
(3/3) Prüfe auf Dateikonflikte                                                                [#######################################################] 100%
(3/3) Überprüfe verfügbaren Festplattenspeicher                                               [#######################################################] 100%
:: Verarbeite Paketänderungen...
(1/3) Installiere xorg-xinput                                                                 [#######################################################] 100%
(2/3) Installiere libinput                                                                    [#######################################################] 100%
(3/3) Installiere xf86-input-libinput                                                         [#######################################################] 100%
:: Starte post-transaction hooks...
(1/3) Updating udev hardware database...
(2/3) Reloading device manager configuration...
(3/3) Arming ConditionNeedsUpdate...
[martin@martin-pc xorg.conf.d]$

and here i rebooted the system -
with the mouse - connected via a cable…

…and after the reboot i runned the xinput - list command


[martin@martin-pc ~]$  xinput -list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Optical USB Mouse                id=8    [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ USB 2.0 Camera : USB 2.0 Camera           id=9    [slave  keyboard (3)]
    ↳ Intel HID events                          id=10   [slave  keyboard (3)]
    ↳ Intel HID 5 button array                  id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
[martin@martin-pc ~]$
  • and now i disconnedt the mouse - and will reboot the system again…

#26

hello again

here i am back - and here you see the results of the command xinput -list that i have got back - without a logitech mouse connected.

as mentioned above: i made a reboot of the system - without a mouse connected.

result: the mousepad did not work - here the results of the code


martin@martin-pc ~]$ xinput -list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ USB 2.0 Camera : USB 2.0 Camera           id=8    [slave  keyboard (3)]
    ↳ Intel HID events                          id=9    [slave  keyboard (3)]
    ↳ Intel HID 5 button array                  id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]
[martin@martin-pc ~]$

what can we do now!? - look forward to hear from you


#27

dear manjaro experts,

any idea what i can do with the akoya e 4254 - notebook and the touchpad issue.

i would love to hear from you - best would be a continue conversation on the according thread - so that all the visitors can learn --,

best regards malaga


#28

The xinput -list command doesn’t show any trace of a touchpad device. Make sure that your laptop has it enabled. Usually there should be a Fn+F5 or some combination like that. Also check the BIOS if is enabled there.
Also, once you added my suggested files, did you removed the xf86-input-synaptics package to make sure there is no event that triggers it or some rule that will inhibit any other config?
What is the output of:

for i in /usr/share/X11/xorg.conf.d/*; do printf "$i:\n%s\n" "$(<$i)"; done

#29

good day dear bogdancovaciu

many thanks for the continued support,…

i have runned the code,-,

[martin-pc martin]# for i in /usr/share/X11/xorg.conf.d/*; do printf "$i:\n%s\n" "$(<$i)"; done
/usr/share/X11/xorg.conf.d/10-amdgpu.conf:
Section "OutputClass"
        Identifier "AMDgpu"
        MatchDriver "amdgpu"
        Driver "amdgpu"
EndSection
/usr/share/X11/xorg.conf.d/10-evdev.conf:
#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection
/usr/share/X11/xorg.conf.d/10-quirks.conf:
# Collection of quirks and blacklist/whitelists for specific devices.


# Accelerometer device, posts data through ABS_X/ABS_Y, making X unusable
# http://bugs.freedesktop.org/show_bug.cgi?id=22442 
Section "InputClass"
        Identifier "ThinkPad HDAPS accelerometer blacklist"
        MatchProduct "ThinkPad HDAPS accelerometer data"
        Option "Ignore" "on"
EndSection

# https://bugzilla.redhat.com/show_bug.cgi?id=523914
# Mouse does not move in PV Xen guest
# Explicitly tell evdev to not ignore the absolute axes.
Section "InputClass"
        Identifier "Xen Virtual Pointer axis blacklist"
        MatchProduct "Xen Virtual Pointer"
        Option "IgnoreAbsoluteAxes" "off"
        Option "IgnoreRelativeAxes" "off"
EndSection

# https://bugs.freedesktop.org/show_bug.cgi?id=55867
# Bug 55867 - Doesn't know how to tag XI_TRACKBALL
Section "InputClass"
        Identifier "Tag trackballs as XI_TRACKBALL"
        MatchProduct "trackball"
        MatchDriver "evdev"
        Option "TypeName" "TRACKBALL"
EndSection

# https://bugs.freedesktop.org/show_bug.cgi?id=62831
# Bug 62831 - Mionix Naos 5000 mouse detected incorrectly
Section "InputClass"
        Identifier "Tag Mionix Naos 5000 mouse XI_MOUSE"
        MatchProduct "La-VIEW Technology Naos 5000 Mouse"
        MatchDriver "evdev"
        Option "TypeName" "MOUSE"
EndSection
/usr/share/X11/xorg.conf.d/10-radeon.conf:
Section "OutputClass"
        Identifier "Radeon"
        MatchDriver "radeon"
        Driver "radeon"
EndSection
/usr/share/X11/xorg.conf.d/40-libinput.conf:
# Match on all types of devices but joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection
/usr/share/X11/xorg.conf.d/70-synaptics.conf:
# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection
[martin-pc martin]#

again - the bios things i will check tomorror - also i will make sure that i have med all the basic configurations of the notebook - in other words - the official setup of the new notebook itself.

in other words - i will have a closer look at the manual - and hopefully will be able to fix the issue .
while reading the man-pages i hooe fo find out the issues of eventually blocking the mouse-pad. r

i come back and report all the findings .


#30

Remove the synaptics config.
sudo rm /usr/share/X11/xorg.conf.d/70-synaptics.conf


#31

good day

[martin@martin-pc xorg.conf.d]$ sudo rm /usr/share/X11/xorg.conf.d/70-synaptics.conf
rm: das Entfernen von '/usr/share/X11/xorg.conf.d/70-synaptics.conf' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
[martin@martin-pc xorg.conf.d]$

file not found …

now i will look for the

a. boot related things and
b. F5 + Fn - related thiings

i come back andreportr all the findings


#32

It was reported by the previous command and you posted it’s content

Anyway … try a newer kernel …


closed #33

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.