After woken up my computer from sleeping my Wifi does not work

connected to Wifi --> sleep --> wake up --> disconnect to Wifi and cannot find any Wifi source

Try disabling MAC address randomization in /etc/NetworkManager/NetworkManager.conf and change it to have this lines:


save it and then run from terminal:
systemctl restart NetvorkManager

It could also be your tlp, which is a power management tool.
NOTE: I am not at all an expert, you could try this until someone with exp replies.

1 Like

Hi, I have no problems with wake up.
Go to System Settings, Energy Saving and take a look at the end of the section if the Wireless has the default value which is Leave Unchanged.

Hope it help, regards

1 Like