After upgrade problem

I just upgraded my Manjaro (4.19.42-1-MANJARO) today 17-05-2019 .

First I had a problem in the upgrade that I gave me a corrupt pamac package and keep me from upgrading my system.
I removed pamac all together from my system in order to be able to upgrade. May it has a invalid PGP signature, don't know (and don't know where to get the official PGP since https://gitlab.manjaro.org/applications/pamac/blob/master/README.md doesn't give one).
So that needs fixing.

After that I was able to upgrade, rebooted (everything fine so far) but when I played some sound it gives me a static noise on every sound, even on the system notification sound.

I don't know how that slip the cracks the testing that Manjaro is doing on the Arch Linux packages, don't know if that testing is being done all together.
So this is my critique.

And need help in fixing the sound issue, at least.

Thanks

PS: This are the packages that were upgrade

[2019-05-17 10:29] [ALPM] upgraded iana-etc (20190415-1 -> 20190504-1)
[2019-05-17 10:29] [ALPM] upgraded bashrc-manjaro (5.0.003-2 -> 5.0.007-1)
[2019-05-17 10:29] [ALPM] upgraded bash (5.0.003-1 -> 5.0.007-1)
[2019-05-17 10:29] [ALPM] upgraded glib2 (2.60.1-1 -> 2.60.2-1)
[2019-05-17 10:29] [ALPM] upgraded librsvg (2:2.44.13-1 -> 2:2.44.14-1)
[2019-05-17 10:29] [ALPM] upgraded libedit (20181209_3.1-1 -> 20190324_3.1-1)
[2019-05-17 10:29] [ALPM] upgraded llvm-libs (8.0.0-1 -> 8.0.0-2)
[2019-05-17 10:29] [ALPM] upgraded systemd-libs (242.16-1 -> 242.29-1)
[2019-05-17 10:29] [ALPM] upgraded pcre2 (10.32-2 -> 10.33-1)
[2019-05-17 10:29] [ALPM] upgraded systemd (242.16-1 -> 242.29-1)
[2019-05-17 10:29] [ALPM] upgraded libwacom (0.32-1 -> 0.33-1)
[2019-05-17 10:29] [ALPM] upgraded libinput (1.13.1-1 -> 1.13.2-1)
[2019-05-17 10:29] [ALPM] upgraded libx86emu (1.12-1 -> 2.3-1)
[2019-05-17 10:29] [ALPM] upgraded hwinfo (21.60-1 -> 21.60-2)
[2019-05-17 10:29] [ALPM] upgraded mhwd-nvidia (1:418.56-1 -> 1:418.74-1)
[2019-05-17 10:29] [ALPM] upgraded nvidia-utils (1:418.56-1 -> 1:418.74-1)
[2019-05-17 10:29] [ALPM-SCRIPTLET] xorg configuration symlink valid...
[2019-05-17 10:29] [ALPM-SCRIPTLET] ==> If you run into trouble with CUDA not being available, run nvidia-modprobe first.
[2019-05-17 10:29] [ALPM] upgraded mesa (19.0.3-1 -> 19.0.4-1)
[2019-05-17 10:29] [ALPM] upgraded avahi (0.7+18+g1b5f401-1 -> 0.7+18+g1b5f401-2)
[2019-05-17 10:29] [ALPM] upgraded glib-networking (2.60.1+2+g1ce6b40-1 -> 2.60.2-1)
[2019-05-17 10:29] [ALPM] upgraded audacity (1:2.3.1-1 -> 1:2.3.2-1)
[2019-05-17 10:29] [ALPM] upgraded bash-completion (2.8-1 -> 2.9-1)
[2019-05-17 10:29] [ALPM] upgraded bubblewrap (0.3.1-1 -> 0.3.3-1)
[2019-05-17 10:29] [ALPM] upgraded v4l-utils (1.16.5-1 -> 1.16.6-1)
[2019-05-17 10:29] [ALPM] upgraded chromium (74.0.3729.131-0 -> 74.0.3729.131-3)
[2019-05-17 10:29] [ALPM] upgraded clang (8.0.0-3 -> 8.0.0-4)
[2019-05-17 10:29] [ALPM] upgraded crypto++ (7.0.0-1 -> 8.2.0-1)
[2019-05-17 10:29] [ALPM] installed liblastfm-qt5 (1.0.9-4)
[2019-05-17 10:29] [ALPM] installed libmygpo-qt5 (1.1.0-2)
[2019-05-17 10:29] [ALPM] upgraded clementine (1.3.1-22 -> 1.3.1.r702.3b76fa627-2)
[2019-05-17 10:29] [ALPM] upgraded cmake (3.14.3-1 -> 3.14.4-1)
[2019-05-17 10:29] [ALPM] upgraded cpupower (5.0-1 -> 5.1-1)
[2019-05-17 10:29] [ALPM] upgraded deepin-anything-dkms (0.0.7-1 -> 0.0.8-1)
[2019-05-17 10:29] [ALPM] upgraded dtkcore (1:2.0.12.1-1 -> 1:2.0.13-1)
[2019-05-17 10:29] [ALPM] upgraded libbytesize (1.4-1 -> 2.0-1)
[2019-05-17 10:29] [ALPM] upgraded ndctl (64.1-2 -> 65-1)
[2019-05-17 10:29] [ALPM] upgraded parted (3.2-8 -> 3.2-9)
[2019-05-17 10:29] [ALPM] upgraded thin-provisioning-tools (0.8.0-1 -> 0.8.1-1)
[2019-05-17 10:29] [ALPM] upgraded deepin-anything (0.0.7-1 -> 0.0.8-1)
[2019-05-17 10:29] [ALPM] upgraded poppler (0.76.0-1 -> 0.76.1-1)
[2019-05-17 10:29] [ALPM] upgraded poppler-glib (0.76.0-1 -> 0.76.1-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-api (3.18.3-1 -> 3.18.4-1)
[2019-05-17 10:30] [ALPM] upgraded dtkwidget (2.0.12.3-2 -> 2.0.13-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-qt5dxcb-plugin (1.1.27-1 -> 1.2.0-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-calendar (1.2.6-1 -> 1.2.7-1)
[2019-05-17 10:30] [ALPM] upgraded papirus-icon-theme (20190331-1 -> 20190501-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-icon-theme (15.12.69-1 -> 15.12.70-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-desktop-schemas (3.13.0-1 -> 3.13.1-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-desktop-base (3:2019.04.24-1 -> 3:2019.05.12-1)
[2019-05-17 10:30] [ALPM] upgraded libwnck3 (3.30.0-1 -> 3.32.0-2)
[2019-05-17 10:30] [ALPM] upgraded deepin-daemon (3.27.1-1 -> 3.27.2-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-menu (3.4.6-1 -> 3.4.8-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-launcher (4.6.9-1 -> 4.6.10-1)
[2019-05-17 10:30] [ALPM] upgraded libdbusmenu-qt5 (0.9.3+16.04.20160218-2 -> 0.9.3+16.04.20160218-4)
[2019-05-17 10:30] [ALPM] upgraded deepin-dock (4.9.9-1 -> 4.9.13-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-file-manager (1:4.8.3-1 -> 1:4.8.4.1-1)
[2019-05-17 10:30] [ALPM] upgraded gnome-desktop (1:3.32.1.2-1 -> 1:3.32.2-1)
[2019-05-17 10:30] [ALPM] upgraded startdde (3.14.4-1 -> 3.14.5-1)
[2019-05-17 10:30] [ALPM] upgraded iproute2 (5.0.0-1 -> 5.1.0-1)
[2019-05-17 10:30] [ALPM] upgraded wpa_supplicant (2:2.6-2 -> 2:2.8-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-control-center (4.10.2-1 -> 4.10.4-1)
[2019-05-17 10:30] [ALPM] upgraded dtkwm (2.0.11-1 -> 2.0.11-2)
[2019-05-17 10:30] [ALPM] upgraded deepin-screen-recorder (2.7.10-1 -> 2.7.11-1)
[2019-05-17 10:30] [ALPM] upgraded perl-libwww (6.38-1 -> 6.39-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-screensaver (0.0.7-1 -> 0.0.8-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-turbo (0.0.2-1 -> 0.0.3-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-screenshot (4.1.10-1 -> 4.1.11-1)
[2019-05-17 10:30] [ALPM] upgraded lightdm (1:1.28.0-3 -> 1:1.28.0-4)
[2019-05-17 10:30] [ALPM] upgraded liblightdm-qt5 (1:1.28.0-3 -> 1:1.28.0-4)
[2019-05-17 10:30] [ALPM] upgraded deepin-session-ui (4.9.6-1.1 -> 4.9.7-1.1)
[2019-05-17 10:30] [ALPM] upgraded vte-common (0.56.2-1 -> 0.56.3-1)
[2019-05-17 10:30] [ALPM] upgraded vte3 (0.56.2-1 -> 0.56.3-1)
[2019-05-17 10:30] [ALPM] upgraded deepin-terminal (3.2.2.1-1 -> 3.2.3.1-1)
[2019-05-17 10:30] [ALPM] upgraded dhcpcd (7.0.8-1 -> 7.2.1-1)
[2019-05-17 10:30] [ALPM] upgraded discount (2.2.4-1 -> 2.2.6-1)
[2019-05-17 10:30] [ALPM] upgraded ebook-tools (0.2.2-5 -> 0.2.2-6)
[2019-05-17 10:30] [ALPM] upgraded exo (0.12.4-1 -> 0.12.5-1)
[2019-05-17 10:30] [ALPM] upgraded libfilezilla (0.15.1-1 -> 0.16.0-1)
[2019-05-17 10:30] [ALPM] upgraded filezilla (3.41.2-1 -> 3.42.1-1)
[2019-05-17 10:30] [ALPM] upgraded gd (2.2.5-1.1 -> 2.2.5-2)
[2019-05-17 10:30] [ALPM] upgraded gedit (3.32.0-2 -> 3.32.0-3)
[2019-05-17 10:30] [ALPM] upgraded js60 (60.6.1-1 -> 60.6.3-1)
[2019-05-17 10:30] [ALPM] upgraded gjs (2:1.56.1-1 -> 2:1.56.2-1)
[2019-05-17 10:30] [ALPM] upgraded glib2-docs (2.60.1-1 -> 2.60.2-1)
[2019-05-17 10:30] [ALPM] upgraded graphviz (2.40.1-14 -> 2.40.1-15)
[2019-05-17 10:30] [ALPM] warning: /etc/default/grub installed as /etc/default/grub.pacnew
[2019-05-17 10:30] [ALPM] upgraded grub (2.03.5-1 -> 2.03.6-4)
[2019-05-17 10:30] [ALPM] upgraded gssdp (1.2.0-1 -> 1.2.1-1)
[2019-05-17 10:30] [ALPM] upgraded python-pygments (2.3.1-1 -> 2.4.0-1)
[2019-05-17 10:30] [ALPM] upgraded gtk-doc (1.29-1 -> 1.30+1+g44c5972-1)
[2019-05-17 10:30] [ALPM] upgraded gtksourceview3 (3.24.10-1 -> 3.24.11-1)
[2019-05-17 10:30] [ALPM] upgraded gupnp (1.2.0-1 -> 1.2.1-1)
[2019-05-17 10:30] [ALPM] upgraded gupnp-igd (0.2.5+3+gedd78a6-1 -> 0.2.5+3+gedd78a6-2)
[2019-05-17 10:30] [ALPM] upgraded libraqm (0.5.0-1 -> 0.6.0-1)
[2019-05-17 10:30] [ALPM] upgraded imagemagick (7.0.8.42-1 -> 7.0.8.45-1)
[2019-05-17 10:30] [ALPM] upgraded inxi (3.0.33-1 -> 3.0.34-1)
[2019-05-17 10:30] [ALPM] upgraded signon-kwallet-extension (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded kaccounts-integration (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded mlt (6.14.0-5 -> 6.16.0-1)
[2019-05-17 10:30] [ALPM] upgraded poppler-qt5 (0.76.0-1 -> 0.76.1-1)
[2019-05-17 10:30] [ALPM] upgraded vulkan-icd-loader (1.1.101-1 -> 1.1.107-1)
[2019-05-17 10:30] [ALPM] upgraded kdenlive (19.04.0-3 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded kpimtextedit (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded libkleo (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded kmime (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded kleopatra (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded kmouth (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded libksane (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded kolourpaint (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded kwalletmanager (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded lib32-glib2 (2.60.1-1 -> 2.60.2-1)
[2019-05-17 10:30] [ALPM] upgraded lib32-libcap (2.26-1 -> 2.27-1)
[2019-05-17 10:30] [ALPM] upgraded lib32-libgpg-error (1.35-1 -> 1.36-1)
[2019-05-17 10:30] [ALPM] upgraded lib32-nvidia-utils (1:418.56-1 -> 1:418.74-1)
[2019-05-17 10:30] [ALPM-SCRIPTLET] xorg configuration symlink valid...
[2019-05-17 10:30] [ALPM] upgraded lib32-mesa (19.0.3-1 -> 19.0.4-1)
[2019-05-17 10:30] [ALPM] upgraded lib32-systemd (242.16-1 -> 242.29-1)
[2019-05-17 10:30] [ALPM] upgraded libkexiv2 (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:30] [ALPM] upgraded libspeechd (0.9.0-1 -> 0.9.1-1)
[2019-05-17 10:30] [ALPM] upgraded linux-firmware (20190313.efd2c1c-1 -> 20190424.4b6cf2b-1)
[2019-05-17 10:31] [ALPM] upgraded linux419 (4.19.36-1 -> 4.19.42-1)
[2019-05-17 10:31] [ALPM] upgraded linux419-headers (4.19.36-1 -> 4.19.42-1)
[2019-05-17 10:31] [ALPM] upgraded linux419-nvidia (1:418.56-3 -> 1:418.74-2)
[2019-05-17 10:31] [ALPM] upgraded linux419-r8168 (8.045.08-31 -> 8.047.01-1)
[2019-05-17 10:31] [ALPM] upgraded man-pages (5.00-1 -> 5.01-1)
[2019-05-17 10:31] [ALPM] upgraded metis (5.1.0.p5-1 -> 5.1.0.p6-1)
[2019-05-17 10:31] [ALPM] upgraded msmtp (1.8.3-1 -> 1.8.4-1)
[2019-05-17 10:31] [ALPM] upgraded nodejs (11.14.0-1 -> 11.15.0-1)
[2019-05-17 10:31] [ALPM] upgraded okular (19.04.0-1 -> 19.04.1-1)
[2019-05-17 10:31] [ALPM] upgraded oniguruma (6.9.1-1 -> 6.9.2-1)
[2019-05-17 10:31] [ALPM] upgraded perl-ffi-checklib (0.23-1 -> 0.24-1)
[2019-05-17 10:31] [ALPM] upgraded perl-alien-build (1.68-1 -> 1.69-1)
[2019-05-17 10:31] [ALPM] warning: /etc/php/php.ini installed as /etc/php/php.ini.pacnew
[2019-05-17 10:31] [ALPM] upgraded php (7.3.4-2 -> 7.3.5-1)
[2019-05-17 10:31] [ALPM] upgraded php-apache (7.3.4-2 -> 7.3.5-1)
[2019-05-17 10:31] [ALPM] upgraded pulseeffects (4.5.9-1 -> 4.6.0-1)
[2019-05-17 10:31] [ALPM] upgraded pyqt5-common (5.12.1-1 -> 5.12.2-1)
[2019-05-17 10:31] [ALPM] upgraded python-peewee (3.9.4-1 -> 3.9.5-1)
[2019-05-17 10:31] [ALPM] upgraded python-pexpect (4.6.0-2 -> 4.7.0-1)
[2019-05-17 10:31] [ALPM] upgraded python-psutil (5.6.1-1 -> 5.6.2-1)
[2019-05-17 10:31] [ALPM] upgraded python-sip-pyqt5 (4.19.16-1 -> 4.19.17-1)
[2019-05-17 10:31] [ALPM] warning: directory permissions differ on /usr/lib/python3.7/site-packages/PyQt5/__pycache__/
filesystem: 740  package: 755
[2019-05-17 10:31] [ALPM] upgraded python-pyqt5 (5.12.1-1 -> 5.12.2-1)
[2019-05-17 10:31] [ALPM] upgraded python-pysocks (1.6.8-2 -> 1.6.8-3)
[2019-05-17 10:31] [ALPM] upgraded python-urllib3 (1.24.2-1 -> 1.25.2-1)
[2019-05-17 10:31] [ALPM] upgraded python-werkzeug (0.15.1-1 -> 0.15.2-1)
[2019-05-17 10:31] [ALPM] upgraded python2-pbr (5.1.3-1 -> 5.2.0-1)
[2019-05-17 10:31] [ALPM] upgraded python2-pexpect (4.6.0-2 -> 4.7.0-1)
[2019-05-17 10:31] [ALPM] upgraded python2-psutil (5.6.1-1 -> 5.6.2-1)
[2019-05-17 10:31] [ALPM] upgraded python2-pygments (2.3.1-1 -> 2.4.0-1)
[2019-05-17 10:31] [ALPM] upgraded python2-sip-pyqt5 (4.19.16-1 -> 4.19.17-1)
[2019-05-17 10:31] [ALPM] upgraded python2-pyqt5 (5.12.1-1 -> 5.12.2-1)
[2019-05-17 10:31] [ALPM] upgraded python2-pysocks (1.6.8-2 -> 1.6.8-3)
[2019-05-17 10:31] [ALPM] upgraded python2-urllib3 (1.24.2-1 -> 1.25.2-1)
[2019-05-17 10:31] [ALPM] upgraded qpdf (8.4.0-1 -> 8.4.1-1)
[2019-05-17 10:31] [ALPM] upgraded qt4 (4.8.7-28 -> 4.8.7-29.1)
[2019-05-17 10:31] [ALPM-SCRIPTLET] >>> NOTE, QT4 has been deprecated and will no longer be supported by Manjaro.
[2019-05-17 10:31] [ALPM-SCRIPTLET]     
[2019-05-17 10:31] [ALPM-SCRIPTLET]     Please consider removing old applications still depending on qt4.
[2019-05-17 10:31] [ALPM-SCRIPTLET]     If still needed Qt4 can be compiled from the AUR.
[2019-05-17 10:31] [ALPM-SCRIPTLET]     
[2019-05-17 10:31] [ALPM] upgraded qt5-webengine (5.12.3-1 -> 5.12.3-2)
[2019-05-17 10:31] [ALPM] upgraded qtcreator (4.9.0-1 -> 4.9.0-3)
[2019-05-17 10:31] [ALPM] warning: /etc/speech-dispatcher/speechd.conf installed as /etc/speech-dispatcher/speechd.conf.pacnew
[2019-05-17 10:31] [ALPM] upgraded speech-dispatcher (0.9.0-1 -> 0.9.1-1)
[2019-05-17 10:31] [ALPM] upgraded subversion (1.11.1-1 -> 1.12.0-1)
[2019-05-17 10:31] [ALPM] upgraded systemd-sysvcompat (242.16-1 -> 242.29-1)
[2019-05-17 10:31] [ALPM] upgraded unrar (1:5.7.4-1 -> 1:5.7.5-1)
[2019-05-17 10:31] [ALPM] upgraded vpnc (1:0.5.3.r454.r67-1 -> 1:0.5.3.r458.r73-1)
[2019-05-17 10:31] [ALPM] upgraded youtube-dl (2019.04.24-1 -> 2019.04.30-1)

Theres no general audio package that changed.
So its probably up to deepin or the kernel.

Edit- nvm. There is pulseeffects

@cscs It was pulseeffects . I had to start it and say yes in the notification popup.
That fixed my issue.

After that I removed pulseeffects since I'm not really using it.

Thanks, sorry for bashing out (I get really upset, I guess as anyone else, with breaking upgrades).

I'm happy now, although the pamac package shows as corrupted on install/upgrade. Probably has the wrong PGP on the system. Other users may need this package

Well you didnt share those errors, so I cant say anything about it.

sudo pacman -Syu

what happens?

# pacman -S pamac-gtk
a resolver dependências...
a procurar pacotes em conflito...

Pacotes (3) pamac-cli-7.4.0-1  pamac-common-7.4.0-1  pamac-gtk-7.4.0-1

Tamanho Total da Transferência:  0,53 MiB
Tamanho Total Instalado:         3,36 MiB

:: Continuar a instalação? [S/n] 
:: A obter pacotes...
 pamac-common-7.4.0-1-x86_64               372,2 KiB  1570K/s 00:00 [#####################################] 100%
 pamac-cli-7.4.0-1-x86_64                   49,4 KiB  2,84M/s 00:00 [#####################################] 100%
 pamac-gtk-7.4.0-1-x86_64                  116,8 KiB  2,15M/s 00:00 [#####################################] 100%
(3/3) a verificar chaves no chaveiro                                [#####################################] 100%
(3/3) a verificar integridade dos pacotes                           [#####################################] 100%
erro: pamac-common: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: O ficheiro /var/cache/pacman/pkg/pamac-common-7.4.0-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] 
erro: pamac-cli: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: O ficheiro /var/cache/pacman/pkg/pamac-cli-7.4.0-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] 
erro: pamac-gtk: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: O ficheiro /var/cache/pacman/pkg/pamac-gtk-7.4.0-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] 
erro: falhou ao submeter a transação (pacote inválido ou corrompido (assinatura PGP))
Ocorreram alguns erros, portanto, nenhum pacote foi actualizado.
1 Like

Search is your friend..

2 Likes

sudo pacman-mirrors -f0

...
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist

sudo pacman -Sy archlinux-keyring manjaro-keyring

:: A sincronizar a base de dados de pacotes...
 core está actualizado
 extra está actualizado
 community está actualizado
 multilib está actualizado
 sublime-text está actualizado
atenção: archlinux-keyring-20190123-2 está actualizado -- a reinstalar
atenção: manjaro-keyring-20190512-1 está actualizado -- a reinstalar
a resolver dependências...
a procurar pacotes em conflito...

Pacotes (2) archlinux-keyring-20190123-2  manjaro-keyring-20190512-1

Tamanho Total Instalado:             1,11 MiB
Tamanho de Atualização da Internet:  0,00 MiB

:: Continuar a instalação? [S/n] 
(2/2) a verificar chaves no chaveiro                                [#####################################] 100%
(2/2) a verificar integridade dos pacotes                           [#####################################] 100%
(2/2) a carregar ficheiros dos pacotes                              [#####################################] 100%
(2/2) a verificar conflitos em ficheiros                            [#####################################] 100%
(2/2) a verificar espaço disponível no disco                        [#####################################] 100%
:: A processar modificações do pacote...
(1/2) a reinstalar archlinux-keyring                                [#####################################] 100%
==> A adicionar chaves a partir de archlinux.gpg...
==> A assinar localmente as chaves de confiança no chaveiro...
  -> A assinar localmente a chave D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C...
==> ERRO: D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C não pode ser assinado localmente.
  -> A assinar localmente a chave DDB867B92AA789C165EEFA799B729B06A680C281...
==> ERRO: DDB867B92AA789C165EEFA799B729B06A680C281 não pode ser assinado localmente.
  -> A assinar localmente a chave 684148BB25B49E986A4944C55184252D824B18E8...
==> ERRO: 684148BB25B49E986A4944C55184252D824B18E8 não pode ser assinado localmente.
  -> A assinar localmente a chave 91FFE0700E80619CEB73235CA88E23E377514E00...
==> ERRO: 91FFE0700E80619CEB73235CA88E23E377514E00 não pode ser assinado localmente.
  -> A assinar localmente a chave 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
==> ERRO: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 não pode ser assinado localmente.
  -> A assinar localmente a chave AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> ERRO: AB19265E5D7D20687D303246BA1DFB64FFF979E7 não pode ser assinado localmente.
(2/2) a reinstalar manjaro-keyring                                  [#####################################] 100%
==> A adicionar chaves a partir de manjaro.gpg...
==> A assinar localmente as chaves de confiança no chaveiro...
  -> A assinar localmente a chave B4663188A692DB1E45A98EE95BD96CC4247B52CC...
==> ERRO: B4663188A692DB1E45A98EE95BD96CC4247B52CC não pode ser assinado localmente.
  -> A assinar localmente a chave 76C6E477042BFE985CC220BD9C08A255442FAFF0...
==> ERRO: 76C6E477042BFE985CC220BD9C08A255442FAFF0 não pode ser assinado localmente.
  -> A assinar localmente a chave 7C89F4D439B2BFACF425107B62443D89B35859F8...
==> ERRO: 7C89F4D439B2BFACF425107B62443D89B35859F8 não pode ser assinado localmente.
  -> A assinar localmente a chave 1E7908935AAB9A00D6B47503363DFFFD59152F77...
==> ERRO: 1E7908935AAB9A00D6B47503363DFFFD59152F77 não pode ser assinado localmente.
  -> A assinar localmente a chave 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90...
==> ERRO: 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90 não pode ser assinado localmente.
  -> A assinar localmente a chave 5A97ED6B72418199F0C22B23137C934B5DCB998E...
==> ERRO: 5A97ED6B72418199F0C22B23137C934B5DCB998E não pode ser assinado localmente.
  -> A assinar localmente a chave 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5...
==> ERRO: 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5 não pode ser assinado localmente.
  -> A assinar localmente a chave 39F0EC1AE50B37E5F3196F09DAD3B211663CA268...
==> ERRO: 39F0EC1AE50B37E5F3196F09DAD3B211663CA268 não pode ser assinado localmente.
  -> A assinar localmente a chave 2D14560CDCE6A75BB186DB758238651DDF5E0594...
==> ERRO: 2D14560CDCE6A75BB186DB758238651DDF5E0594 não pode ser assinado localmente.
  -> A assinar localmente a chave 7A443CEE69B6B3777740E258084A7FC0035B1D49...
==> ERRO: 7A443CEE69B6B3777740E258084A7FC0035B1D49 não pode ser assinado localmente.
  -> A assinar localmente a chave F66AD0FF0E57C561615A0901CEE477135C5872B0...
==> ERRO: F66AD0FF0E57C561615A0901CEE477135C5872B0 não pode ser assinado localmente.
  -> A assinar localmente a chave 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
==> ERRO: 35B4FF23EA9477582C2A0AF12B80869C5C0102A6 não pode ser assinado localmente.
  -> A assinar localmente a chave E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
==> ERRO: E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E não pode ser assinado localmente.
  -> A assinar localmente a chave 74C2F2CC05A0AB7D859839938934292D604F8BA2...
==> ERRO: 74C2F2CC05A0AB7D859839938934292D604F8BA2 não pode ser assinado localmente.
  -> A assinar localmente a chave 77DC01C9971AC3C39A0626F72C089F09AC97B894...
==> ERRO: 77DC01C9971AC3C39A0626F72C089F09AC97B894 não pode ser assinado localmente.
  -> A assinar localmente a chave 16DC688DF3EECC72323954237EC47C82A42D53A2...
==> ERRO: 16DC688DF3EECC72323954237EC47C82A42D53A2 não pode ser assinado localmente.
  -> A assinar localmente a chave 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA...
==> ERRO: 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA não pode ser assinado localmente.
  -> A assinar localmente a chave 22C903DE964E6FE321656E318DB9F8C18DF53602...
==> ERRO: 22C903DE964E6FE321656E318DB9F8C18DF53602 não pode ser assinado localmente.
erro: comando não executado corretamente
:: A correr os hooks de pós-instalação...
(1/1) Arming ConditionNeedsUpdate...

sudo pacman-key --populate archlinux manjaro

==> A adicionar chaves a partir de archlinux.gpg...
==> A adicionar chaves a partir de manjaro.gpg...
==> A assinar localmente as chaves de confiança no chaveiro...
  -> A assinar localmente a chave B4663188A692DB1E45A98EE95BD96CC4247B52CC...
==> ERRO: B4663188A692DB1E45A98EE95BD96CC4247B52CC não pode ser assinado localmente.
  -> A assinar localmente a chave D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C...
==> ERRO: D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C não pode ser assinado localmente.
  -> A assinar localmente a chave 76C6E477042BFE985CC220BD9C08A255442FAFF0...
==> ERRO: 76C6E477042BFE985CC220BD9C08A255442FAFF0 não pode ser assinado localmente.
  -> A assinar localmente a chave 7C89F4D439B2BFACF425107B62443D89B35859F8...
==> ERRO: 7C89F4D439B2BFACF425107B62443D89B35859F8 não pode ser assinado localmente.
  -> A assinar localmente a chave 1E7908935AAB9A00D6B47503363DFFFD59152F77...
==> ERRO: 1E7908935AAB9A00D6B47503363DFFFD59152F77 não pode ser assinado localmente.
  -> A assinar localmente a chave 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90...
==> ERRO: 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90 não pode ser assinado localmente.
  -> A assinar localmente a chave DDB867B92AA789C165EEFA799B729B06A680C281...
==> ERRO: DDB867B92AA789C165EEFA799B729B06A680C281 não pode ser assinado localmente.
  -> A assinar localmente a chave 5A97ED6B72418199F0C22B23137C934B5DCB998E...
==> ERRO: 5A97ED6B72418199F0C22B23137C934B5DCB998E não pode ser assinado localmente.
  -> A assinar localmente a chave 684148BB25B49E986A4944C55184252D824B18E8...
==> ERRO: 684148BB25B49E986A4944C55184252D824B18E8 não pode ser assinado localmente.
  -> A assinar localmente a chave 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5...
==> ERRO: 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5 não pode ser assinado localmente.
  -> A assinar localmente a chave 39F0EC1AE50B37E5F3196F09DAD3B211663CA268...
==> ERRO: 39F0EC1AE50B37E5F3196F09DAD3B211663CA268 não pode ser assinado localmente.
  -> A assinar localmente a chave 2D14560CDCE6A75BB186DB758238651DDF5E0594...
==> ERRO: 2D14560CDCE6A75BB186DB758238651DDF5E0594 não pode ser assinado localmente.
  -> A assinar localmente a chave 7A443CEE69B6B3777740E258084A7FC0035B1D49...
==> ERRO: 7A443CEE69B6B3777740E258084A7FC0035B1D49 não pode ser assinado localmente.
  -> A assinar localmente a chave F66AD0FF0E57C561615A0901CEE477135C5872B0...
==> ERRO: F66AD0FF0E57C561615A0901CEE477135C5872B0 não pode ser assinado localmente.
  -> A assinar localmente a chave 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
==> ERRO: 35B4FF23EA9477582C2A0AF12B80869C5C0102A6 não pode ser assinado localmente.
  -> A assinar localmente a chave E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
==> ERRO: E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E não pode ser assinado localmente.
  -> A assinar localmente a chave 74C2F2CC05A0AB7D859839938934292D604F8BA2...
==> ERRO: 74C2F2CC05A0AB7D859839938934292D604F8BA2 não pode ser assinado localmente.
  -> A assinar localmente a chave 77DC01C9971AC3C39A0626F72C089F09AC97B894...
==> ERRO: 77DC01C9971AC3C39A0626F72C089F09AC97B894 não pode ser assinado localmente.
  -> A assinar localmente a chave 16DC688DF3EECC72323954237EC47C82A42D53A2...
==> ERRO: 16DC688DF3EECC72323954237EC47C82A42D53A2 não pode ser assinado localmente.
  -> A assinar localmente a chave 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA...
==> ERRO: 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA não pode ser assinado localmente.
  -> A assinar localmente a chave 91FFE0700E80619CEB73235CA88E23E377514E00...
==> ERRO: 91FFE0700E80619CEB73235CA88E23E377514E00 não pode ser assinado localmente.
  -> A assinar localmente a chave 22C903DE964E6FE321656E318DB9F8C18DF53602...
==> ERRO: 22C903DE964E6FE321656E318DB9F8C18DF53602 não pode ser assinado localmente.
  -> A assinar localmente a chave 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
==> ERRO: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 não pode ser assinado localmente.
  -> A assinar localmente a chave AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> ERRO: AB19265E5D7D20687D303246BA1DFB64FFF979E7 não pode ser assinado localmente.

sudo pacman-key --refresh-keys

gpg: refreshing 132 keys from hkp://pool.sks-keyservers.net
gpg: key E62F853100F0D0F0: 89 signatures not checked due to missing keys
...
gpg: Número total processado: 132
gpg:              não modificados: 131
gpg:         novas assinaturas: 1
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:  22  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:  22  signed:  85  trust: 1-, 0q, 0n, 21m, 0f, 0u
gpg: depth: 2  valid:  75  signed:  16  trust: 75-, 0q, 0n, 0m, 0f, 0u
gpg: proxima verificação da base de dados de confiança a ....

sudo rm -f /var/cache/pacman/pkg/pamac*

sudo pacman -S pamac-gtk

a resolver dependências...
a procurar pacotes em conflito...

Pacotes (3) pamac-cli-7.4.0-1  pamac-common-7.4.0-1  pamac-gtk-7.4.0-1

Tamanho Total da Transferência:  0,53 MiB
Tamanho Total Instalado:         3,36 MiB

:: Continuar a instalação? [S/n] 
:: A obter pacotes...
 pamac-common-7.4.0-1-x86_64               372,2 KiB  1344K/s 00:00 [#####################################] 100%
 pamac-cli-7.4.0-1-x86_64                   49,4 KiB  2,84M/s 00:00 [#####################################] 100%
 pamac-gtk-7.4.0-1-x86_64                  116,8 KiB  2,15M/s 00:00 [#####################################] 100%
(3/3) a verificar chaves no chaveiro                                [#####################################] 100%
(3/3) a verificar integridade dos pacotes                           [#####################################] 100%
erro: pamac-common: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: O ficheiro /var/cache/pacman/pkg/pamac-common-7.4.0-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] 
erro: pamac-cli: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: O ficheiro /var/cache/pacman/pkg/pamac-cli-7.4.0-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] 
erro: pamac-gtk: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: O ficheiro /var/cache/pacman/pkg/pamac-gtk-7.4.0-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] 
erro: falhou ao submeter a transação (pacote inválido ou corrompido (assinatura PGP))
Ocorreram alguns erros, portanto, nenhum pacote foi actualizado.

Here we are again...

PS:
I dont see Helmut Stult as a contributer to pamac in https://gitlab.manjaro.org/applications/pamac/project_members so it doesn't seem a good idea to trust this PGP key.

|| My help request still stands. ||

I have take a look at what is seems the Helmut Stult (schinfo) home page and he says he his a member of the Manjaro Team.

I try to verify this from an Manjaro official source like this one but I cannot find any Helmut Stult.

It would be nice to have an Manjaro official source where we could find the Manjaro team members.
It would be important in order to verify trust (PGP) in cases like this one that I'm having.

Either way I have done the insecure thing and decided that Helmut Stult is in fact member of the Manjaro Team (anyone can say that on his homepage, but...).

So I added his PGP key (that is on https://schinfo.de/) with

# gpg --recv-key F66AD0FF0E57C561615A0901CEE477135C5872B0

After this, when I do

# pacman -S pamac-gtk

I still get the same error.

So something is really wrong.

1 Like

I believe the error is that

# pacman-key --populate archlinux manjaro

is not signing locally some keys (the keys are shown with an ERRO message above)

Please read the rest of the linked thread as the last sentence of the linked post suggests.

It would also be nice if you could post output in English, e.g.

LANG=C sudo pacman -Syu

or

LC_ALL=C sudo pacman -Syu

@jonathon There is no problem with pacman -Syyu because I have remove the package pamac.

When I do LANG=C sudo pacman -Syu I get:

resolving dependencies...
looking for conflicting packages...

Packages (3) pamac-cli-7.4.0-1  pamac-common-7.4.0-1  pamac-gtk-7.4.0-1

Total Download Size:   0.53 MiB
Total Installed Size:  3.36 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 pamac-common-7.4.0-1-x86_64               372.2 KiB  1410K/s 00:00 [#####################################] 100%
 pamac-cli-7.4.0-1-x86_64                   49.4 KiB  2.84M/s 00:00 [#####################################] 100%
 pamac-gtk-7.4.0-1-x86_64                  116.8 KiB  2.85M/s 00:00 [#####################################] 100%
(3/3) checking keys in keyring                                      [#####################################] 100%
(3/3) checking package integrity                                    [#####################################] 100%
error: pamac-common: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: File /var/cache/pacman/pkg/pamac-common-7.4.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: pamac-cli: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: File /var/cache/pacman/pkg/pamac-cli-7.4.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: pamac-gtk: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: File /var/cache/pacman/pkg/pamac-gtk-7.4.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

And LANG=C pacman-key --populate archlinux manjaro gives:

=> Appending keys from archlinux.gpg...
==> Appending keys from manjaro.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC...
==> ERROR: B4663188A692DB1E45A98EE95BD96CC4247B52CC could not be locally signed.
  -> Locally signing key D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C...
==> ERROR: D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C could not be locally signed.
  -> Locally signing key 76C6E477042BFE985CC220BD9C08A255442FAFF0...
==> ERROR: 76C6E477042BFE985CC220BD9C08A255442FAFF0 could not be locally signed.
  -> Locally signing key 7C89F4D439B2BFACF425107B62443D89B35859F8...
==> ERROR: 7C89F4D439B2BFACF425107B62443D89B35859F8 could not be locally signed.
  -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77...
==> ERROR: 1E7908935AAB9A00D6B47503363DFFFD59152F77 could not be locally signed.
  -> Locally signing key 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90...
==> ERROR: 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90 could not be locally signed.
  -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
==> ERROR: DDB867B92AA789C165EEFA799B729B06A680C281 could not be locally signed.
  -> Locally signing key 5A97ED6B72418199F0C22B23137C934B5DCB998E...
==> ERROR: 5A97ED6B72418199F0C22B23137C934B5DCB998E could not be locally signed.
  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
==> ERROR: 684148BB25B49E986A4944C55184252D824B18E8 could not be locally signed.
  -> Locally signing key 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5...
==> ERROR: 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5 could not be locally signed.
  -> Locally signing key 39F0EC1AE50B37E5F3196F09DAD3B211663CA268...
==> ERROR: 39F0EC1AE50B37E5F3196F09DAD3B211663CA268 could not be locally signed.
  -> Locally signing key 2D14560CDCE6A75BB186DB758238651DDF5E0594...
==> ERROR: 2D14560CDCE6A75BB186DB758238651DDF5E0594 could not be locally signed.
  -> Locally signing key 7A443CEE69B6B3777740E258084A7FC0035B1D49...
==> ERROR: 7A443CEE69B6B3777740E258084A7FC0035B1D49 could not be locally signed.
  -> Locally signing key F66AD0FF0E57C561615A0901CEE477135C5872B0...
==> ERROR: F66AD0FF0E57C561615A0901CEE477135C5872B0 could not be locally signed.
  -> Locally signing key 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
==> ERROR: 35B4FF23EA9477582C2A0AF12B80869C5C0102A6 could not be locally signed.
  -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
==> ERROR: E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E could not be locally signed.
  -> Locally signing key 74C2F2CC05A0AB7D859839938934292D604F8BA2...
==> ERROR: 74C2F2CC05A0AB7D859839938934292D604F8BA2 could not be locally signed.
  -> Locally signing key 77DC01C9971AC3C39A0626F72C089F09AC97B894...
==> ERROR: 77DC01C9971AC3C39A0626F72C089F09AC97B894 could not be locally signed.
  -> Locally signing key 16DC688DF3EECC72323954237EC47C82A42D53A2...
==> ERROR: 16DC688DF3EECC72323954237EC47C82A42D53A2 could not be locally signed.
  -> Locally signing key 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA...
==> ERROR: 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA could not be locally signed.
  -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
==> ERROR: 91FFE0700E80619CEB73235CA88E23E377514E00 could not be locally signed.
  -> Locally signing key 22C903DE964E6FE321656E318DB9F8C18DF53602...
==> ERROR: 22C903DE964E6FE321656E318DB9F8C18DF53602 could not be locally signed.
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
==> ERROR: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 could not be locally signed.
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> ERROR: AB19265E5D7D20687D303246BA1DFB64FFF979E7 could not be locally signed.

# LANG=C pacman -Syy archlinux-keyring manjaro-keyring

:: Synchronizing package databases...
 core                                      151.1 KiB   889K/s 00:00 [#####################################] 100%
 extra                                    1807.1 KiB  1838K/s 00:01 [#####################################] 100%
 community                                   5.2 MiB  1433K/s 00:04 [#####################################] 100%
 multilib                                  184.0 KiB  1373K/s 00:00 [#####################################] 100%
 sublime-text                             1824.0   B  0.00B/s 00:00 [#####################################] 100%
 sublime-text.sig                          543.0   B  0.00B/s 00:00 [#####################################] 100%
warning: archlinux-keyring-20190123-2 is up to date -- reinstalling
warning: manjaro-keyring-20190512-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (2) archlinux-keyring-20190123-2  manjaro-keyring-20190512-1

Total Installed Size:  1.11 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(2/2) checking keys in keyring                                      [#####################################] 100%
(2/2) checking package integrity                                    [#####################################] 100%
(2/2) loading package files                                         [#####################################] 100%
(2/2) checking for file conflicts                                   [#####################################] 100%
(2/2) checking available disk space                                 [#####################################] 100%
:: Processing package changes...
(1/2) reinstalling archlinux-keyring                                [#####################################] 100%
==> Appending keys from archlinux.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C...
==> ERROR: D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C could not be locally signed.
  -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
==> ERROR: DDB867B92AA789C165EEFA799B729B06A680C281 could not be locally signed.
  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
==> ERROR: 684148BB25B49E986A4944C55184252D824B18E8 could not be locally signed.
  -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
==> ERROR: 91FFE0700E80619CEB73235CA88E23E377514E00 could not be locally signed.
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
==> ERROR: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 could not be locally signed.
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> ERROR: AB19265E5D7D20687D303246BA1DFB64FFF979E7 could not be locally signed.
(2/2) reinstalling manjaro-keyring                                  [#####################################] 100%
==> Appending keys from manjaro.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC...
==> ERROR: B4663188A692DB1E45A98EE95BD96CC4247B52CC could not be locally signed.
  -> Locally signing key 76C6E477042BFE985CC220BD9C08A255442FAFF0...
==> ERROR: 76C6E477042BFE985CC220BD9C08A255442FAFF0 could not be locally signed.
  -> Locally signing key 7C89F4D439B2BFACF425107B62443D89B35859F8...
==> ERROR: 7C89F4D439B2BFACF425107B62443D89B35859F8 could not be locally signed.
  -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77...
==> ERROR: 1E7908935AAB9A00D6B47503363DFFFD59152F77 could not be locally signed.
  -> Locally signing key 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90...
==> ERROR: 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90 could not be locally signed.
  -> Locally signing key 5A97ED6B72418199F0C22B23137C934B5DCB998E...
==> ERROR: 5A97ED6B72418199F0C22B23137C934B5DCB998E could not be locally signed.
  -> Locally signing key 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5...
==> ERROR: 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5 could not be locally signed.
  -> Locally signing key 39F0EC1AE50B37E5F3196F09DAD3B211663CA268...
==> ERROR: 39F0EC1AE50B37E5F3196F09DAD3B211663CA268 could not be locally signed.
  -> Locally signing key 2D14560CDCE6A75BB186DB758238651DDF5E0594...
==> ERROR: 2D14560CDCE6A75BB186DB758238651DDF5E0594 could not be locally signed.
  -> Locally signing key 7A443CEE69B6B3777740E258084A7FC0035B1D49...
==> ERROR: 7A443CEE69B6B3777740E258084A7FC0035B1D49 could not be locally signed.
  -> Locally signing key F66AD0FF0E57C561615A0901CEE477135C5872B0...
==> ERROR: F66AD0FF0E57C561615A0901CEE477135C5872B0 could not be locally signed.
  -> Locally signing key 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
==> ERROR: 35B4FF23EA9477582C2A0AF12B80869C5C0102A6 could not be locally signed.
  -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
==> ERROR: E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E could not be locally signed.
  -> Locally signing key 74C2F2CC05A0AB7D859839938934292D604F8BA2...
==> ERROR: 74C2F2CC05A0AB7D859839938934292D604F8BA2 could not be locally signed.
  -> Locally signing key 77DC01C9971AC3C39A0626F72C089F09AC97B894...
==> ERROR: 77DC01C9971AC3C39A0626F72C089F09AC97B894 could not be locally signed.
  -> Locally signing key 16DC688DF3EECC72323954237EC47C82A42D53A2...
==> ERROR: 16DC688DF3EECC72323954237EC47C82A42D53A2 could not be locally signed.
  -> Locally signing key 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA...
==> ERROR: 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA could not be locally signed.
  -> Locally signing key 22C903DE964E6FE321656E318DB9F8C18DF53602...
==> ERROR: 22C903DE964E6FE321656E318DB9F8C18DF53602 could not be locally signed.
error: command failed to execute correctly
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...

Semi off-topic: if you add a key to the gpg keyring, it isn't automatically added to the pacman keyring. This is done with pacman-key --recv-key.

However you shouldn't need to do that anyway.

And Manjaro team members are listed here, including Helmut:
https://forum.manjaro.org/g/Manjaro-Team

Thanks @torvic . After adding the Helmut key with pacman-key I still get the same error on installing pamac

All I did to continue updating is uninstall pamac :slightly_frowning_face: and updating went ok then install pamac :wink:

sudo pacman -R pamac-cli pamac-gtk pamac-common
sudo pacman -Syyu
sudo pacman -S pamac-cli pamac-gtk pamac-common

@gushock

To me installing pamac-cli pamac-gtk pamac-common doesn't work

I notice you decided to change mirrors without doing pacman -Syyu .. which isnt going to help.

Maybe try a complete reset for gpg
I am not sure if this is correct, so do your research or wait for others to verify.

  • Delete/rename /etc/pacman.d/gnupg
  • Initialize (both) keyrings (per standard tutorial)
  • Run pacman -Syy

I believe some command is missing (I have not RTFM and I forget easily...), like add the missing key, but I suggest some search on this issue.

1 Like

I don't have the same issue on my other Manjaro PC.

So I'm thinking what I did different on this PC. And I have done something that maybe related with this problem.

What I did was:
Following some askubuntu post or something that I have end up removing my password keyrings of gnome-keyring. I believe I did remove something with the keyrings on /home/daniel/.local/share/keyrings/, can't find the exact page on my browser history that I did follow.

So, right now:
ls -l /home/daniel/.local/share/keyrings gives me this:

-rw-r--r-- 1 daniel daniel    5 abr 25 11:48 default
-rw------- 1 daniel daniel 2573 mai 18 16:03 login.keyring

Is there something wrong with this?

Can my problem be relate with this thing that I have done to gnome-keyring?

I also have set this variable

PYTHON_KEYRING_BACKEND=keyring.backends.SecretService.Keyring

in my /etc/enviroment file, in the meantime.

Maybe my problem is related with some of those things

Also, is this correct? Should I do this?

There is your issue!
Doing random things on System Settings/Configuration is not a smart thing, if you want to maintain a working system.

Smart support personnel respond with "Re-install" and they are done!
I suggest you investigate, so you gain knowledge and experience.

I can't help finding something on your system, which you don't even remember. Sorry :confounded:
Maybe one of the forum experts can guess what is missing.

1 Like