After Updating - Phone is on Minimum Brightness

This is a follow-up to: After Updating - Phone Boots but no GUI

I’ve reinstalled my operating system 3-4 times since getting it, as I thought I had a problem with the screen no longer turning on whenever I did updates.

I just realized today, however. My screen isn’t dying at all, the screen does turn on, the brightness is just so low that it’s impossible to use. Under the right lighting I can just about see the time and swipe up the keypad for the passcode, but that’s it.

Whenever I update my phone, my brightness goes down to the minimum. Now that I know the issue, I fixed it by blindly unlocking, typing in the passcode, pulling down the menu, and spending 2 minutes swiping randomly left to right until I managed to get the brightness slider. :laughing:

Could the minimum brightness be updated, so users are never in a position the phone might become almost unusable?

On standby to provide more information if required.

1 Like

Does this happen if you flash the latest beta and update? I believe the latest is Beta 4.

If so, please test if it happens if you flash the latest dev image, since a lot of development has gone into fixing these little paper cuts recently.

1 Like

I’ve used all the following, and each had a similar problem:

  • Manjaro-ARM-plasma-mobile-pinephone-factory-20210112.img.xz
  • Manjaro-ARM-plasma-mobile-pinephone-beta4.img.xz
  • Manjaro-ARM-plasma-mobile-pinephone-20210510.img.xz
  • Manjaro-ARM-plasma-mobile-pinephone-20210526.img.xz

I’ll try the latest dev image today and report back if the problem occurs again.

1 Like

Just a heads-up, I just installed Manjaro-ARM-plasma-mobile-pinephone-dev-20210530.img.xz, and can vouch the issue seems it may be resolved.

Previously the issue started on the next restart after doing the updates, but the phone is perfectly usable now. ^-^

I’ll drop another message only if the problem occurs again, meanwhile I did have some other issues, but I’ll make separate posts for them.

1 Like

That’s great to hear. :slight_smile:

Oh, actually on the side, could it still be worth reconsidering the minimum brightness of the device in general?
Or at least limiting it until an advanced option is toggled to allow more flexibility?

I recall the first time I ever used the phone as well (exploring settings etc.) I screwed myself over when I was testing the minimum and maximum brightness. ^-^’

I agree. Giving the user the ability to set the Brightness to 0, is not great design.

Seems it was fixed at some point, but a newer update broke it again.

2 Likes

Ahh… that’s unfortunate…
Sorry about that, it seems I judged too soon.

Usually, it happens right after updates, but now the screen is dead again. It occurred after a restart, but this time after uninstalling kweather. (Uninstalled, reinstalled, then uninstalled again.)


All I’ve done on the phone is change the theme related settings to be Breeze Dark and explored widgets, and executed the following commands:

# setup script
sudo hostnamectl set-hostname "pinelopi"
sudo pacman -Rs --noconfirm buho calindori keysmith koko kongress krecorder ktrip maui-clip psensor telegram-desktop vvave
sudo pacman -Syyu --noconfirm
pacman -Qtdq | sudo pacman -Rns --noconfirm -
sudo pacman -S --noconfirm git htop neofetch nvm sl
echo 'source /usr/share/nvm/init-nvm.sh' >> ~/.bashrc
source ~/.bashrc
nvm install --lts
npm i -g tldr
sudo flatpak install -y flathub com.github.iwalton3.jellyfin-media-player com.tutanota.Tutanota
sudo shutdown -r now

# changed theme to breeze dark
# changed updates to stable mode, then did an update available in discover
# The phone worked with moderate use fine, browser/apps/restarts/etc

# added widget for weather (had issues so uninstalled)

# other commands
htop # to kill kweather
sudo pacman -Rs kweather
sudo shutdown -r now
sudo pacman -S kweather
sudo shutdown -r now
sudo pacman -Rs kweather # issue persisted so removed
sudo shutdown -r now # screen is dead

This sums up the life my phone had before running into this problem again.

I also had this issue after an upgrade ~14d ago. I flashed a beta some months ago and upgrader from time to time.

Last week I downloaded a nightly image and everthing was fine, but an update brought back the faulty behaviour.

BTW: Don’t know if this is related: on my pinephone the proximity sensor and led rubber thing is missing (can’t post related links yet).

Here is an issue about sth similar in mobian: Proximity sensor misbehaving (#3) · Issues · Mobian / Mobian Issues · GitLab

I tried disabling /usr/share/lib/udev/rules.d/10-proximity.rules but it didn’t help.

EDIT: And here (ThreadId 12481 on pine 64 forums (still can’t link there :roll_eyes:) is a thread about the rubber thingy, which is missing on my phone (maybe I lost it, when changing the motherboard).

This isn’t a manjaro specific issue, as I’ve tried GloDroid which also allows for the brightness to be set to 0. It seems to be a kernel related thing which needs to be solved once and for all.

Not sure if this is exactly the same.
I tried to update today the factory release. Last time it worked.

This time the display got dark (or brightness to 0 ?) and after an enforced reboot I get the KDE icon for a while and then darkness.

Is this related or maybe a separate issue ?