After update to 5.8 Kernel X won't start

Just upgraded my kernel to 5.8 from 5.6 and am unable to boot properly.

I can get into a tty terminal and from there I tried startx but I get a set of errors telling me:

Failed to set IOPL for for I/O (Operation not permitted)
Fatal server error: no screens found
Server terminated with error (1)

I’m not sure where to go from here.

I am using an XPS 15 9560 which has a Nvidia optimus set up. The drivers seem to be fine:

Running mhwd -li gives video-hybrid-intel-nvidia-440xx-prime
(Although there is a warning about no installed USB configs)
And cat /etc/modules-load.d/*.conf | grep nvidia gives

Deleting /etc/X11/xorg.conf and restarting a couple of times seems to have fixed the problem.

No idea why that worked, but maybe it will help someone else getting stuck at the same place.

I have the same problem as Loganrah. I installed the 5.8 kernel (it was with version 5.4.57-1).

I started the computer with this kernel and after a while only the black screen with a cursor appeared.
I didn’t see any activity on the hard disk anymore so I reboot again with version 5.4 and it worked fine, so I guess the problem is the new kernel.

This is the information from my computer:

OS: Manjaro Linux x86_64 
Kernel: 5.4.57-1-MANJARO 
Packages: 1865 (pacman) 
Shell: bash 5.0.18 
Resolution: 1440x900 
DE: Xfce 4.14 
WM: Xfwm4 
WM Theme: McOS-MJV-Light-Xfce 
Theme: McOS-MJV-Light-Xfce [GTK2], Zukitwo-Wise [GTK3] 
Icons: Tela [GTK2], Faenza-Dark [GTK3] 
Terminal: tilix 
CPU: AMD FX-4100 (4) @ 3.600GHz 
GPU: NVIDIA GeForce 8400 GS Rev. 3 
Memory: 2813MiB / 7946MiB 

I hope that this information will be useful to you in finding the problem and its solution.


Try to see if you can get a terminal at the blinking cursor by pressing Ctrl + Alt + F2 (or F3, F4, F5 or F6). That should open a tty terminal, which lets you investigate and shows that the kernel is starting up correctly (as it was in my case, the problem was with X11 not the kernel). You may need to use the function button, if you have one, as I did.